Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455456 - media-libs/phonon-gstreamer fails with gentoo-multilib - /usr/lib64/libphonon.so.4.6.0: could not read symbols: File in wrong format
Summary: media-libs/phonon-gstreamer fails with gentoo-multilib - /usr/lib64/libphonon...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 445666 (view as bug list)
Depends on:
Blocks: portage-multilib
  Show dependency tree
 
Reported: 2013-02-04 15:26 UTC by salamanderrake
Modified: 2013-03-10 21:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
My emerge --info (emerge--info.txt,5.13 KB, text/plain)
2013-02-05 03:08 UTC, salamanderrake
Details
My build.log (phonon-gstreamer_build.log.txt,69 bytes, text/plain)
2013-02-05 03:08 UTC, salamanderrake
Details

Note You need to log in before you can comment on or make changes to this bug.
Description salamanderrake 2013-02-04 15:26:00 UTC
phonon-gstreamer fails to build using gentoo-multilib.

Reproducible: Always




Linking CXX shared module phonon_gstreamer.so
cd /var/tmp/portage/media-libs/phonon-gstreamer-4.6.2-r1/work/phonon-gstreamer-4.6.2_build/gstreamer && /usr/bin/cmake -E cmake_link_script CMakeFiles/phonon_gstreamer.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++  -fPIC -march=native  -O2 -pipe -m32  -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-check-new -fno-common -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc  -Wl,-O1 -Wl,--as-needed -m32 -shared -Wl,-soname,phonon_gstreamer.so -o phonon_gstreamer.so CMakeFiles/phonon_gstreamer.dir/phonon_gstreamer_automoc.cpp.o CMakeFiles/phonon_gstreamer.dir/abstractrenderer.cpp.o CMakeFiles/phonon_gstreamer.dir/audiodataoutput.cpp.o CMakeFiles/phonon_gstreamer.dir/audioeffect.cpp.o CMakeFiles/phonon_gstreamer.dir/audiooutput.cpp.o CMakeFiles/phonon_gstreamer.dir/backend.cpp.o CMakeFiles/phonon_gstreamer.dir/debug.cpp.o CMakeFiles/phonon_gstreamer.dir/devicemanager.cpp.o CMakeFiles/phonon_gstreamer.dir/effect.cpp.o CMakeFiles/phonon_gstreamer.dir/effectmanager.cpp.o CMakeFiles/phonon_gstreamer.dir/gsthelper.cpp.o CMakeFiles/phonon_gstreamer.dir/medianode.cpp.o CMakeFiles/phonon_gstreamer.dir/mediaobject.cpp.o CMakeFiles/phonon_gstreamer.dir/pipeline.cpp.o CMakeFiles/phonon_gstreamer.dir/plugininstaller.cpp.o CMakeFiles/phonon_gstreamer.dir/qwidgetvideosink.cpp.o CMakeFiles/phonon_gstreamer.dir/streamreader.cpp.o CMakeFiles/phonon_gstreamer.dir/videowidget.cpp.o CMakeFiles/phonon_gstreamer.dir/volumefadereffect.cpp.o CMakeFiles/phonon_gstreamer.dir/widgetrenderer.cpp.o CMakeFiles/phonon_gstreamer.dir/videodataoutput.cpp.o CMakeFiles/phonon_gstreamer.dir/glrenderer.cpp.o CMakeFiles/phonon_gstreamer.dir/x11renderer.cpp.o /usr/lib32/qt4/libQtCore.so -lpthread /usr/lib32/qt4/libQtGui.so /usr/lib64/libphonon.so.4.6.0 -lgstreamer-0.10 -lgstbase-0.10 -lgstinterfaces-0.10 -lgstvideo-0.10 -lgstaudio-0.10 -lgstpbutils-0.10 -lglib-2.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -lgstapp-0.10 /usr/lib32/qt4/libQtOpenGL.so -lGL -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lgstapp-0.10 /usr/lib32/qt4/libQtOpenGL.so -lGL -Wl,-rpath,/usr/lib32/qt4::::::::::: 
/usr/lib64/libphonon.so.4.6.0: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[2]: *** [gstreamer/phonon_gstreamer.so] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/phonon-gstreamer-4.6.2-r1/work/phonon-gstreamer-4.6.2_build'
make[1]: *** [gstreamer/CMakeFiles/phonon_gstreamer.dir/all] Error 2
make[1]: Leaving directory `/var/tmp/portage/media-libs/phonon-gstreamer-4.6.2-r1/work/phonon-gstreamer-4.6.2_build'
make: *** [all] Error 2
 * ERROR: media-libs/phonon-gstreamer-4.6.2-r1 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=media-libs/phonon-gstreamer-4.6.2-r1'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/phonon-gstreamer-4.6.2-r1'`.
 * The complete build log is located at '/var/log/portage/media-libs:phonon-gstreamer-4.6.2-r1:20130204-152216.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/media-libs/phonon-gstreamer-4.6.2-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/phonon-gstreamer-4.6.2-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/phonon-gstreamer-4.6.2-r1/work/phonon-gstreamer-4.6.2_build'
 * S: '/var/tmp/portage/media-libs/phonon-gstreamer-4.6.2-r1/work/phonon-backend-gstreamer-4.6.2'

>>> Failed to emerge media-libs/phonon-gstreamer-4.6.2-r1, Log file:

>>>  '/var/log/portage/media-libs:phonon-gstreamer-4.6.2-r1:20130204-152216.log'
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-04 19:49:58 UTC
Please attach the complete build log and the output of `emerge --info`.
Comment 2 salamanderrake 2013-02-05 03:08:11 UTC
Created attachment 337972 [details]
My emerge --info
Comment 3 salamanderrake 2013-02-05 03:08:31 UTC
Created attachment 337974 [details]
My build.log
Comment 4 salamanderrake 2013-02-05 06:18:13 UTC
*** Bug 445666 has been marked as a duplicate of this bug. ***
Comment 5 Darragh Bailey 2013-03-09 01:16:50 UTC
Following change to the ebuild allows it to work correctly for gentoo-multilib

--- /usr/portage/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.2-r1.ebuild	2013-03-02 22:01:20.000000000 +0000
+++ phonon-gstreamer/phonon-gstreamer-4.6.2-r2.ebuild	2013-03-09 01:13:37.884958256 +0000
@@ -47,6 +47,7 @@
 src_configure() {
 	local mycmakeargs=(
 		$(cmake-utils_use_with alsa)
+		-DPhonon_DIR=/usr/$(get_libdir)/cmake/phonon/
 	)
 	cmake-utils_src_configure
 }


Ensures it gets the correct version of the cmake config file for phonon.
Comment 6 Michael Palimaka (kensington) gentoo-dev 2013-03-10 10:23:48 UTC
Thanks! Fixed in CVS.

+  10 Mar 2013; Michael Palimaka <kensington@gentoo.org>
+  phonon-gstreamer-4.6.3.ebuild, phonon-gstreamer-9999.ebuild:
+  Fix build with gentoo-multilib thanks to Darragh Bailey
+  <felix@compsoc.nuigalway.ie>, wrt bug #455456.
Comment 7 salamanderrake 2013-03-10 21:24:37 UTC
Thanks.