Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455428 - www-client/firefox-18.0.1 should depend on >=dev-db/sqlite-3.7.14.1
Summary: www-client/firefox-18.0.1 should depend on >=dev-db/sqlite-3.7.14.1
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-04 12:22 UTC by Eliovir
Modified: 2013-06-05 10:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eliovir 2013-02-04 12:22:46 UTC
Updating from www-client/firefox-17.0.1 to www-client/firefox-18.0.1, the configure step failed with this message

checking for sqlite3 >= 3.7.14.1... Requested 'sqlite3 >= 3.7.14.1' but version of SQLite is 3.7.13
configure: error: Library requirements (sqlite3 >= 3.7.14.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

I've got dev-db/sqlite-3.7.13.

Reproducible: Always

Steps to Reproduce:
1. emerge dev-db/sqlite-3.7.13
2. emerge www-client/firefox-18.0.1 (with USE=system-sqlite alsa dbus jit minimal)
3.


Expected Results:  
Dependency must be install dev-db/sqlite >= 3.7.14.1
Comment 1 Sergey Popov gentoo-dev Security 2013-06-05 10:27:38 UTC
dev-db/sqlite:3 slot has minimal version 3.7.16 now, closing as OBSOLETE