Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455208 - Remove sys-firmware/amd-ucode (WAS: sys-firmware/amd-ucode-2012.09.10 - ebuild SRC_URI no longer available)
Summary: Remove sys-firmware/amd-ucode (WAS: sys-firmware/amd-ucode-2012.09.10 - ebuil...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo TreeCleaner Project
URL:
Whiteboard: pending removal: 2013-10-23
Keywords: PMASKED
: 475380 (view as bug list)
Depends on: 485376
Blocks:
  Show dependency tree
 
Reported: 2013-02-02 23:48 UTC by dkrenzel
Modified: 2013-10-21 19:49 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dkrenzel 2013-02-02 23:48:28 UTC
tldr; -- SRC_URI in amd-ucode package is invalid

Installing Version 13 AMD64 into system with Athlon II processor, upon checking after first boot for errors, found this for each of the four cpu cores:

Feb  2 15:51:54 g1 kernel: microcode: failed to load file amd-ucode/microcode_amd.bin
Feb  2 15:51:54 g1 kernel: microcode: CPU1: patch_level=0x010000c8

Researched and found out I needed to install package "amd-ucode" to make the firmware available.



Attempted "emerge amd-ucode"

Had to add package keyword =sys-firmware/amd-ucode-2012.09.10 ~amd64 -- I realize this may be by design since the status is "unstable"

Next, I re-attempted "emerge amd-ucode" and got this:

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-firmware/amd-ucode-2012.09.10
>>> Downloading 'http://www.amd64.org/pub/microcode/amd-ucode-2012-09-10.tar'
--2013-02-02 17:40:20--  http://www.amd64.org/pub/microcode/amd-ucode-2012-09-10.tar
Resolving www.amd64.org... 217.9.48.20
Connecting to www.amd64.org|217.9.48.20|:80...

It appears to me that this line in the ebuild script points to a resource that is no longer available (and hasn't been, for some time):
SRC_URI="http://www.amd64.org/pub/microcode/${MY_P}.tar"

I manually downloaded the tar file, placed "microcode_amd.bin" into "/lib64/firmware/amd-ucode/" and everything worked:

Feb  2 17:09:00 g1 kernel: microcode: CPU1: patch_level=0x010000c8
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-03 01:03:21 UTC
If you say

> It appears to me that this line in the ebuild script points to a resource that is no longer available

which I confirm is the case, then how did you manage to do

> I manually downloaded the tar file, placed "microcode_amd.bin" into "/lib64/firmware/amd-ucode/" and everything worked

then? Did this manual download came from a different URL?
Comment 2 dkrenzel 2013-02-04 00:50:10 UTC
(In reply to comment #1)
> If you say
> 
> > It appears to me that this line in the ebuild script points to a resource that is no longer available
> 
> which I confirm is the case, then how did you manage to do
> 
> > I manually downloaded the tar file, placed "microcode_amd.bin" into "/lib64/firmware/amd-ucode/" and everything worked
> 
> then? Did this manual download came from a different URL?

Yes, I dug around for a short bit on the AMD site and then just grabbed it from a Fedora source:

http://pkgs.fedoraproject.org/repo/pkgs/microcode_ctl/amd-ucode-2012-09-10.tar/559bc355d3799538584add80df2996f0/amd-ucode-2012-09-10.tar
Comment 3 poletti.marco 2013-03-17 08:35:55 UTC
The same Fedora URL was suggested here a few months ago:
http://forums.gentoo.org/viewtopic-t-944292-start-0.html

And amd64.org is still down.

Is it possible to download the tar from that link and make it available in the gentoo mirrors? In this way we'd have a working URL for the ebuild without depending on Fedora.
Comment 5 Martin 2013-07-29 23:04:14 UTC
Is the emerge package really fixed/resolved for the amd64.org site no longer available?...

Trying just now to emerge the amd-ucode package gives:


# emerge -vDu amd-ucode

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] sys-firmware/amd-ucode-2012.09.10  70 kB

Total: 1 package (1 new), Size of downloads: 70 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-firmware/amd-ucode-2012.09.10
>>> Downloading 'http://www.amd64.org/pub/microcode/amd-ucode-2012-09-10.tar'
--2013-07-29 23:54:44--  http://www.amd64.org/pub/microcode/amd-ucode-2012-09-10.tar
Resolving www.amd64.org... 217.9.48.20
Connecting to www.amd64.org|217.9.48.20|:80... failed: Connection timed out.
Retrying.

--2013-07-29 23:55:46--  (try: 2)  http://www.amd64.org/pub/microcode/amd-ucode-2012-09-10.tar
Connecting to www.amd64.org|217.9.48.20|:80... failed: Connection timed out.
Retrying.

--2013-07-29 23:56:48--  (try: 3)  http://www.amd64.org/pub/microcode/amd-ucode-2012-09-10.tar
Connecting to www.amd64.org|217.9.48.20|:80... failed: Connection timed out.
Giving up.

!!! Couldn't download 'amd-ucode-2012-09-10.tar'. Aborting.
 * Fetch failed for 'sys-firmware/amd-ucode-2012.09.10', Log file:
 *  '/var/tmp/portage/sys-firmware/amd-ucode-2012.09.10/temp/build.log'

>>> Failed to emerge sys-firmware/amd-ucode-2012.09.10, Log file:

>>>  '/var/tmp/portage/sys-firmware/amd-ucode-2012.09.10/temp/build.log'

 * Messages for package sys-firmware/amd-ucode-2012.09.10:

 * Fetch failed for 'sys-firmware/amd-ucode-2012.09.10', Log file:
 *  '/var/tmp/portage/sys-firmware/amd-ucode-2012.09.10/temp/build.log'


Is this easily fixed to use an alternate download?

Thanks,
Martin
Comment 6 Sergey Popov gentoo-dev Security 2013-07-30 03:22:52 UTC

*** This bug has been marked as a duplicate of bug 475380 ***
Comment 7 Kent Fredric (IRC: kent\n) gentoo-dev 2013-09-18 02:29:17 UTC
(In reply to poletti.marco from comment #3)
> The same Fedora URL was suggested here a few months ago:
> http://forums.gentoo.org/viewtopic-t-944292-start-0.html
> 
> And amd64.org is still down.
> 
> Is it possible to download the tar from that link and make it available in
> the gentoo mirrors? In this way we'd have a working URL for the ebuild
> without depending on Fedora.

If it were possible, it would already have happened sadly.

The reason its not already on the gentoo mirrors is this part in the ebuild:

> # The license does not allow us to mirror the content.
> RESTRICT="mirror"

Which basically means upstream have said "If we die, its ok with us that nobody can get this stuff anymore".

Silly if you ask me.
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2013-09-18 11:33:54 UTC
*** Bug 475380 has been marked as a duplicate of this bug. ***
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2013-09-18 11:34:50 UTC
We are not allowed to redistribute the tarball so the only viable choice is to rely on the Fedora url (I wonder how come they mirror it themselves)
Comment 10 Kent Fredric (IRC: kent\n) gentoo-dev 2013-09-18 12:15:45 UTC
Did a bit of digging and it seems theres a debian mirror of some kind too,

> http://lists.debian.org/debian-release/2012/09/msg00706.html

Lead me to 

> http://anonscm.debian.org/gitweb/?p=users/hmh/amd64-microcode.git;a=tree

There's also 3 mirrors listed here:

> http://www.filewatcher.com/m/amd-ucode-2012-09-10.tar.71680-0.html

Given the circumstances, I'd imagine it pertinent to contact upstream and ask for an exemption that grants us permission to mirror it, given that upstream were last seen at the end of 2012 going "Yeah, the server is down, we're going to get it back at some stage". 

> https://lkml.org/lkml/2012/12/20/2
Comment 11 Kent Fredric (IRC: kent\n) gentoo-dev 2013-09-18 12:18:34 UTC
Bah, all three mirrors on that filesearch list are dead, so that gives us only the debian git and fedora uri's as valid sources.
Comment 12 Kent Fredric (IRC: kent\n) gentoo-dev 2013-09-18 12:26:44 UTC
Ooh, look, it seems they did get it in linux-firmware! 

https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/amd-ucode 

Dated 2013-07-11 

And a quick diff of the relevant license in that tree ( https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/LICENSE.amd-ucode ) , suggests they've changed the licensing to a more permissive one.
Comment 13 Kent Fredric (IRC: kent\n) gentoo-dev 2013-09-18 12:33:48 UTC
Hell, we already have an ebuild in tree that solves this problem :D

=sys-kernel/linux-firmware-20130728 *BLOCKS* sys-firmware/amd-ucode

Its also not mirror restricted.

So as soon as that can be stabilized, sys-firmware/amd-ucode can be treecleaned. 

( Unless somebody wants to parse the relevant stuff out of linux-firmware into a standalone ebuild )
Comment 14 Markos Chandras (RETIRED) gentoo-dev 2013-09-19 16:54:39 UTC
Now that linux-firmware is getting stable in 485376, it's time to proceed with the removal.
Comment 15 Michal Plichta 2013-10-05 21:21:48 UTC
I have one comment/question. I need sys-firmware/amd-ucode for microcode, and can install linux-firmware since:

# emerge -pv linux-firmware

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-kernel/linux-firmware-20130728  USE="-savedconfig" 18,793 kB
[blocks B      ] sys-kernel/linux-firmware[-savedconfig] ("sys-kernel/linux-firmware[-savedconfig]" is blocking x11-drivers/radeon-ucode-20130626)
[blocks B      ] x11-drivers/radeon-ucode ("x11-drivers/radeon-ucode" is blocking sys-kernel/linux-firmware-20130728)

Total: 1 package (1 new), Size of downloads: 18,793 kB
Conflict: 2 blocks (2 unsatisfied)

And I need x11-drivers/radeon-ucode for:
/lib/firmware/radeon/PALM_me.bin
/lib/firmware/radeon/PALM_pfp.bin
/lib/firmware/radeon/SUMO2_me.bin
/lib/firmware/radeon/SUMO2_pfp.bin
/lib/firmware/radeon/SUMO_me.bin
/lib/firmware/radeon/SUMO_pfp.bin
/lib/firmware/radeon/SUMO_rlc.bin
/lib/firmware/radeon/SUMO_uvd.bin

So what to do?
Comment 16 poletti.marco 2013-10-05 21:26:07 UTC
Uninstall x11-drivers/radeon-ucode and then install sys-kernel/linux-firmware.
All the files that you mentioned are also provided by sys-kernel/linux-firmware (this is why they block each other).
Comment 17 M. B. 2013-10-14 19:57:43 UTC
@Michael Plichta

Easy solution, but lacks a little sophistication which you might want to employ in order to keep radeon-ucode at its most recent, since linux-firmware lacks behind.
1. unmerge radeon-ucode
2. enable the "savedconfig" USE-flag for for linux-firmware
3. emerge linux-firmware
4. move /etc/portage/savedconfig/sys-kernel/linux-firmware-[yourversion] to /etc/portage/savedconfig/sys-kernel/linux-firmware
5. edit said file to not contain any radeon firmware (you might as well remove everything but the amd microcode)
6. emerge linux-firmware again
7. emerge latest radeon-ucode alongside it

et voilà - latest radeon microcode + amd microcode available side by side.
Comment 18 Michal Plichta 2013-10-14 20:21:46 UTC
(In reply to M. B. from comment #17)
> @Michael Plichta
> 
> Easy solution, but lacks a little sophistication which you might want to
> employ in order to keep radeon-ucode at its most recent, since
> linux-firmware lacks behind.
> 1. unmerge radeon-ucode
> 2. enable the "savedconfig" USE-flag for for linux-firmware
> 3. emerge linux-firmware
> 4. move /etc/portage/savedconfig/sys-kernel/linux-firmware-[yourversion] to
> /etc/portage/savedconfig/sys-kernel/linux-firmware
> 5. edit said file to not contain any radeon firmware (you might as well
> remove everything but the amd microcode)
> 6. emerge linux-firmware again
> 7. emerge latest radeon-ucode alongside it
> 
> et voilà - latest radeon microcode + amd microcode available side by side.

I will try it, thx. But which file do you meant in p. 5?
Comment 19 Markos Chandras (RETIRED) gentoo-dev 2013-10-21 19:49:09 UTC
Removed