Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 454956 - gnome-base/orbit-2.14.19-r1 with sys-devel/automake-1.13.1 - test/everything/Makefile.am:81: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/test.sh'
Summary: gnome-base/orbit-2.14.19-r1 with sys-devel/automake-1.13.1 - test/everything/...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 468732 (view as bug list)
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-02-01 06:39 UTC by iGentoo
Modified: 2013-05-06 07:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
orbit-2.14.19-r1-build.log (orbit-2.14.19-r1-build.log,2.44 KB, text/plain)
2013-02-01 06:39 UTC, iGentoo
Details
/var/tmp/portage/gnome-base/orbit-2.14.19-r1/temp/automake.out (automake.out,12.90 KB, text/plain)
2013-02-01 06:40 UTC, iGentoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description iGentoo 2013-02-01 06:39:23 UTC
Created attachment 337546 [details]
orbit-2.14.19-r1-build.log

1. WANT_AUTOMAKE=1.13 emerge =gnome-base/orbit-2.14.19-r1
2. build log:

>>> Source unpacked in /var/tmp/portage/gnome-base/orbit-2.14.19-r1/work
>>> Preparing source in /var/tmp/portage/gnome-base/orbit-2.14.19-r1/work/ORBit2-2.14.19 ...
 * Running eautoreconf in '/var/tmp/portage/gnome-base/orbit-2.14.19-r1/work/ORBit2-2.14.19' ...
 * Running gtkdocize --copy ...
 [ ok ]
 * Running libtoolize --install --copy --force --automake ...
 [ ok ]
 * Running aclocal ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running autoheader ...
 [ ok ]
 * Running automake --add-missing --copy ...
 [ !! ]

 * Failed Running automake !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/gnome-base/orbit-2.14.19-r1/temp/automake.out

/var/tmp/portage/gnome-base/orbit-2.14.19-r1/temp/automake.out:
...
test/everything/Makefile.am:76:   'Makefile.shared' included from here
test/everything/Makefile.am:13: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
test/everything/Makefile.am:81: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/test.sh'
Makefile.shared:6: warning: '%'-style pattern rules are a GNU make extension
...


emerge --info gnome-base/orbit
Portage 2.2.0_alpha161 (hardened/linux/amd64/selinux, gcc-4.7.2, glibc-2.17, 3.7.5-pax.x86_64 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.5-pax.x86_64-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-gentoo-2.2
KiB Mem:     6102024 total,   2340224 free
KiB Swap:   10484724 total,  10484724 free
Timestamp of tree: Fri, 01 Feb 2013 05:15:01 +0000
ld GNU gold (GNU Binutils 2.23.1) 1.11
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2, 3.3.0-r1
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo systemd hardened-dev gnome custom
Installed sets: @local
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-Wall -Wextra -gdwarf-4 -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-Wall -Wextra -gdwarf-4 -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
DISTDIR="/usr/local/portage/distfiles"
FCFLAGS="-Wall -Wextra -gdwarf-4 -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms split-elog split-log splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-Wall -Wextra -gdwarf-4 -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--icf=safe"
MAKEOPTS="V=1 -j6"
PKGDIR="/usr/local/portage/packages-amd64"
PORTAGE_BZIP2_COMMAND="lbzip2"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9ef"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--ipv4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/systemd /var/lib/layman/hardened-development /var/lib/layman/gnome /usr/local/portage"
SYNC="rsync://mirrors.ustc.edu.cn/gentoo-portage"
USE="X acl alsa amd64 audit bash-completion berkdb bzip2 c++0x cairo caps cli cracklib crypt custom-cflags cxx dbus dri ffmpeg gdbm gmp gnome gpm gtk gtk3 hardened iconv icu ipv6 jit jpeg jpeg2k justify lzma mmx modules mudflap multilib ncurses nls nptl open_perms opengl openmp orc pam pax_kernel pcre png pulseaudio qt4 readline selinux session sse sse2 ssl svg systemd tcpd threads tiff udev unicode urandom vim-syntax xattr xinetd zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="bootchart btrfs caps dmsquash-live gensplash livenet lvm nfs ssh-client syslog systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US zh zh_CN" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 python3_3" QEMU_SOFTMMU_TARGETS="x86_64 arm mips64el ppc64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2 3.3"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND

=================================================================
                        Package Settings
=================================================================

gnome-base/orbit-2.14.19-r1 was built with the following:
USE="(multilib) (selinux) -debug -doc -test"
Comment 1 iGentoo 2013-02-01 06:40:20 UTC
Created attachment 337548 [details]
/var/tmp/portage/gnome-base/orbit-2.14.19-r1/temp/automake.out
Comment 2 Justin Lecher gentoo-dev 2013-05-03 17:17:58 UTC
+*orbit-2.14.19-r3 (03 May 2013)
+
+  03 May 2013; Justin Lecher <jlec@gentoo.org> +orbit-2.14.19-r3.ebuild,
+  +files/orbit-2.14.19-automake-1.13.patch:
+  Fix usage of srcdir with tests for atuomake-1.13 compatibility, #454956
+
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2013-05-06 07:48:00 UTC
*** Bug 468732 has been marked as a duplicate of this bug. ***