Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 454882 - dev-perl/TermReadKey-2.300.0 - ReadKey.o: file not recognized: file truncated - collect2: ld execution failed with return code 1
Summary: dev-perl/TermReadKey-2.300.0 - ReadKey.o: file not recognized: file truncated...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-31 18:09 UTC by Polko Alexander
Modified: 2013-07-01 08:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,3.35 KB, text/plain)
2013-01-31 21:22 UTC, Polko Alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Polko Alexander 2013-01-31 18:14:15 UTC
Hello, I had this a problem when compiling php && mysql, emerge -av php mysql.
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-31 19:23:29 UTC
1) Which problem do you have?
2) Please place the output of `emerge --info` in a comment.
3) Please attach the build log as an attachment.

We don't use external pastes for various reasons (not permanent, not traceable, no bugzilla ID, not useable in automated bug analysis software, ...).

For more information on how to do bug reporting, consult http://www.gentoo.org/doc/en/bugzilla-howto.xml
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-31 19:27:01 UTC
Also, please don't add arches in the CC list; they work differently from the platform field and are therefore only added by maintainers for certain tasks (like stabilization of a package on a certain architecture).
Comment 4 Polko Alexander 2013-01-31 21:20:31 UTC
# emerge --info
Portage 2.1.11.50 (default/linux/x86/10.0/desktop/kde, gcc-4.6.3, glibc-2.16.0, 3.7.4-gentoo i686)
=================================================================
System uname: Linux-3.7.4-gentoo-i686-Intel-R-_Atom-TM-_CPU_N450_@_1.66GHz-with-gentoo-2.2
KiB Mem:     1016268 total,     29308 free
KiB Swap:    1951892 total,   1463560 free
Timestamp of tree: Thu, 31 Jan 2013 06:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=atom -O2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=atom -O2 -fomit-frame-pointer -pipe"
DISTDIR="/home/gentoo/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/home/gentoo/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7z X a52 aac acl acpi alsa apache2 berkdb bindist bluetooth bmp branding bzip2 cairo cdda cdr cdrw chm cli consolekit cracklib crypt cups cxx dbus declarative djvu dri dts dvd dvdr ebook emboss encode exif fam firefox flac fortran ftp gdbm gif gpm gtk iconv ipv6 java jpeg jpg kde kipi lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl ogg opengl openmp p7zip pam pango pcre pdf perl phonon php plasma png policykit ppds python qt3support qt4 rar rdp readline samba sdl semantic-desktop session spell ssl startup-notification svg tcpd tiff tng truetype udev udisks unicode upower usb vorbis wav wxwidgets x264 x86 xcb xcomposite xinerama xml xscreensaver xv xvid zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 5 Polko Alexander 2013-01-31 21:22:46 UTC
Created attachment 337506 [details]
build.log
Comment 6 Myckel Habets archtester 2013-01-31 21:41:17 UTC
Removing x86 arch team. We don't belong here.
Comment 7 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-31 23:12:14 UTC
@maintainers: See bug summary title for English error description.
Comment 8 Alexander Vershilov (RETIRED) gentoo-dev 2013-06-28 22:22:44 UTC
unable to reproduce on current stable system.
Comment 9 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-06-28 22:28:49 UTC
 can't reproduce it. 

Please, check your perl/gcc updates. And reopen,  if still have a problem