Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453640 - kde-base/audiocd-kio: possible depend on || ( dev-libs/libcdio-paranoia media-sound/cdparanoia ) if only `cdparanoia` executable is used, no libs
Summary: kde-base/audiocd-kio: possible depend on || ( dev-libs/libcdio-paranoia media...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2013-01-23 08:39 UTC by Massimo Burcheri
Modified: 2013-02-03 20:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Massimo Burcheri 2013-01-23 08:39:37 UTC
kde-base/audiocd-kio-4.9.3 (needed by k3b e.g.) is blocking new app-admin/eselect-cdparanoia-0.1 and dev-libs/libcdio-paranoia-0.90.
I'm already using the libcdio replacement for mplayer2 and abcde since a while. Old cdparanoia is old and unmaintained. Now just libcdio-paranoia bin was split from libcdio into its own ebuild.
Maybe rather add USE-flag "cdio" to audiocd-kio. Interface is quite similar, ripping was working with abcde (quite) out of the box, as mentioned in bug 453636.

The same for current ~amd64 kde-base/audiocd-kio-4.9.5:

$ ACCEPT_KEYWORD="~amd64" emerge -autv --oneshot =kde-base/audiocd-kio-4.9.5
[blocks B      ] <media-sound/cdparanoia-3.10.2-r5 ("<media-sound/cdparanoia-3.10.2-r5" is blocking app-admin/eselect-cdparanoia-0.1)

Total: 10 packages (9 upgrades, 1 new), Size of downloads: 20,335 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-admin/eselect-cdparanoia-0.1::gentoo, installed) pulled in by
    app-admin/eselect-cdparanoia required by (dev-libs/libcdio-paranoia-0.90::gentoo, installed)

  (media-sound/cdparanoia-3.10.2-r4::gentoo, ebuild scheduled for merge) pulled in by
    media-sound/cdparanoia required by (kde-base/audiocd-kio-4.9.5::gentoo, ebuild scheduled for merge)
    media-sound/cdparanoia required by (app-cdr/k3b-2.0.2-r4::gentoo, installed)
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2013-01-23 11:42:53 UTC
What do you mean it's blocking? It's possible to install cdparanoia and libcdio-paranoia into same system.

Your problem can be solved by `emerge -1 cdparanoia` to get the upgrade, and if you are mixing arch with ~arch you also need "media-sound/cdparanoia" entry in package.keywords -- all of cdio, paranoia, must be unmasked together
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2013-01-23 11:44:01 UTC
If this package is using the `cdparanoia` binary and not the libraries at all, then you can do this:

|| ( dev-libs/libcdio-paranoia media-sound/cdparanoia )

The command line interfaces should be the same, or same enough for things to keep working

Watch out for those libraries, it's a bit like graphicsmagick vs. imagemagick here, if you know what I mean
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2013-01-23 11:46:32 UTC
Bug 452430 is about tracking packages that fail to build against cdio and cdio-paranoia >= 0.90, not for tracking possibilities of converting into || ( )
if you want, you can create own tracker for such change and file bugs for every "Check if your package is only using cdparanoia executable, and if so, then change || ( )" ...
Comment 4 Chris Reffett (RETIRED) gentoo-dev Security 2013-02-03 20:13:56 UTC
Nope, kio_audiocd links against the libs, so can't put the || dependency in.