Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 452798 - x11-misc/lightdm does not respect CC
Summary: x11-misc/lightdm does not respect CC
Status: RESOLVED DUPLICATE of bug 463846
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Markos Chandras (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2013-01-18 10:53 UTC by Agostino Sarubbo
Modified: 2013-05-27 17:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-01-18 10:53:33 UTC
You receive this bug because this package does not respect my system's CC ( x86_64-pc-linux-gnu-gcc - /usr/bin/x86_64-pc-linux-gnu-gcc ) and calls directly gcc -/usr/bin/gcc
The possible solutions to fix this issue are:
1)Fix the buildsystem, if you can
2)inherit toolchain-funcs and use tc-export CC
3)inherit toolchain-funcs and use emake CC="$(tc-getCC)"


This package partially does not respect CC:

g-ir-scanner: compile: gcc -Wall -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include 
-march=native -g0 -O2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -c -o 
/tmp/portage/x11-misc/lightdm-1.4.0/work/lightdm-1.4.0/liblightdm-gobject/tmp-introspectFe8H9C/LightDM-1.o 
/tmp/portage/x11-misc/lightdm-1.4.0/work/lightdm-1.4.0/liblightdm-gobject/tmp-introspectFe8H9C/LightDM-1.c
libtool: link: gcc -o 
/tmp/portage/x11-misc/lightdm-1.4.0/work/lightdm-1.4.0/liblightdm-gobject/tmp-introspectFe8H9C/.libs/LightDM-1 
-march=native -g0 -O2 
/tmp/portage/x11-misc/lightdm-1.4.0/work/lightdm-1.4.0/liblightdm-gobject/tmp-introspectFe8H9C/LightDM-1.o 
-pthread -Wl,--export-dynamic -Wl,--export-dynamic  -L. ./.libs/liblightdm-gobject-1.so -lxklavier 
-lX11 -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -lrt -lglib-2.0 -pthread

and at configure time:
checking whether gcc understands -Wno-sign-compare... yes
Comment 1 Agostino Sarubbo gentoo-dev 2013-01-24 22:00:39 UTC
@Markos, lightdm-gtk-greeter has the same problem at configure time
Comment 2 Samuli Suominen gentoo-dev 2013-05-27 17:10:49 UTC

*** This bug has been marked as a duplicate of bug 463846 ***