Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451360 - sci-libs/opencascade-6.5 with tcl-8.6.0-r1: src/Draw/Draw_Window.cxx:1047:37: error: 'Tcl_Interp' has no member named 'result'
Summary: sci-libs/opencascade-6.5 with tcl-8.6.0-r1: src/Draw/Draw_Window.cxx:1047:37:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: https://build.opensuse.org/package/vi...
Whiteboard:
Keywords:
: 451274 (view as bug list)
Depends on:
Blocks: tcltk-8.6
  Show dependency tree
 
Reported: 2013-01-11 08:08 UTC by Juergen Rose
Modified: 2013-03-03 10:09 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
bzip2ed /var/tmp/portage/sci-libs/opencascade-6.5/temp/build.log (build.log.bz2,239.20 KB, application/x-bzip2)
2013-01-12 06:44 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2013-01-11 08:08:53 UTC
'emerge opencascade' fails with:
...
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../.. -I/usr/include -I/usr/include -I../../../inc -I../../../drv/Draw -I../../../src/Draw -I../../../drv/DBRep -I../../../src/DBRep -I../../../drv/DrawTrSurf -I../../../src/DrawTrSurf -I/opt/sun-jdk-1.6.0.38/include -I/opt/sun-jdk-1.6.0.38/include/linux -D_OCC64 -m64 -DNDEBUG -DNo_Exception -march=amdfam10 -O2 -pipe -fpermissive -DCSFDB -DOCC_CONVERT_SIGNALS -DLIN -DLININTEL -D_GNU_SOURCE=1 -O2 -c ../../../src/DrawTrSurf/DrawTrSurf_BSplineCurve2d.cxx  -fPIC -DPIC -o .libs/DrawTrSurf_BSplineCurve2d.o
../../../src/Draw/Draw_VariableCommands.cxx: In static member function 'static void Draw::Set(Standard_CString, const Handle_Draw_Drawable3D&, Standard_Boolean)':
../../../src/Draw/Draw_VariableCommands.cxx:756:27: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
../../../src/Draw/Draw_Window.cxx: In function 'void Prompt(Tcl_Interp*, int)':
../../../src/Draw/Draw_Window.cxx:73:41: error: 'Tcl_Interp' has no member named 'result'
../../../src/Draw/Draw_Window.cxx: In function 'Standard_Boolean Init_Appli()':
../../../src/Draw/Draw_Window.cxx:1047:37: error: 'Tcl_Interp' has no member named 'result'
make[3]: *** [Draw_Window.lo] Error 1


Reproducible: Always




root@caiman:/root(59)# emerge --info '=sci-libs/opencascade-6.5'
Portage 2.1.11.39 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.16.0, 3.7.1-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.1-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.2
Timestamp of tree: Fri, 11 Jan 2013 03:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x11 bicatali science java-overlay sunrise lisp x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/bicatali /var/lib/layman/science /var/lib/layman/java-overlay /var/lib/layman/sunrise /var/lib/layman/lisp /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fts3 fuse g3dvl gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pam pcre pda pdf perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rhythmbox rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4a ssl stlport subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk toolbar tools truetype udev udisks unicode usb userlocales utempter v4l vaapi vala vdpau video virtualbox visio vorbis vpx wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sci-libs/opencascade-6.5 was built with the following:
USE="doc examples java (multilib) -debug -gl2ps"
CXXFLAGS="-march=amdfam10 -O2 -pipe -fpermissive"




root@caiman:/root(60)# emerge -pqv '=sci-libs/opencascade-6.5'
[ebuild   R   ] sci-libs/opencascade-6.5 [6.5] USE="doc examples java -debug -gl2ps"
Comment 1 Justin Lecher gentoo-dev 2013-01-11 09:28:03 UTC
From opensuse, see URL

ix build failure with tcl 8.6

With this patch, opencascade still builds with tcl 8.5.

Submitted upstream: http://www.opencascade.org/org/forum/thread_20125/

Index: opencascade/ros/src/Draw/Draw_Window.cxx
===================================================================
--- opencascade.orig/ros/src/Draw/Draw_Window.cxx
+++ opencascade/ros/src/Draw/Draw_Window.cxx
@@ -70,7 +70,7 @@
       errChannel = Tcl_GetStdChannel(TCL_STDERR);
       if (code != TCL_OK) {
         if (errChannel) {
-          Tcl_Write(errChannel, Interp->result, -1);
+          Tcl_Write(errChannel, Tcl_GetStringResult(Interp), -1);
           Tcl_Write(errChannel, "\n", 1);
         }
         Tcl_AddErrorInfo(Interp,
@@ -1044,7 +1044,7 @@
   mainWindow =
   Tk_MainWindow(interp) ;
   if (mainWindow == NULL) {
-    fprintf(stderr, "%s\n", interp->result);
+    fprintf(stderr, "%s\n", Tcl_GetStringResult(interp));
     exit(1);
   }
   Tk_Name(mainWindow) =
@@ -2064,7 +2064,7 @@
     OCC_CATCH_SIGNALS
     Standard_Integer res = Tk_Init(interp) ;
     if (res != TCL_OK)
-      cout << "tkLoop: error in Tk initialization. Tcl reported: " << interp->result << endl;
+      cout << "tkLoop: error in Tk initialization. Tcl reported: " << Tcl_GetStringResult(interp) << endl;
 
   } catch  (Standard_Failure) {
     cout <<"tkLoop: exception in TK_Init "<<endl;
@@ -2074,7 +2074,7 @@
   mainWindow =
     Tk_MainWindow(interp) ;
   if (mainWindow == NULL) {
-        fprintf(stderr, "%s\n", interp->result);
+        fprintf(stderr, "%s\n", Tcl_GetStringResult(interp));
         cout << "tkLoop: Tk_MainWindow() returned NULL. Exiting..." << endl;
         Tcl_Exit(0);
    }
Comment 2 Pacho Ramos gentoo-dev 2013-01-11 19:14:41 UTC
*** Bug 451274 has been marked as a duplicate of this bug. ***
Comment 3 Juergen Rose 2013-01-12 06:44:04 UTC
Created attachment 335286 [details]
bzip2ed /var/tmp/portage/sci-libs/opencascade-6.5/temp/build.log
Comment 4 Gabriel Misailidis 2013-01-15 21:10:08 UTC
I have applied the patch Justin posted but it doesn't being emerged. 
Justin the link you've posted needs to log in to download the patch.
Comment 5 Justin Lecher gentoo-dev 2013-01-16 19:50:58 UTC
(In reply to comment #4)
> I have applied the patch Justin posted but it doesn't being emerged. 
> Justin the link you've posted needs to log in to download the patch.

https://build.opensuse.org/package/view_file?file=OpenCASCADE-6.5.0-fix-tcl8.6.patch&package=OpenCascade&project=Education&rev=8c9c59579a49cab3753ba59a62018a3e
Comment 6 Geoff Madden 2013-01-31 13:59:55 UTC
(In reply to comment #4)
> I have applied the patch Justin posted but it doesn't being emerged. 
> Justin the link you've posted needs to log in to download the patch.

Hi Gabriel,

i just cut & pasted the patch,placed it into the opencascade files dir & modified the ebuild to reflect where the patch was located. I have just completed the compile successfully.
Geoff
Comment 7 Juergen Rose 2013-01-31 14:30:17 UTC
Now it works for me too.
Comment 8 Gabriel Misailidis 2013-02-01 16:24:25 UTC
I can confirm too. It was emerged fine.
I am sorry for the delay.I was doing wrong with patching it.

Thanks.
Comment 9 augury 2013-02-05 06:16:10 UTC
ok

ros/src/Draw/Draw_Window.cxx 


line 1024 
-Standard_Boolean Init_Appli()
+Standard_Boolean Init_Appli(&result)  //untested

+char result;  //this worked


line 71
-static void Prompt(Tcl_Interp *Interp, int partial)
+static void Prompt(Tcl_Interp *Interp, int partial, char result)

line 73
-Tcl_Write(errChannel, interp->result, -1);
+Tcl_Write(errChannel, result, -1);



It built with out me commenting it out.  This is a probably a segfault.  It's about the same.  I was screwing around with tcl.h so I don't know wtf it is now.
Comment 10 Justin Lecher gentoo-dev 2013-02-05 07:49:56 UTC
http://patch-tracker.debian.org/patch/series/view/opencascade/6.5.0.dfsg-2/submitted/fix-tcl8.6.patch

this one was accepted by upstream.
Comment 11 Pli 2013-02-21 15:03:51 UTC
Workaround:

CPPFLAGS="-DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE"
in make.conf file.

Worked for me
Comment 12 Justin Lecher gentoo-dev 2013-03-03 10:09:10 UTC
+  03 Mar 2013; Justin Lecher <jlec@gentoo.org> opencascade-6.5.ebuild,
+  +files/opencascade-6.5-tcl8.6.patch, metadata.xml:
+  Add fix for compilation with tcl-8.6, thanks debian, #451360
+