Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 451142 - dev-lang/tcl-8.6.0 breaks dev-vcs/git-1.8.1
Summary: dev-lang/tcl-8.6.0 breaks dev-vcs/git-1.8.1
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tcltk-8.6
  Show dependency tree
 
Reported: 2013-01-10 09:50 UTC by octoploid
Modified: 2013-01-11 09:25 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description octoploid 2013-01-10 09:50:30 UTC
After the upgrade to tcl/tk-8.6.0 dev-vcs/git doesn't build anymore:
...
make[1]: Entering directory `/var/tmp/portage/dev-vcs/git-1.8.1/work/git-1.8.1/git-gui'
    INDEX lib/
  DEST /var/tmp/portage/dev-vcs/git-1.8.1/image//usr/libexec/git-core
    INSTALL 755 git-gui
    INSTALL 755 git-gui--askpass
    LINK        git-citool -> git-gui
  DEST /var/tmp/portage/dev-vcs/git-1.8.1/image//usr/share/git-gui/lib
    INSTALL 644 tclIndex
install: cannot stat ‘lib/tclIndex’: No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-vcs/git-1.8.1/work/git-1.8.1/git-gui'
make: *** [install] Error 2
 * ERROR: dev-vcs/git-1.8.1 failed (install phase):

Running "make V=1 lib/tclIndex" in /var/tmp/portage/dev-vcs/git-1.8.1/work/git-1.8.1/git-gui gives:
...
application-specific initialization failed: package not known
invalid command name "auto_mkindex_parser::command"




Reproducible: Always
Comment 1 John Keeping 2013-01-10 13:07:43 UTC
This is caused by configuring tcl with '--with-encoding=utf-8'.  It seems that this creates a broken tcl install which fails to read its own (internal) configuration:

--with-encoding=<val> sets TCL_CFGVAL_ENCODING=<val>

This is used in tclPkgConfig.c where it is passed to Tcl_RegisterConfig() which uses that encoding to decode the values in the package configuration table.  However, if the encoding is not found it completely skips reading the configuration; silently.  When this configuration isn't read, tcl has no idea where its library is located which causes everything to break.

I have confirmed that removing the '--with-encoding=utf-8' line from tcl-8.6.0.ebuild fixes tcl on my system.
Comment 2 Siuchung Cheung (Clement) 2013-01-11 08:39:34 UTC
Same problem. Confirmed suggested fix in comment 1 works for me.
Comment 3 Justin Lecher gentoo-dev 2013-01-11 09:25:11 UTC
Please use tcl-8.6.0-r1.