Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 450330 - no service can provide "net" on arm stage3-armv6j_hardfp (last known good build Nov 15 2012)
Summary: no service can provide "net" on arm stage3-armv6j_hardfp (last known good bui...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Stages (show other bugs)
Hardware: ARM Linux
: Normal blocker with 1 vote (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-05 04:32 UTC by Dale Hamel
Modified: 2015-02-17 02:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dale Hamel 2013-01-05 04:32:35 UTC
Using a recent stage3 from http://distfiles.gentoo.org/releases/arm/autobuilds/current-stage3-armv6j_hardfp/, it is impossible to setup any service to provide net.

Symbolically linking net.lo to net.eth0 and then starting net.eth0 gives the device network access, but net.eth0 does not provide net. For instance, sshd cannot be started, even after net.eth0 is started, because it requires net.

Net.eth0 will also not start at boot, even when registered at the boot runlevel.

Installed wicd, tried same steps as with net.eth0. Can get internet access, but does not provide net for other init scripts. Does not start on boot, even when registered.

All of this was tested on a raspberry pi. Older stages (last known was nov 15) work with no problem.

Reproducible: Always

Steps to Reproduce:
1. Use a recent stage3 (tested with http://distfiles.gentoo.org/releases/arm/autobuilds/current-stage3-armv6j_hardfp/stage3-armv6j_hardfp-20130103.tar.bz2) on a raspberry pi
2. Bootstrap the device as described at http://wiki.gentoo.org/wiki/Raspberry_Pi_Quick_Install_Guide
3. Try starting sshd after starting net.eth0
Actual Results:  
SSHD or any other service that requires net will not recognize that any service (wicd or net.eth*) provides it.

Expected Results:  
The service should recognize that the other service provides net

All steps performed on a raspberry pi running latest firmware.
Comment 1 Dale Hamel 2013-01-05 04:46:33 UTC
This affects anyone attempting to use gentoo on a raspberry pi, if we don't fix it soon then we could lose mindshare in this community.
Comment 2 Dale Hamel 2013-01-05 05:01:43 UTC
Also noticed that net.eth0 says "need firewalld" when starting.

Confirmed to work fine on Nov 15 build.
Comment 3 Michael Weber (RETIRED) gentoo-dev 2013-07-12 14:08:26 UTC
Same here for the 20130207 build.
Workaround in rc.conf:rc_sshd_need="!net"
Comment 4 Raúl Porcel (RETIRED) gentoo-dev 2013-08-24 11:59:12 UTC
Does this happen with the ones from this month?
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-08-25 01:42:32 UTC
I've hit a similar issue when using an old stage3 to install my odroid x2 (armv7).
In my case, I got it working after updating openrc and after fixing the date. If you hit this issue with a recent stage, please check if your device has the correct date.
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2015-02-17 02:53:15 UTC
We need more information to deal with this bug.