Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 449486 - gnome-base/gnome-3.6.2: filemanager is random
Summary: gnome-base/gnome-3.6.2: filemanager is random
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 451372 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-31 16:37 UTC by Juergen Rose
Modified: 2013-02-03 00:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-12-31 16:37:09 UTC
If I choose a file in the Downloads window of firefox and select "Open containing folder" baobab is started. In the past (with gnome-3.4.1) nautilus was started.

I suppose this bug is almost the same as Bug 442062.

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2012-12-31 17:03:46 UTC
Does it only occur with firefox? From where are you launching firefox? (terminal, gnome-shell?) What does "$ echo $XDG_DATA_DIRS" output?
Comment 2 Juergen Rose 2012-12-31 17:19:32 UTC
If seen this in the last days only with firefox. Normally I start firefox from the gnome shell sometimes form the terminal. Because I started firefox last time some days ago, I don't know exactly, how I started it. I will check.

rose@impala:/home_impala/rose(1)$ echo $XDG_DATA_DIRS
/usr/local/share:/usr/share:/usr/share/gdm
Comment 3 Juergen Rose 2012-12-31 17:24:30 UTC
I killed firefox and started firefox again from the gnome-shell (applications menu -> favorites), then I opened the Downloads window and selected "Open containing folder"  and now file-roller is started.
Comment 4 Juergen Rose 2012-12-31 17:26:31 UTC
I killed firefox again and start it from the gnome terminal then I opened the Downloads window and selected "Open containing folder"  and now baobab is started.
Comment 5 Juergen Rose 2012-12-31 17:33:33 UTC
I have to correct Comment 3, probably I hit the wrong menu entry ("Open" instead of "Open containing folder"). Now I get also baobab, if I start firefox from the gnome shell.
Comment 6 Juergen Rose 2012-12-31 17:36:28 UTC
BTW, if I insert an USB stick, also "Open with baobab" in german "Oeffnen mit Festplattenbelegung analysieren" is offered.
Comment 7 Pacho Ramos gentoo-dev 2012-12-31 18:09:58 UTC
How are you stating gnome? Also, are you running it as root? (the output you saw before was from a root shell)
Comment 8 Juergen Rose 2012-12-31 18:20:14 UTC
I start as root gdm and login as user rose. The user rose is the owner of all gnome processes:

root@lynx:/root(11)# ps -ef | grep gnome | grep -v grep
root     19276 19274  0 13:00 ?        00:00:00 /usr/libexec/gdm-simple-slave --display-id /org/gnome/DisplayManager/Displays/_0
rose     19583 19563  0 13:08 ?        00:00:00 gnome-session
rose     19738     1  0 13:08 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session
rose     19740 19583  0 13:08 ?        00:00:00 /usr/bin/ssh-agent -- gnome-session
rose     19749     1  0 13:08 ?        00:00:00 /usr/libexec/at-spi2-registryd --use-gnome-session
rose     19761 19583  0 13:08 ?        00:00:05 /usr/libexec/gnome-settings-daemon
rose     19770     1  0 13:08 ?        00:00:00 /usr/bin/gnome-keyring-daemon --start --components=ssh
Comment 9 Pacho Ramos gentoo-dev 2012-12-31 18:24:07 UTC
Then:
1. Launch gnome-terminal
2. Verify:
$ echo $XDG_DATA_DIRS 
/usr/share/gnome:/usr/local/share:/usr/share:/usr/share/gdm
-> if /usr/share/gnome is present
3. Run "firefox" from that terminal and verify if problem still exists
Comment 10 Juergen Rose 2012-12-31 18:25:00 UTC
Sorry I did the command in the wrong window, but the result the right window is not very different:

root@impala:/root(78)# ps -ef | grep gnome | grep -v grep
rose      2425     1  0 Dec27 ?        00:00:23 /usr/libexec/at-spi2-registryd --use-gnome-session
rose     14695 28544 11 Dec27 ?        13:30:33 /usr/bin/gnome-shell
rose     14718     1  0 Dec27 ?        00:00:00 /usr/libexec/gnome-shell-calendar-server
rose     19266 14695  0 Dec27 ?        00:00:16 gnome-terminal
rose     19272 19266  0 Dec27 ?        00:00:00 gnome-pty-helper
rose     25787     1  0 Dec27 ?        00:00:15 /usr/bin/gnome-dvb-daemon
root     27525 27524  0 Dec19 ?        00:00:00 /usr/libexec/gdm-simple-slave --display-id /org/gnome/DisplayManager/Display1
rose     28544 28145  0 Dec19 ?        00:00:03 gnome-session
rose     28666     1  0 Dec19 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session
rose     28668 28544  0 Dec19 ?        00:00:03 /usr/bin/ssh-agent -- gnome-session
rose     28675 28544  0 Dec19 ?        00:06:10 /usr/libexec/gnome-settings-daemon
rose     28683     1  0 Dec19 ?        00:00:01 /usr/bin/gnome-keyring-daemon --start --components=gpg
rose     28729 28544  0 Dec19 ?        00:01:18 gnome-screensaver
Comment 11 Juergen Rose 2013-01-01 14:32:43 UTC
I rebooted the computer, started gdm, logged in as user rose and started a gnome-terminal.  XDG_DATA_DIRS does now not contain /usr/share/gnome but this directory exist. And firebox starts baobab for directory viewing as before:

rose@impala:/home_impala/rose(1)$ env | grep XDG
XDG_MENU_PREFIX=gnome-
XDG_SESSION_COOKIE=5a68222d62ffa27375642b1a00157350-1357050209.221290-1567817127
XDG_CONFIG_DIRS=/etc/xdg
XDG_DATA_DIRS=/usr/local/share:/usr/share:/usr/share/gdm
rose@impala:/home_impala/rose(2)$ firefox 

** (baobab:29609): CRITICAL **: atk_bridge_adaptor_cleanup: assertion `inited' failed
^Z
[1]+  Angehalten              firefox
rose@impala:/home_impala/rose(3)$ bg
[1]+ firefox &
rose@impala:/home_impala/rose(4)$ ll /usr/share/gnome
insgesamt 28
drwxr-xr-x  2 root root 4096 27. Dez 11:22 applications/
drwxr-xr-x  4 root root 4096 19. Mär 2011  apps/
drwxr-xr-x  2 root root 4096 27. Dez 10:28 autostart/
-rw-r--r--  1 root root  191 27. Dez 10:29 gnome-version.xml
drwxr-xr-x 54 root root 4096 31. Dez 18:28 help/
drwxr-xr-x  2 root root 4096 27. Dez 10:28 shutdown/
drwxr-xr-x  2 root root 4096 27. Dez 12:18 wm-properties/
rose@impala:/home_impala/rose(5)$ 


Gnome-terminal starts as login shell.
Comment 12 Pacho Ramos gentoo-dev 2013-01-11 18:51:14 UTC
*** Bug 451372 has been marked as a duplicate of this bug. ***
Comment 13 Pacho Ramos gentoo-dev 2013-01-11 18:55:17 UTC
(In reply to comment #11)
[...]
> Gnome-terminal starts as login shell.

It shouldn't, setting was reverted to follow upstream and preventing issues like this:
*gnome-terminal-2.32.1-r1 (24 Nov 2012)
*gnome-terminal-3.4.1.1-r1 (24 Nov 2012)

  24 Nov 2012; Pacho Ramos <pacho@gentoo.org> +gnome-terminal-2.32.1-r1.ebuild,
  +gnome-terminal-3.4.1.1-r1.ebuild, -gnome-terminal-3.4.0.1.ebuild:
  Stop defaulting to enable login shell as it causes problems (#442062 by
  Juergen Rose), with this we revert to upstream (and most distributions)
  default setting.
Comment 14 Juergen Rose 2013-01-12 09:35:42 UTC
(In reply to comment #13)
> (In reply to comment #11)
> [...]
> > Gnome-terminal starts as login shell.
> 
> It shouldn't, setting was reverted to follow upstream and preventing issues
> like this:
> *gnome-terminal-2.32.1-r1 (24 Nov 2012)
> *gnome-terminal-3.4.1.1-r1 (24 Nov 2012)
> 
>   24 Nov 2012; Pacho Ramos <pacho@gentoo.org>
> +gnome-terminal-2.32.1-r1.ebuild,
>   +gnome-terminal-3.4.1.1-r1.ebuild, -gnome-terminal-3.4.0.1.ebuild:
>   Stop defaulting to enable login shell as it causes problems (#442062 by
>   Juergen Rose), with this we revert to upstream (and most distributions)
>   default setting.

Hi Pacho,

I like, that bash is started as a login shell, if I open a terminal window.
Is there any way to circumvent this mime problem with nautilus in the case I am starting a login shell in gnome-terminal, e.g. by setting of environment variables (adding /usr/share/gnome to XDG_DATA_DIRS )?
Comment 15 Pacho Ramos gentoo-dev 2013-01-12 09:51:51 UTC
Maybe you could call /etc/X11/xinit/xinitrc.d/15-xdg-data-gnome script from your .bash_profile. Also, maybe you wouldn't need to set it as login interpreter if you move you "special things" to .bashrc... but I don't know real reasons for you preferring login shell ;)
Comment 16 Martin Wegner 2013-01-23 12:39:06 UTC
As bug #451372 was made a duplicate of this bug, I will add my comment here: I see the same behaviour as described in bug #451372, baobab being the default handler for directories wherever some program has the option to open a folder ("Open containing folder" in firefox, the notification when a removable device was mounted, etc.). I see no random behaviour, nor does it make a difference whether I start a program via terminal or gnome-shell.

As per the gnome bug report [0] and this Arch Linux bug report [1] this issue arises since baobab registers itself as handler for directories in /usr/share/applications/baobab.desktop:
[...]
MimeType=inode/directory;
[...]

Somehow (as I don't know how mime.cache and selecting default handlers for mime types work) baobab becomes the default handler for directories in Gnome.

How can this be changed back to nautilus?

[0] https://bugzilla.gnome.org/show_bug.cgi?id=687598
[1] https://bugs.archlinux.org/task/31861

PS: I don't know if it's needed, but my XDG_DATA_DIRS contains /usr/share/gnome:

/usr/share/gnome:/usr/local/share:/usr/share:/usr/share/gdm

(I ran $ echo $XDG_DATA_DIRS from a zsh running inside a gnome-terminal in my Gnome session.)
Comment 17 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-01-23 13:59:01 UTC
In /usr/share/gnome/applications/defaults.list, we have inode/directory=nautilus-folder-handler.desktop, which had worked in earlier gnome versions, but fails now since nautilus-3.6 only installs nautilus.desktop; there is no more nautilus-folder-handler.desktop.

So we really need to go over the defaults.list file and make sure that all the entries in it are still correct for 3.6
Comment 18 Olliver Schinagl 2013-02-02 11:40:00 UTC
I just checked my
/usr/share/gnome/applications/defaults.list

and
inode/directory=nautilus-folder-handler.desktop

is listed as the directory entry. Yet, boabab still launches as the default FM.

I spent a good 10 minutes cleaning out my .cache, .local and .config dirs to make sure it's not a personal setting.

As a workaround i'm changing my default .local/share/applications/mimeapps.list to do it for now.
Comment 19 Pacho Ramos gentoo-dev 2013-02-02 16:55:20 UTC
(In reply to comment #18)
> I just checked my
> /usr/share/gnome/applications/defaults.list
> 
> and
> inode/directory=nautilus-folder-handler.desktop
> 
> is listed as the directory entry. Yet, boabab still launches as the default
> FM.
> 
> I spent a good 10 minutes cleaning out my .cache, .local and .config dirs to
> make sure it's not a personal setting.
> 
> As a workaround i'm changing my default
> .local/share/applications/mimeapps.list to do it for now.

Changing in /usr/share/gnome/applications/defaults.list:
inode/directory=nautilus-folder-handler.desktop

by:
inode/directory=nautilus-folder-handler.desktop;nautilus.desktop

should work
Comment 20 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-03 00:40:40 UTC
Should be fixed in gnome-session-3.6.2-r2

+*gnome-session-3.6.2-r2 (03 Feb 2013)
+
+  03 Feb 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+  -gnome-session-3.6.2.ebuild, gnome-session-3.6.2-r1.ebuild,
+  +gnome-session-3.6.2-r2.ebuild, +files/defaults.list-r1:
+  Update default gnome file handlers: fix nautilus-3.6 directory handling (bug
+  #449486), prefer chromium over epiphany, fall back to libreoffice or
+  openoffice if abiword and gnumeric are not installed. Drop old 3.6.2 ebuild
+  and propagate ~arm keyword to -r1 and -r2.