Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449270 - gnome-base/gdm-3.6.2: unable to log in after logout from autologin
Summary: gnome-base/gdm-3.6.2: unable to log in after logout from autologin
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Keywords: Inclusion, PATCH
Depends on:
Reported: 2012-12-30 09:34 UTC by LeonBernieniv
Modified: 2013-07-27 11:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description LeonBernieniv 2012-12-30 09:34:43 UTC
The patch here:
Update PLS.

Reproducible: Always
Comment 1 water 2013-01-18 12:28:32 UTC
I meet the same problem in gnome-base/gdm-3.6.2 . 
My system is amd64 arch.
kernel is 3.6.11 gentoo-sources .
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-01-22 22:54:27 UTC
I see, it was an inadequate usage of pam it seems :)
Comment 3 Evgeny Bobkin 2013-03-26 08:54:40 UTC
I can confirm this issue, please include this patch!
Comment 4 Riccardo Brasca 2013-04-11 22:36:11 UTC
Any news about this? It still happens to me!
Comment 5 David Klann 2013-04-17 15:08:41 UTC
The patch referred to in the attachment by LeonBernieniv on 2012-12-30 09:34:43 UTC solved the GNOME auto-login problem for me. Details:

Arch: amd64

gnome-base/gdm-3.6.2 (patched) USE flags: consolekit fallback fprint gnome-shell introspection ipv6 ldap plymouth tcpd xinerama -accessibility -audit -debug -selinux -smartcard -systemd -test

(Note: not using systemd)

I can post other details if needed.

Comment 6 Charles Svitlik 2013-07-18 17:18:44 UTC
I'm also experiencing this with gdm-3.6.2 and gdm-3.6.2-r1. The patch mentioned in Comment #1 fixes it.

emerge --info gdm:
Portage (hardened/linux/amd64, gcc-4.7.3, glibc-2.17, 3.10.0-hardened x86_64)
                        System Settings
System uname: Linux-3.10.0-hardened-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P7350_@_2.00GHz-with-gentoo-2.2
KiB Mem:     3873056 total,    167768 free
KiB Swap:    2097144 total,   1813912 free
Timestamp of tree: Thu, 18 Jul 2013 06:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r1, 3.2.5-r1, 3.3.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo gamerlay steam-overlay x11
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy compress-build-logs config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles merge-sync news notitles parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/gamerlay /var/lib/layman/steam /var/lib/layman/x11"
USE="10bit X Xaw3d aalib acl acpi alsa amd64 autoipd avahi berkdb bluetooth bzip2 cairo cdda cjk cleartype cli consolekit corefonts cracklib crypt cue cups cvs cxx dbus dconf dga directfb djvu dri dvd egl exif fbcon ffmpeg fftw flac fontconfig fontforge fuse gallium gconf gdbm gdu gif gles gles1 gles2 gmp gnome gnome-keyring gnome-online-accounts gnome-shell gnuplot gnutls gold gpm gstreamer gtk gtk3 hardened http i18n iconv icu id3tag imagemagick imlib infinality ipv6 jabber jack jit joystick jpeg justify l10n lame laptop libcaca libnotify libsamplerate lirc mad mmx mmxext modules mp3 mpeg msn mudflap multilib nautilus ncurses networkmanager nls nptl nss offensive ogg openal opengl openmp opus pam pango pax_kernel pcre pdf perl pic plotutils png policykit pulseaudio python qt3support randr readline realtime rss s3tc samba sdl session smp spell sqlite sse sse2 ssl startup-notification subversion svg taglib tcpd theora threads tiff tls truetype udev udisks unicode upcall upnp urandom usb v4l vaapi vala vim-syntax vorbis vpx wifi wxwidgets x264 xcb xcomposite xft xinerama xml xorg xpm xrandr xv xvid zlib zsh-completion" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc default" INPUT_DEVICES="keyboard mouse synaptics evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86 x86_64 i386" QEMU_USER_TARGETS="x86 x86_64 i386" RUBY_TARGETS="ruby20 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

gnome-base/gdm-3.6.2-r1 was built with the following:
USE="consolekit fallback gnome-shell introspection ipv6 tcpd xinerama -accessibility -audit -debug -fprint -ldap -plymouth (-selinux) -smartcard -systemd -test"
Comment 7 Pacho Ramos gentoo-dev 2013-07-27 11:29:07 UTC
This is solved in 3.8