Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448778 - app-crypt/mit-krb5 : krb5-conf returns incorrect libs that are required to link
Summary: app-crypt/mit-krb5 : krb5-conf returns incorrect libs that are required to link
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Kerberos Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-27 06:41 UTC by Alexander Vershilov (RETIRED)
Modified: 2014-12-23 16:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build time fix (mit-krb.patch,363 bytes, patch)
2012-12-27 14:58 UTC, Alexander Vershilov (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Vershilov (RETIRED) gentoo-dev 2012-12-27 06:41:46 UTC
krb5-conf --libs shows build options among the list of libraries. It leads to incorrect .pc files in other packages (e.g. net-libs/neon[kerberos])

Reproducible: Always

Steps to Reproduce:
1. krb5-config --libs

Actual Results:  
-L/usr/lib64 -Wl,--hash-style=gnu,--sort-common,--as-needed -lkrb5 -lk5crypto -lcom_err

Expected Results:  
-lkrb5 -lk5crypto -lcom_err

emerge --info app-crypt/mit-krb5
Portage 2.2.0_alpha149 (hardened/linux/amd64, gcc-4.6.3, glibc-2.16.0, 3.6.8-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.6.8-gentoo-x86_64-Intel-R-_Core-TM-_i3-2310M_CPU_@_2.10GHz-with-gentoo-2.2
Timestamp of tree: Wed, 26 Dec 2012 07:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo gentoo-haskell aidecoe mgorny init6 rion qnikst
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native -maes"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native -mtune=native -maes"
DISTDIR="/mnt/distfiles"
EMERGE_DEFAULT_OPTS="-j3"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe -march=native -mtune=native -maes"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,--hash-style=gnu,--sort-common,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/portage"
PORTDIR_OVERLAY="/home/qnikst/workspace/myself/gentoo-haskell /var/lib/layman/aidecoe /var/lib/layman/mgorny /var/lib/layman/init6 /var/lib/layman/rion /home/qnikst/workspace/myself/qnikst-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 berkdb bindist bzip2 cli cracklib crypt cups cxx dbus dri gdbm gpm hardened iconv ipv6 justify mmx modules mudflap multilib ncurses nls nptl opengl openmp pam pax_kernel pcre pppd readline session sse sse2 sse3 ssl tcpd truetype unicode urandom xft zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 i686 x86_64" QEMU_USER_TARGETS="x86_64 i386 i686" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="canon epson" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-crypt/mit-krb5-1.11 was built with the following:
USE="keyutils (multilib) pkinit threads -doc -openldap -test -xinetd"
CFLAGS="-O2 -pipe -march=native -mtune=native -maes -fno-strict-aliasing -fno-strict-overflow"
CXXFLAGS="-O2 -pipe -march=native -mtune=native -maes -fno-strict-aliasing -fno-strict-overflow"
Comment 1 Alexander Vershilov (RETIRED) gentoo-dev 2012-12-27 14:58:05 UTC
Created attachment 333476 [details, diff]
build time fix

this patch fixes situation howerer it changes krb5-config --libs logic
Comment 2 Alexander Vershilov (RETIRED) gentoo-dev 2012-12-27 15:00:38 UTC
another solution is to add next filters to executable (based on fedora patch)
however it doesn't strip all build time garbage.

    lib_flags=`echo $lib_flags | sed -e "s#-fPIE##g" -e "s#-pie##g"`
    lib_flags=`echo $lib_flags | sed -e "s#-Wl,-z,relro##g"`
    lib_flags=`echo $lib_flags | sed -e "s#-Wl,-z,now##g"`
    lib_flags=`echo $lib_flags | sed -e "s#-Wl,-O[012]##g"`
    lib_flags=`echo $lib_flags | sed -e "s#-Wl,--hash-style=[^,]*,##g"`
Comment 3 Eray Aslan gentoo-dev 2012-12-27 15:03:36 UTC
Yeah, I know the reason for the garbled output.  It is also trivial to fix.  Will do so after getting feedback from upstream though.
Comment 4 Eray Aslan gentoo-dev 2012-12-28 07:30:58 UTC
Should be fixed in kit-krb5-1.11-r1.  Please let me know if you still have a problem.  Thank you.
Comment 5 Alexander Vershilov (RETIRED) gentoo-dev 2012-12-28 09:10:15 UTC
Works for me.
Comment 6 Julian Ospald 2014-12-23 15:51:35 UTC
why is this patch not upstream?
Comment 7 Eray Aslan gentoo-dev 2014-12-23 16:00:35 UTC
http://mailman.mit.edu/pipermail/krbdev/2012-December/011317.html is the upstream's answer.