Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 448424 - x11-drivers/xf86-video-nouveau-1.0.4 cannot find the nVidia card on PowerBook G4
Summary: x11-drivers/xf86-video-nouveau-1.0.4 cannot find the nVidia card on PowerBook G4
Status: RESOLVED DUPLICATE of bug 446253
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-24 16:21 UTC by seraph@xs4all.nl
Modified: 2013-03-04 15:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description seraph@xs4all.nl 2012-12-24 16:21:52 UTC
After doing a normal @world update, X could no longer be started on my PowerBook G4.  The following upgrades were done:

x11-libs/libdrm-2.4.40 [2.4.33]
app-admin/eselect-opengl-1.2.6.1 [1.2.5-r1]
x11-proto/glproto-1.4.16 [1.4.15]
media-libs/mesa-9.0 [8.0.3]
x11-base/xorg-server-1.13.0-r1 [1.12.4]
x11-drivers/xf86-video-nouveau-1.0.4 [0.0.16_pre20120322]

Reverting these packages to their previous versions solved the problem instantly.

Checking /var/log/Xorg.0.log, I found that libdrm is apparently no longer able to find my card; with the previous version I get:

[   847.105] (II) NOUVEAU driver for NVIDIA chipset families :
[   847.105]    RIVA TNT        (NV04)
[   847.105]    RIVA TNT2       (NV05)
[   847.105]    GeForce 256     (NV10)
[   847.105]    GeForce 2       (NV11, NV15)
[   847.105]    GeForce 4MX     (NV17, NV18)
[   847.105]    GeForce 3       (NV20)
[   847.105]    GeForce 4Ti     (NV25, NV28)
[   847.105]    GeForce FX      (NV3x)
[   847.106]    GeForce 6       (NV4x)
[   847.106]    GeForce 7       (G7x)
[   847.106]    GeForce 8       (G8x)
[   847.106]    GeForce GTX 200 (NVA0)
[   847.106]    GeForce GTX 400 (NVC0)
[   847.106] (--) using VT number 2

[   847.109] drmOpenDevice: node name is /dev/dri/card0
[   847.109] drmOpenDevice: open result is 9, (OK)
[   847.109] drmOpenByBusid: Searching for BusID pci:0000:00:10.0
[   847.109] drmOpenDevice: node name is /dev/dri/card0
[   847.109] drmOpenDevice: open result is 9, (OK)
[   847.109] drmOpenByBusid: drmOpenMinor returns 9
[   847.109] drmOpenByBusid: drmGetBusid reports pci:0000:00:10.0
[   847.109] (II) [drm] nouveau interface version: 1.0.0

But with the updated packages, I get:
[  4379.948] (II) NOUVEAU driver
[  4379.948] (II) NOUVEAU driver for NVIDIA chipset families :
[  4379.948]    RIVA TNT        (NV04)
[  4379.948]    RIVA TNT2       (NV05)
[  4379.948]    GeForce 256     (NV10)
[  4379.948]    GeForce 2       (NV11, NV15)
[  4379.948]    GeForce 4MX     (NV17, NV18)
[  4379.948]    GeForce 3       (NV20)
[  4379.948]    GeForce 4Ti     (NV25, NV28)
[  4379.948]    GeForce FX      (NV3x)
[  4379.948]    GeForce 6       (NV4x)
[  4379.949]    GeForce 7       (G7x)
[  4379.949]    GeForce 8       (G8x)
[  4379.949]    GeForce GTX 200 (NVA0)
[  4379.949]    GeForce GTX 400 (NVC0)
[  4379.949] (--) using VT number 2

[  4379.951] (II) [drm] nouveau interface version: 1.0.0
[  4379.951] (EE) No devices detected.
[  4379.952]
Fatal server error:
[  4379.952] no screens found
Comment 1 seraph@xs4all.nl 2013-03-04 15:49:31 UTC

*** This bug has been marked as a duplicate of bug 446253 ***