Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448414 - net-analyzer/munin-2.0.8-r2: mailman plugin does not work because logfile path is wrong
Summary: net-analyzer/munin-2.0.8-r2: mailman plugin does not work because logfile pat...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Sysadmin Bugs
Depends on:
Reported: 2012-12-24 14:24 UTC by Juan David Ibáñez Palomar
Modified: 2012-12-31 10:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Juan David Ibáñez Palomar 2012-12-24 14:24:14 UTC
There is an error in the munin plugin for mailman:


The "logfile" path is wrong:

/var/log/mailman/post        # Wrong
/var/lib/mailman/logs/post   # Right

Reproducible: Always

Steps to Reproduce:
1. Install munin & mailman
2. Set-up the mailman plugin
3. Run "munin-run mailman"
Actual Results:  
Can't open /var/log/mailman/post.0 for reading: No such file or directory at /etc/munin/plugins/mailman line 109.

Expected Results:  
posts.value XXX
members.value XXX
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-12-24 16:58:46 UTC
Lovely, it's not configurable...

I got to fix this upstream but it worries me because it does not include an explicit license, which is not good.

Although I could probably argue that mailman is misconfigured by default if it saves logs in /var/lib — nevertheless this is a bug that has to be fixed, will try something.
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-12-30 12:48:02 UTC
Okay this should be solved in 2.0.9-r1.

The paths are now configurable, and I changed the default configuration file to point to Gentoo's default for mailman.
Comment 3 Juan David Ibáñez Palomar 2012-12-31 10:40:26 UTC
It works now, thanks!