Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448172 - sys-devel/gcc-4.1.2 - /usr/lib64/libart_lgpl_2.so: could not read symbols: File in wrong format /// make[6]: *** [lib-gnu-java-awt-peer-gtk.la] Error 1
Summary: sys-devel/gcc-4.1.2 - /usr/lib64/libart_lgpl_2.so: could not read symbols: Fi...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-22 12:27 UTC by Viacheslav Gagara
Modified: 2017-08-12 20:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gcc-build-logs.tar.bz2 (gcc-build-logs.tar.bz2,167.56 KB, application/x-bzip-compressed-tar)
2012-12-22 12:34 UTC, Viacheslav Gagara
Details
environment.gz (environment.gz,39.04 KB, application/x-gzip)
2012-12-22 12:37 UTC, Viacheslav Gagara
Details
build.log.gz (build.log.gz,317.09 KB, application/x-gzip)
2012-12-22 12:41 UTC, Viacheslav Gagara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viacheslav Gagara 2012-12-22 12:27:30 UTC
gcc-4.1.2 failed to build.
Error: /usr/lib64/libart_lgpl_2.so: could not read symbols: File in wrong format
Looks like it tries to use 64bit version of libart_lgpl_2.so while 32bit is required.

Installed libart libs:
/usr/lib32/libart_lgpl_2.so
/usr/lib32/libart_lgpl_2.so.2
/usr/lib32/libart_lgpl_2.so.2.3.21
/usr/lib64/libart_lgpl_2.la
/usr/lib64/libart_lgpl_2.so
/usr/lib64/libart_lgpl_2.so.2
/usr/lib64/libart_lgpl_2.so.2.3.21

app-emulation/emul-linux-x86-baselibs-20121202 (/usr/lib32/libart_lgpl_2.so -> libart_lgpl_2.so.2.3.21)
media-libs/libart_lgpl-2.3.21-r1 (/usr/lib64/libart_lgpl_2.so -> libart_lgpl_2.so.2.3.21)


Reproducible: Always

Steps to Reproduce:
1.emerge -v =sys-devel/gcc-4.1.2

Actual Results:  
ERROR: sys-devel/gcc-4.1.2 failed (compile phase):

Expected Results:  
sys-devel/gcc-4.1.2 should compile successfully.


# emerge --info
Portage 2.1.11.38 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.16.0, 3.3.2-gentoo x86_64)
=================================================================
System uname: Linux-3.3.2-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.2
Timestamp of tree: Thu, 20 Dec 2012 18:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r1, 2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.1.2, 4.2.4-r1, 4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula AdobeFlash-10 AdobeFlash-10.1 AdobeFlash-10.3 Oracle-BCLA-JavaSE google-chrome skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X Xaw3d a52 aac acpi adplug alsa amd64 amr apache2 arts artworkextra avahi berkdb bluetooth bonobo branding bzip2 cairo cdda cdr chardet cli consolekit cracklib crypt cups cxx dbus dga djvu dri dts dvd dvdr dvdread dvi eap-tls emboss encode esd exif fam fastcgi ffmpeg firefox flac fortran fuse gd gdbm gif gimp glitz gnutls gpm gsm gstreamer gtk gtk2 gtk3 gtkhtml guile howl-compat iconv idle imap ipv6 irda java java5 jingle jpeg kde keyring kqemu lcms ldap libnotify lm_sensors mad matroska mdnsresponder-compat minizip mmx mmxext mng modules mono mozilla mp3 mp4 mpeg mudflap multilib mysql ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcmcia pcre pdf pmu png policykit postgres ppds pppd python qt3 qt3support qt4 readline regex samba sasl seamonkey semantic-desktop session smp sourceview spamassassin spell srv sse sse2 ssl ssse3 startup-notification static-libs subversion svg syslog tcpd theora threads tiff trayicon truetype udev udisks unicode upower usb v4l2 valgrind vcd vim-syntax vim-with-x vorbis wma wmf wxwidgets x264 xcb xface xforms xhtml xinerama xml xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access access_compat auth auth_dbm auth_anon auth_digest alias file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate mime-magic cern-meta expires headers usertrack unique-id proxy proxy-connect proxy-ftp proxy-http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env setenvif mime status autoindex asis negotiation dir imap actions userdir so filter unique_id authz_host authn_core authz_core unixd socache_shmcb" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev touchpad synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="uk ru en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia v4l v4l2" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

-------------------
Error details:
/bin/sh ./libtool --tag=GCJ --mode=link /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/gcc/gcj -B/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/x86_64-pc-linux-g
/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/gcc/gcj -B/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/x86_64-pc-linux-gnu/32/libjava/ -B/var/tmp/portage/sys-de
/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/gcc/gcj -B/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/x86_64-pc-linux-gnu/32/libjava/ -B/var/tmp/portage/sys-de
creating gcj-dbtool
./gcj-dbtool -n classmap.db || touch classmap.db
/usr/lib64/libart_lgpl_2.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[6]: *** [lib-gnu-java-awt-peer-gtk.la] Error 1
Comment 1 Viacheslav Gagara 2012-12-22 12:34:31 UTC
Created attachment 333026 [details]
gcc-build-logs.tar.bz2
Comment 2 Viacheslav Gagara 2012-12-22 12:37:54 UTC
Created attachment 333028 [details]
environment.gz
Comment 3 Viacheslav Gagara 2012-12-22 12:41:01 UTC
Created attachment 333030 [details]
build.log.gz

full build.log file
Comment 4 Viacheslav Gagara 2012-12-22 12:44:30 UTC
# emerge --info '=sys-devel/gcc-4.1.2'
Portage 2.1.11.38 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.16.0, 3.3.2-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.2-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.2
Timestamp of tree: Thu, 20 Dec 2012 18:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r1, 2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.1.2, 4.2.4-r1, 4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula AdobeFlash-10 AdobeFlash-10.1 AdobeFlash-10.3 Oracle-BCLA-JavaSE google-chrome skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X Xaw3d a52 aac acpi adplug alsa amd64 amr apache2 arts artworkextra avahi berkdb bluetooth bonobo branding bzip2 cairo cdda cdr chardet cli consolekit cracklib crypt cups cxx dbus dga djvu dri dts dvd dvdr dvdread dvi eap-tls emboss encode esd exif fam fastcgi ffmpeg firefox flac fortran fuse gd gdbm gif gimp glitz gnutls gpm gsm gstreamer gtk gtk2 gtk3 gtkhtml guile howl-compat iconv idle imap ipv6 irda java java5 jingle jpeg kde keyring kqemu lcms ldap libnotify lm_sensors mad matroska mdnsresponder-compat minizip mmx mmxext mng modules mono mozilla mp3 mp4 mpeg mudflap multilib mysql ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcmcia pcre pdf pmu png policykit postgres ppds pppd python qt3 qt3support qt4 readline regex samba sasl seamonkey semantic-desktop session smp sourceview spamassassin spell srv sse sse2 ssl ssse3 startup-notification static-libs subversion svg syslog tcpd theora threads tiff trayicon truetype udev udisks unicode upower usb v4l2 valgrind vcd vim-syntax vim-with-x vorbis wma wmf wxwidgets x264 xcb xface xforms xhtml xinerama xml xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access access_compat auth auth_dbm auth_anon auth_digest alias file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate mime-magic cern-meta expires headers usertrack unique-id proxy proxy-connect proxy-ftp proxy-http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env setenvif mime status autoindex asis negotiation dir imap actions userdir so filter unique_id authz_host authn_core authz_core unixd socache_shmcb" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev touchpad synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="uk ru en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia v4l v4l2" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-devel/gcc-4.1.2 was built with the following:
USE="cxx fortran gcj gtk mudflap (multilib) nls nptl (-altivec) -bootstrap -build -d -doc (-hardened) (-libssp) -multislot -nocxx -objc -objc++ -objc-gc -test -vanilla"
CFLAGS="-march=nocona -O2 -pipe -O2"
CXXFLAGS="-march=nocona -O2 -pipe -O2"
Comment 5 Andreas K. Hüttel gentoo-dev 2017-08-12 20:17:40 UTC
Closing since gcc-4.1 is now masked.