Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448130 - app-office/libreoffice-3.6.4.3 - /usr/lib64//libclucene-core.so: undefined reference to `std::__detail::_List_node_base::_M_unhook()@GLIBCXX_3.4.15'
Summary: app-office/libreoffice-3.6.4.3 - /usr/lib64//libclucene-core.so: undefined re...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
: 448090 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-21 22:42 UTC by Martin Mokrejš
Modified: 2013-03-17 11:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (build.log.bz2,187.46 KB, application/x-bzip)
2012-12-21 22:44 UTC, Martin Mokrejš
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2012-12-21 22:42:10 UTC
=============
(35/44) Building module cli_ure
=============
Entering /var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3/cli_ure/inc

Entering /var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3/cli_ure/version

/bin/cp version.txt ../unxlngx6.pro/bin/cliureversion.mk
cli_ure deliver
Module 'cli_ure' delivered successfully. 1 files copied, 4 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 512 occurred while making /var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3/l10ntools/prj

 it seems that the error is inside 'l10ntools', please re-run build
 inside this module to isolate the error and/or test your fix:

build_error.log should contain the captured output of the failed module(s)

-----------------------------------------------------------------------
To rebuild a specific module:

make l10ntools.clean # optional
make l10ntools

when the problem is isolated and fixed, re-run 'make'
make[1]: *** [build-packimages] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3'
make: *** [build] Error 2
 * ERROR: app-office/libreoffice-3.6.4.3 failed (compile phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 9046:  Called die
 * The specific snippet of code:
 *       make build || die
 * 
 * If you need support, post the output of `emerge --info '=app-office/libreoffice-3.6.4.3'`,
 * the complete build log and the output of `emerge -pqv '=app-office/libreoffice-3.6.4.3'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea-bin-6  CLASSPATH="" JAVA_HOME="/opt/icedtea-bin-6.1.11.5"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""
and of course, the output of emerge --info
 * The complete build log is located at '/var/tmp/portage/app-office/libreoffice-3.6.4.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/libreoffice-3.6.4.3/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3'
 * S: '/var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3'
Comment 1 Martin Mokrejš 2012-12-21 22:44:53 UTC
Created attachment 332988 [details]
build.log.bz2
Comment 2 Martin Mokrejš 2012-12-22 11:50:00 UTC
Ah, /var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3/build_error.log actually has more details:


[ build CXX ] l10ntools/source/help/HelpIndexer_main.cxx
S=/var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3 && O=$S/solver/unxlngx6.pro && W=$S/workdir/unxlngx6.pro &&  mkdir -p $W/CxxObject/l10ntools/source/help/ $W/Dep/CxxObject/l10ntools/source/help/ && x86_64-pc-linux-gnu-g++ -DCPPU_ENV=gcc3 -DENABLE_GRAPHITE -DENABLE_GTK -DGCC -DGXX_INCLUDE_PATH=/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4 -DHAVE_GCC_VISIBILITY_FEATURE -DHAVE_THREADSAFE_STATICS -DLINUX -DNDEBUG -DOPTIMIZE -DOSL_DEBUG_LEVEL=0 -DSOLAR_JAVA -DSUPD=360 -DUNIX -DUNX -DX86_64 -D_PTHREADS -D_REENTRANT  -DBOOST_NO_0X_HDR_TYPEINDEX -DBOOST_NO_CXX11_HDR_TYPEINDEX -DSYSTEM_EXPAT  -DSYSTEM_LIBXML  -DSYSTEM_DB_HEADER='<db4.8/db.h>'     -Wall -Wendif-labels -Wextra -fmessage-length=0 -fno-common -pipe  -DLIBO_MERGELIBS -fPIC -Wshadow -Wsign-promo -Woverloaded-virtual  -Wno-non-virtual-dtor -fvisibility=hidden  -fvisibility-inlines-hidden  -fno-strict-aliasing -std=gnu++0x -Wno-deprecated-declarations  -DEXCEPTIONS_ON -fexceptions -fno-enforce-eh-specs -save-temps -Wall -O2 -pipe -msse  -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -msse4 -march=native -c $S/l10ntools/source/help/HelpIndexer_main.cxx -o $W/CxxObject/l10ntools/source/help/HelpIndexer_main.o -MMD -MT $W/CxxObject/l10ntools/source/help/HelpIndexer_main.o -MP -MF $W/Dep/CxxObject/l10ntools/source/help/HelpIndexer_main.d_ -I$S/l10ntools/source/help/  -I/usr/include/CLucene/ext -I$O/inc/external -I$O/inc -I$S/solenv/inc -I/opt/icedtea-bin-6.1.11.5/include -I/opt/icedtea-bin-6.1.11.5/include/linux -I/opt/icedtea-bin-6.1.11.5/include/native_threads/include -I/usr/include/libxml2    -I/usr/include/libxml2       && mv $W/Dep/CxxObject/l10ntools/source/help/HelpIndexer_main.d_ $W/Dep/CxxObject/l10ntools/source/help/HelpIndexer_main.d
x86_64-pc-linux-gnu-g++: warning: -pipe ignored because -save-temps specified
[ build LNK ] Executable/HelpIndexer
S=/var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3 && O=$S/solver/unxlngx6.pro && W=$S/workdir/unxlngx6.pro &&  mkdir -p $W/LinkTarget/Executable/ && x86_64-pc-linux-gnu-g++     '-Wl,-rpath,$ORIGIN/../lib:$ORIGIN' -Wl,-rpath-link,$O/lib -Wl,-z,defs  -Wl,-rpath-link,/lib:/usr/lib -Wl,-z,combreloc  -L$S/solenv/unxlngx6/lib -L$O/lib -L$S/solenv/unxlngx6/lib  -Wl,--hash-style=gnu  -Wl,--dynamic-list-cpp-new -Wl,--dynamic-list-cpp-typeinfo -Wl,-Bsymbolic-functions  -Wl,-O1 -Wl,--as-needed  $W/CxxObject/l10ntools/source/help/HelpIndexer_main.o     -Wl,--start-group  -Wl,--end-group -Wl,--no-as-needed  -lexpat -lxslt -lz -lm -lrt -lxml2   -lxml2   -ldb-4.8  -L/usr/lib64/ -lclucene-core -lclucene-shared   -lclucene-contribs-lib  -luno_sal -lhelplinkerlo -o $W/LinkTarget/Executable/HelpIndexer
/usr/lib64//libclucene-core.so: undefined reference to `std::__detail::_List_node_base::_M_unhook()@GLIBCXX_3.4.15'
/usr/lib64//libclucene-core.so: undefined reference to `std::__detail::_List_node_base::_M_hook(std::__detail::_List_node_base*)@GLIBCXX_3.4.15'
collect2: ld returned 1 exit status
make[2]: *** [/var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3/workdir/unxlngx6.pro/LinkTarget/Executable/HelpIndexer] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3/l10ntools'


A reinstall of dev-cpp/clucene-2.3.3.4-r4 did not help, neither a reinstall of glibc. A bug http://forums.fedoraforum.org/showthread.php?t=268245 pointed me to:

$ find /usr -name libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.2.4/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.2.4/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.6/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.6/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6
^C
$ strings /usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6 | grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBC_2.2.5
GLIBC_2.3
GLIBC_2.14
GLIBC_2.3.2
GLIBC_2.3.4
GLIBCXX_DEBUG_MESSAGE_LENGTH
$ strings /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6 | grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBC_2.2.5
GLIBC_2.3
GLIBC_2.14
GLIBC_2.3.2
GLIBC_2.3.4
GLIBCXX_DEBUG_MESSAGE_LENGTH
$


I upgraded dev-libs/boost-1.52.0-r2 to -r5 using gcc-4.6.3, no help. I recompiled again cpplucene, no help. Finally, recompiling cpplucene using gcc-4.5.3 fixed that for me. After that, I can compile the openoffice code using either, gcc-4.5.3 and 4.6.3. Just doing:

# cd /var/tmp/portage/app-office/libreoffice-3.6.4.3/work/libreoffice-core-3.6.4.3
# make l10ntools.clean
# make l10ntools

http://forums.gentoo.org/viewtopic-p-7198742.html

So who is at fault?
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2012-12-25 15:12:50 UTC
Post also emerge --info...
Comment 4 Martin Mokrejš 2012-12-26 15:59:46 UTC
# emerge --info
Portage 2.1.11.38 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.16.0, 3.7.1-default x86_64)
=================================================================
System uname: Linux-3.7.1-default-x86_64-Intel-R-_Core-TM-_i7-2640M_CPU_@_2.80GHz-with-gentoo-2.2
Timestamp of tree: Sat, 22 Dec 2012 23:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.5.4-r5, 2.6.8-r1, 2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.2.4-r1, 4.3.6-r1, 4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo gentoo-haskell science x-portage x-layman
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm Oracle-BCLA-JavaSE skype-eula Nero-EULA-US AdobeFlash-10.3 skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -msse  -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -msse4 -mavx -maes -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -msse  -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -msse4 -mavx -maes -march=native"
DISTDIR="/mnt/1TB/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nostrip parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/1TB/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/haskell /home/mmokrejs/proj/sci /usr/local/portage /var/lib/layman"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 amr apache apache2 berkdb bluetooth bzip2 cairo cgi cli cracklib crypt cups cxx dbus device-mapper dhcp dri emboss encode fax ffmpeg flac fontconfig fortran gd gdbm gimp gpm gtk gudev hal hpijs hwdb iconv id3tag innodb java jce jpeg jpg keymap ladspa laptop lcms libnotify lm_sensors mad mmx modules mpi mpich2 multilib mysql ncurses nfs nls nptl nptlonly nsplugin ntfsprogs ocr ogg opengl openmp openssl pam parport pcre pdf perl php png policykit ppds pppd python readline resolvconf scanner server session sndfile sqlite sse sse2 sse3 ssl suexec svg syslog tcpd threads tiff tk truetype udev unicode usb vim-syntax wavpack x11 xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en cs cz" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vesa vmware fbdev intel i915 i965 nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2012-12-26 18:47:43 UTC
*** Bug 448090 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2012-12-27 07:54:58 UTC
if you compile clucene with gcc-4.6.x and then try to build libreoffice with gcc-4.5.x, that's an error on your part

are you sure you had gcc-4.6.x selected when building libreoffice ?

post the output of:
$ cat /etc/ld.so.conf.d/05gcc-x86_64-pc-linux-gnu.conf
Comment 7 Andreas K. Hüttel gentoo-dev 2013-03-17 11:13:06 UTC
Mixing and matching compilers...