Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 445120 - sys-libs/tdb-1.2.11: Build failed - [Errno 2] No such file or directory: '/var/tmp/portage/sys-libs/tdb-1.2.10/work/tdb-1.2.10/bin/default/lib/replace/getpass_2.d'
Summary: sys-libs/tdb-1.2.11: Build failed - [Errno 2] No such file or directory: '/va...
Status: RESOLVED DUPLICATE of bug 379837
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-28 22:38 UTC by Lars
Modified: 2013-06-04 03:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The complete build log (build.log,27.62 KB, text/plain)
2012-11-28 22:38 UTC, Lars
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars 2012-11-28 22:38:58 UTC
Created attachment 330860 [details]
The complete build log

emerge -pqv '=sys-libs/tdb-1.2.10'
[ebuild     U ] sys-libs/tdb-1.2.10 [1.2.9] USE="python"



emerge --info '=sys-libs/tdb-1.2.10'
Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.5.7-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7250_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Wed, 28 Nov 2012 16:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.5
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo rion java-overlay science local_overlay g-ctan
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 sun-bcla-java-vm skype-eula AdobeFlash-10.1 AdobeFlash-10.3 cadsoft EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -mtune=generic -msse -msse2 -msse3 -mfpmath=sse -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb /var/lib/redmine/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-O2 -march=core2 -mtune=generic -msse -msse2 -msse3 -mfpmath=sse -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/rion /var/lib/layman/java-overlay /var/lib/layman/science /usr/local/portage /var/lib/g-ctan"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X X509 Xaw3d a52 aac aacplus aalib acct acl acpi activefilter addbookmarks additions addns addressbook aio akonadi alias alisp alsa amd64 amr amrnb amrwb aotuv apache2 apng archive ass async asyncns atm audiofile auth autoipd automount autoreplace autotrace avahi bash-completion berkdb bitmap bittorrent bluetooth branding bs2b bzip2 cairo calendar caps cdaudio cdda cddax cddb cdio cdparanoia cdr chdir chroot cleartype cli clucene clutter connectionstatus consolekit contactnotes contrast coverage cracklib cron crypt cscope css cuda cups curl cxx daap dar64 dbus dc1394 dell desktopglobe device-mapper devil dga dia dirac directfb disk-partition distinct-l djbfft djvu dmraid dmx dnd dri dts dv dvb dvd dvdr dvdread dvi dynamic eap-sim eap-tls ebook eigen emacs embedded-fuseiso emf emovix enca encode eolconv epos escreen espeak etwin eurephia exif expat extras faac faad fam fame fastcgi fat fax fbcon fbcondecor fbsplash fdt festival ffmpeg fftw finger firefox firefox3 fits flac flite fluidsynth fmod fontconfig foomaticdb fortran fpx freetds freetts ftd2xx ftdi ftp fts3 fuse fusion g3dvl gadu gbm gcj gcrypt gd gdbm geoip geolocation ggi ggz gif gimp git glib glitz gme gmp gnokii gnutls gopher gpg gphoto2 gpm gpu graphics graphviz groupwise grp gs gsm gstreamer gtk gtk3 gudev gzip handwriting hardened hbci hfs highlight history hog hotpixels hpcups hpijs hpn htmlhandbook http humanities hwdb hybrid-auth hyperestraier ical iconv icotools icoutils icu id3tag idea idn ieee1394 ifp ilbc imagemagick imlib inkjar inotify ioctl ios ipod iproute2 ipv6 ipw4965 irc irmc isag ivtv jabber jack jadetex java java5 java6 javascript jbig jce jemalloc jfs jingle jit joystick jpeg jpeg2k jsapi json kate kdm kdrive keymap kig-scripting kipi kpathsea kqemu kvm ladspa lame lapack laptop lasi lastfm latex lcms ldap lensfun libass libcaca libkms libmpeg2 libnl libnotify libsamplerate libssh2 libsysfs libtiger libv4l libv4l2 libvisual live llvm lm_sensors logitech-mouse loop-aes lqr lua lvm lzma lzo mac macvtap mad madwifi marble matroska mbox mbrola md5sum mdadm mdnsresponder-compat mem-scramble messenger midi mikmod minizip mixer mjpeg mmap mms mmx mmxext mng mod modplug modules mono mozdevelop mozdom mozilla mp2 mp3 mp3tunes mp4 mpeg mpg123 mpi mplayer mpx mtp mudflap mule multilib multimedia multiuser musepack musicbrainz mvl mysql mythtv nas natspec ncurses nemesi netbeans netboot nettle network network-cron new-hpcups nfs njb nls nntp nodrm nokia nowlistening nptl nsplugin nss ntfs ntlm nut nuv nvidia objc objc++ objc-gc ocr octave odbc ofa offensive ofono ofx ogg openal opencl opencore-amr openexr opengl openmp openntpd openssl openvg openvpn optimization optimized-qmake oscar oss otp otr pam pam_ssh panorama parted passenger passwordsave paste64 pcap pcmcia pcre pdf pdfannotextractor pdfimport perl phonon pkcs11 pkinit plasma plotutils plugins pmu png pnm policykit postscript ppds ppp pppd presto pronounce pth pulseaudio pvr python qalculate qemu qemu-ifup qpak qt-faststart qt3support qt4 quicktime quotas qwt radio radius rar raw rdesktop rdesktop-vrdp rdp rdpusb readline realtime redeyes reiser4 reiserfs replytolist resolvconf restrict-javascript rfc3779 rpm rss rtc rtf rtmp rtsp ruby rups s3 samba sametime sasl scanner schroedinger science scim script sdl sdl-image secure-delete security segger semantic-desktop sensord serial session shine shout sidebar sift silc skins skype slang slit slp smbclient smbkrb5passwd smbsharemodes smi smime smp sms smtp sndfile snmp socks5 sound soundex soundtouch speex spell spice spoof-source sqlite sse sse2 sse3 ssh ssl ssse3 startup-notification statistics stream subversion svg swat swig sysfs syslog t1lib taglib tcl tcpd teletext templates test-programs texteffect tga themes theora thin-splines threads thumbnail tiff timezone timidity tk tls toolbar toolkit-scroll-bars tor-hardening tordns translator transmitter trayicon truetype tv twolame udev udev-acl udisks ukit uml unicode usb usbredir utempter uuid v4l v4l2 vaapi vamp vcd vcdinfo vcdx vde vdpau vdr versaloon vhosts video vim-pager vim-syntax vim-with-x virt-network visualization vlc vlm vnc vorbis vpnc vpx wad wavpack webgl webinterface webkit webp webpresence wicd wifi wimax win32 winbind winetools winetriks winpopup wma wma-fixed wmf wps wxwidgets wxwindows x264 xa xanim xattr xcomposite xemacs xetex xext xforms xfs xine xinerama xinetd xml xmldoclet xmp xnest xosd xpm xprint xrandr xscreensaver xulrunner xv xvfb xvid xvmc yahoo yv12 zephyr zeroconf zip zlib zoran zsh-completion zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="cgid actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias dav dav_fs dav_lock deflate dir disk_cache" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z template toshiba_pdrm11 jl2005a topfield ax203 st2205 jl2005c tp6801" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="pvrusb2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse joystick synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" LIRC_DEVICES="hauppauge hauppauge_dvb" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="dummy fbdev nv vesa nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Fred Passerin 2012-12-08 15:44:24 UTC
I had the same problem.

Disabling distcc permits to compile tdb successfully.
Comment 2 Ciprian Ciubotariu 2013-03-29 23:49:36 UTC
Happened to me as well, with distcc enabled.

Shouldn't such ebuilds disable distcc automagically?
Comment 3 Sergey Popov gentoo-dev Security 2013-05-27 09:02:55 UTC
Confirming this issue, tdb 1.2.11. Happens only when using FEATURES="distcc"
Comment 4 Joe Breuer 2013-06-03 11:50:54 UTC
See also bug #379837
Comment 5 Sergey Popov gentoo-dev Security 2013-06-04 03:42:08 UTC

*** This bug has been marked as a duplicate of bug 379837 ***