Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 444964 - x11-drivers/xf86-video-ati-7.0.0 with x11-base/xorg-server-1.13 - second X server fails to start on second card
Summary: x11-drivers/xf86-video-ati-7.0.0 with x11-base/xorg-server-1.13 - second X se...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-27 18:54 UTC by Dusanc
Modified: 2015-02-22 21:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xorg.conf.0 (xorg.conf.0,2.04 KB, text/plain)
2012-11-27 18:59 UTC, Dusanc
Details
xorg.conf.1 (xorg.conf.1,1.93 KB, text/plain)
2012-11-27 18:59 UTC, Dusanc
Details
/etc/X11/gdm/custom.conf (custom.conf,455 bytes, text/plain)
2012-11-27 19:00 UTC, Dusanc
Details
Working Xservers log (Xorg.0.log,43.48 KB, text/plain)
2012-11-27 19:03 UTC, Dusanc
Details
Non working Xserver log (Xorg.1.log,19.44 KB, text/plain)
2012-11-27 19:04 UTC, Dusanc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dusanc 2012-11-27 18:54:40 UTC
After the update from xorg-server 1.12 to 1.13 my multiseat setup with 2 graphic cards (Radeon HD3450 and HD5430) with a separate xserver on each of them stopped working Whichever server starts 2nd it fails (tried different combinations on diff cards) with message:
(EE) RADEON(0): [drm] failed to set drm interface version.
(EE) RADEON(0): Kernel modesetting setup failed

As can be seen in the link to fdo bug report it happens to other multiseat ATI users too.
I tried kernels from 2.6.39 to 3.6.6

I use GDM and custom.conf is:
[servers]
0=Standard1
1=Standard0

[server-Standard0]
name=Standard server 0
command=/usr/bin/X1 -config xorg.conf.1 -nolisten tcp -layout seat1 -novtswitch -isolateDevice PCI:3:0:0 -sharevts -xinerama -keeptty
flexible=false

[server-Standard1]
name=Standard server 1
command=/usr/bin/X0 -config xorg.conf.0 -nolisten tcp -layout seat0 -novtswitch -isolateDevice PCI:1:0:0 -xinerama -keeptty
flexible=false



Reproducible: Always

Steps to Reproduce:
1. Have 2 separate graphic cards
2. Xorg -config xorg.conf.0 -nolisten tcp -isolateDevice PCI:1:0:0 &
Xorg -config xorg.conf.1 -nolisten tcp -isolateDevice PCI:3:0:0
3.
Actual Results:  
First seat (display, mouse and keyboard) had working login screen
Second seat displayed Xorg blue screen with error message

Expected Results:  
Second seat (display, mouse and keyboard) should have working login screen

emerge --info
Portage 2.1.11.31 (default/linux/amd64/10.0/desktop, gcc-4.5.4, glibc-2.15-r3, 2.6.39.4 x86_64)
=================================================================
System uname: Linux-2.6.39.4-x86_64-Intel-R-_Core-TM-2_CPU_6400_@_2.13GHz-with-gentoo-2.1
Timestamp of tree: Tue, 27 Nov 2012 17:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-lang/python:          2.6.6-r2, 2.7.3-r2, 3.1.4-r3, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.5
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.bih.net.ba/gentoo/ http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr automount branding bzip2 cairo cdda cdr cli consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr emboss encode exif fam fax ffmpeg flac gdbm gif gnome gnutls gphoto2 gpm gstreamer gtk h323 iconv joystick jpeg jpeg2k kdrive lame lcms ldap libnotify lm_sensors logrotate lzo mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nptl nsplugin ogg openmp pam pango pcre pdf png policykit ppds pppd pulseaudio quicktime readline samba sane scanner sdl session smp spell sse sse2 ssl ssse3 startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower usb v4l v4l2 vorbis wxwidgets x264 xcb xml xml2 xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Dusanc 2012-11-27 18:59:10 UTC
Created attachment 330746 [details]
xorg.conf.0
Comment 2 Dusanc 2012-11-27 18:59:36 UTC
Created attachment 330748 [details]
xorg.conf.1
Comment 3 Dusanc 2012-11-27 19:00:52 UTC
Created attachment 330750 [details]
/etc/X11/gdm/custom.conf
Comment 4 Dusanc 2012-11-27 19:03:46 UTC
Created attachment 330752 [details]
Working Xservers log
Comment 5 Dusanc 2012-11-27 19:04:16 UTC
Created attachment 330754 [details]
Non working Xserver log
Comment 6 Jeroen Roovers gentoo-dev 2012-11-27 22:17:31 UTC
Please post your `emerge -vpq x11-drivers/xf86-video-ati' output in a comment.
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-28 01:00:33 UTC
xf86-video-ati-7.0.0 supports only KMS. "cat /proc/fb" must output radeondrmfb, else you don't have KMS and need to enable it in your kernel. Note that if you build radeon as module, you must ensure that it loads before the X server starts.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-28 01:04:36 UTC
Also check if it works with xf86-video-ati-6.14.6-r1
Comment 9 Dusanc 2012-11-28 21:30:11 UTC
krshina3 ~ # emerge -vpq x11-drivers/xf86-video-ati
[ebuild   R   ] x11-drivers/xf86-video-ati-7.0.0  USE="udev (-glamor)"

krshina3 ~ # cat /proc/fb
0 radeondrmfb
1 radeondrmfb

Downgrading to xf86-video-ati-6.14.6-r1 did the trick, it works now, so it's not the problem with xserver, but with drivers.

Thanks a lot for the help
Comment 10 Matt Turner gentoo-dev 2015-02-22 21:56:07 UTC
Hopefully fixed long ago. If not, open a bug upstream https://bugs.freedesktop.org/enter_bug.cgi?product=xorg&component=Driver/Radeon