Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 44391 - gentoo-sources-2.4.22 is unstable under heavy load
Summary: gentoo-sources-2.4.22 is unstable under heavy load
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: x86-kernel@gentoo.org (DEPRECATED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-11 14:10 UTC by Róbert Čerňanský
Modified: 2004-04-16 17:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
My kernel config (.config,33.20 KB, text/plain)
2004-03-11 14:12 UTC, Róbert Čerňanský
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Róbert Čerňanský 2004-03-11 14:10:08 UTC
After upgrading my system I notice that applications causing
segfaults often. I figured out that this happens only with new
kernel (gentoo-sources-2.4.22-r5 and r7). When I boot previous
kernel (gentoo-sources-2.4.20-r9) system is stable.

It is hard to find exact steps to reproduce this, but it happens
when system is under heavy load (when lot of memory and swap is
used - I have only 64MB RAM so it is quite often). For example, when
I run OpenOffice and few other apps then after few hours of work
some apps end up with Segmentation Fault.
I tried to make very large image in Gimp. After few minutes of
swapping goes down whole X-windows (and lot of daemons).

I foud this message in /var/log/everything/current:

Mar 11 21:53:35 [kernel] Unable to handle kernel paging request at virtual address 01c00085
                - Last output repeated twice -
Mar 11 21:53:36 [devfsd] action_compat: error unlinking: "vcs10"

After this, system was unusable so I synced disks and rebooted with
magic keys (Alt+SysRq...).

I tested disks and memory - both are OK.


# emerge --info
Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.22-gentoo-r7)
=================================================================
System uname: 2.4.22-gentoo-r7 i586 Pentium MMX
Gentoo Base System version 1.4.3.13
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.7.7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-mcpu=pentium-mmx -march=pentium-mmx -mmmx -O2 -fomit-frame-pointer -falign-functions=4 -falign-jumps=4"
CHOST="i586-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=pentium-mmx -march=pentium-mmx -mmmx -O2 -fomit-frame-pointer -falign-functions=4 -falign-jumps=4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/opt/reserve/install/portage"
SYNC="rsync://rsync.belnet.be/gentoo-portage"
USE="3dfx X aalib avi berkdb bluetooth bonobo crypt cups dga directfb emacs encode esd fbcon foomaticdb gdbm ggi gif gphoto2 gpm gtk gtk2 gtkhtml guile imlib java jpeg leim libg++ libwww mad maildir mikmod mmx motif mpeg mule ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline samba sdl slang spell ssl svga tcltk tcpd tetex truetype usb voodoo3 x86 xface xml2 xmms xv zlib"
Comment 1 Róbert Čerňanský 2004-03-11 14:12:52 UTC
Created attachment 27218 [details]
My kernel config
Comment 2 Jason Cox (RETIRED) gentoo-dev 2004-04-13 13:03:30 UTC
Does this still exist with any of the 2.4.25 kernels? Have you tried a vanilla kernel to see if the problem is still around?
Comment 3 Jason Cox (RETIRED) gentoo-dev 2004-04-16 17:54:56 UTC
Assuming a newer kernel fixed this one. Unstable is usually only specific to one kernel, or there's an underlying hardware problem.