Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 44384 - ACCESS DENIED when emerging alsa-driver with portage-2.0.50-r1 and alsa-driver-1.0.3
Summary: ACCESS DENIED when emerging alsa-driver with portage-2.0.50-r1 and alsa-drive...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2004-03-11 12:16 UTC by David Bailey
Modified: 2004-03-19 15:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description David Bailey 2004-03-11 12:16:25 UTC
alsa-driver 0.98 didn't work with kernel 2.6.4-rc1 so I tried using newer alsa-drivers 1.0 and later.

Always seem to get the following error and can't find a solution-

make[1]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.3/work/alsa-driver-1.0.3'
make -C /usr/src/linux SUBDIRS=/var/tmp/portage/alsa-driver-1.0.3/work/alsa-driver-1.0.3/kbuild modules
make[1]: Entering directory `/usr/src/linux-2.6.4-rc1'
  MKELF   scripts/elfconfig.h
ACCESS DENIED  open_wr:   /usr/src/linux-2.6.4-rc1/scripts/elfconfig.h
/bin/sh: line 1: scripts/elfconfig.h: Permission denied
make[2]: *** [scripts/elfconfig.h] Error 1
make[1]: *** [scripts] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.4-rc1'
make: *** [compile] Error 2

!!! ERROR: media-sound/alsa-driver-1.0.3 failed.
!!! Function src_compile, Line 66, Exitcode 2
!!! Parallel Make Failed

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-media-sound_-_alsa-driver-1.0.3-8718.log"

open_wr:   /usr/src/linux-2.6.4-rc1/scripts/elfconfig.h

I tried assigning both the elfconfig.h and then the whole linux-2.6.4-rc1 first to the portage and then wheel groups and tried making them all group read-write. None of this helped, so I put everything back to group root.

I also tried to emerge sync and emerge portage, but this didn't help.

Reproducible: Always
Steps to Reproduce:
1. I don't know that I am doing anything special.

Expected Results:  
Emerged alsa-drivers

Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.6.4-rc1)
System uname: 2.6.4-rc1 i686 Intel(R) Pentium(R) M processor 1600MHz
Gentoo Base System version
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.2
CFLAGS="-O3 -march=i686 -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -march=i686 -funroll-loops -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="X apm arts avi berkdb crypt cups encode esd foomaticdb gdbm gif gnome gpm
gtk gtk2 guile imlib java jpeg kde libg++ libwww mad mikmod motif mozilla mpeg
mysql ncurses nls oggvorbis opengl oss pam pdflib perl png postgres python qt
quicktime readline sdl slang spell ssl svga tcltk tcpd truetype
video_cards_radeon x86 xml2 xmms xv zlib"
Comment 1 Jeremy Huddleston (RETIRED) gentoo-dev 2004-03-11 19:06:40 UTC
you need >=alsa-driver-1.0.2c if you use a 2.6.x kernel.
Comment 2 David Bailey 2004-03-12 04:50:30 UTC
If you'll read past the first line, you'll see that this also occurred with alsa-driver 1.0.2c and 1.0.3.
Comment 3 James 2004-03-17 07:14:57 UTC
Same problem here. kernel 2.6.4-rc1, alsa-driver 1.0.3
Comment 4 David Bailey 2004-03-17 07:21:20 UTC
I finally got this working. I realized that I had compiled alsa into the kernel and was having some other kernel recompile wierdness. After some work and reboots, I got things going by skipping the alsa-driver, and just emerging the alsa-utils and related files.

I think perhaps the code that's supposed to check to see whether or not alsa is in the kernel doesn't work unless it's the active kernel, and you end up with this message, although I haven't tried to reproduce this.
Comment 5 Martin Holzer (RETIRED) gentoo-dev 2004-03-19 01:40:38 UTC
kernel 2.6.4 provides alsa-driver and has 1.0.3 built in

Comment 6 Jeremy Huddleston (RETIRED) gentoo-dev 2004-03-19 15:15:04 UTC
although alsa-driver >= 1.0.2c SHOULD work with 2.6 kernels if you want or need to use it instead of what's in-kernel... however there are problems getting it to work due to sandbox issues like this one and other issues... unfortunately nobody has submitted a patch for us to use to get it to work, and I can't run 2.6 for other reasons to test it out...