Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 44381 - emerge kdepim-3.2.1 fails (during kmail compile)
Summary: emerge kdepim-3.2.1 fails (during kmail compile)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-03-11 11:38 UTC by Robert Peter
Modified: 2004-04-26 18:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Robert Peter 2004-03-11 11:38:34 UTC
The update of kdepim 3.2.1 fails every time I try. I tried lowering cflags and tried both 2.4 and 2.6 kernel headers. Running kernel 2.6.3, qt 3.3.1.

Output of emerge:
/usr/qt/3/bin/moc folderpropertiesdialog.h -o folderpropertiesdialog.moc
make[3]: *** No rule to make target `../ktnef/lib/', needed by `'.  Stop.
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/kdepim-3.2.1/work/kdepim-3.2.1/kmail'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdepim-3.2.1/work/kdepim-3.2.1/kmail'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdepim-3.2.1/work/kdepim-3.2.1'
make: *** [all] Error 2

Reproducible: Always
Steps to Reproduce:
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2004-03-11 11:46:42 UTC
probably a parallel build error.  changing your MAKEOPTS to -j1 in make.conf might fix the problem for you.
Comment 2 Robert Peter 2004-03-11 12:46:18 UTC
MAKEOPTS="-j1" did not solve this, same error.
Comment 3 Caleb Tennis (RETIRED) gentoo-dev 2004-03-11 13:17:54 UTC
It's interesting.  I suppose it has to do with the order in which stuff is being compiled in kdepim.  For some reason yours is going in a different order than what is expected.

I did some looking and can't really see why it would be doing this.  There may be a way to trick it into compiling first; not sure.  You may want to try and get in touch with one of the kdepim folks, either on the kde mailinglists or IRC.
Comment 4 Robert Peter 2004-03-12 03:26:16 UTC
The error seems to be caused by DO_NOT_COMPILE-flags I set. I got the following ones which affect kdepim: "kmobile ktnef korn kpilot ksync kitchensync kalarmd karm kandy kalarm konsolekalendar kontact korganizer"
Comment 5 Caleb Tennis (RETIRED) gentoo-dev 2004-03-12 04:59:04 UTC
Well, obviously from the bug kmail needs ktnef, and probably some others.
Comment 6 Caleb Tennis (RETIRED) gentoo-dev 2004-04-26 18:05:13 UTC
the DO_NOT_COMPILE chain turned off some dependencies.  I think of this as a bug, but it's an upstream one.  If you would like to see it fixed, please describe it at and maybe the kde people will pick it up :)