Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 443018 - fsck on /usr fails because it is already mounted
Summary: fsck on /usr fails because it is already mounted
Status: RESOLVED DUPLICATE of bug 410605
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: OpenRC (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: OpenRC Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 20:26 UTC by Roland
Modified: 2012-12-20 22:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland 2012-11-13 20:26:50 UTC
Hello,

after a Upgrade to udev-194 or 195. The Filesystemcheck for the mountpoint /usr fails because it is already mounted. The other Mountpoints work fine. I don't know how to get a better error discription.

 sys-fs/udev-195  USE="acl gudev hwdb keymap openrc -doc -introspection (-selinux) -static-libs" 0 kB
Comment 1 Jeroen Roovers gentoo-dev 2012-11-13 22:52:05 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the boot log to this bug report.
Comment 2 Roland 2012-11-14 06:52:29 UTC
emerge --info
Portage 2.1.11.31 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r3, 3.6.5-gentoo x86_64)
=================================================================
System uname: Linux-3.6.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Tue, 13 Nov 2012 16:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4::gnome
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo zugaina stuff multimedia chtekk-apps sunrise suka gnome rebutia sabayon pinkbyte bleeding-edge x-myoverlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j18"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/stuff /var/lib/layman/multimedia /var/lib/layman/chtekk-apps /var/lib/layman/sunrise /var/lib/layman/suka /var/lib/layman/gnome /var/lib/layman/rebutia /var/lib/layman/sabayon /var/lib/layman/pinkbyte /var/lib/layman/bleeding-edge /usr/portage/local/myoverlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif glitz gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk hal i18n iconv ieee1394 ipv6 jack jack-tmpfs jpeg lame lash lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf png policykit portaudio ppds pppd pulseaudio qt3support qt4 rar readline samba screenshot sdl session socialweb spell sse sse2 ssl startup-notification svg swf tcpd threads tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xinerama xml xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="ttpci cx18 cx231xx cx23885 usb-dw2104" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="pdfimport wiki-publisher" LINGUAS="de" LIRC_DEVICES="serial igorplugusb" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel i128 i810" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Roland 2012-11-14 07:23:52 UTC
  OpenRC 0.10.5 is starting up Gentoo Linux (x86_64)

 * /proc is already mounted
 * Mounting /run ...
 * /run/openrc: creating directory
 * /run/lock: creating directory
 * /run/lock: correcting owner
 * Mounting config filesystem ...
 [ ok ]
 * Mounting cgroup filesystem ...
 [ ok ]
 * Using /dev mounted from kernel ...
 [ ok ]
 * Starting udev ...
 [ ok ]
 * Populating /dev with existing devices through uevents ...
 [ ok ]
 * Waiting for uevents to be processed ...
 [ ok ]
 * Mounting /dev/shm ...
 [ ok ]

rc sysinit logging stopped at Wed Nov 14 08:19:24 2012


rc boot logging started at Wed Nov 14 08:19:24 2012

 * Setting system clock using the hardware clock [UTC] ...
 [ ok ]
 * Loading module vboxdrv ...
 [ ok ]
 * Loading module vboxnetflt ...
 [ ok ]
 * Loading module vboxnetadp ...
 [ ok ]
 * Loading module vboxpci ...
 [ ok ]
 * Loading module vhba ...
 [ ok ]
 * Autoloaded 5 module(s)
 * Setting up the Logical Volume Manager ...
  No volume groups found
  No volume groups found
  No volume groups found
 [ ok ]
 * Checking local filesystems  ...
/dev/sda8: sauber, 37576/788416 Dateien, 2352343/3148732 Blöcke
/dev/sda5 ist eingehängt.  e2fsck: Fortsetzung nicht möglich, breche ab.


/dev/sda6: sauber, 2819/788416 Dateien, 244738/3148732 Blöcke
Comment 4 SpanKY gentoo-dev 2012-11-14 23:32:30 UTC
udev doesn't run fsck or anything else related to filesystems

please post your /etc/fstab as an attachment

are you using an initramfs ?  how is your /usr getting mounted ?
Comment 5 William Hubbs gentoo-dev 2012-11-17 18:54:57 UTC
Is this a dupe of #410605?
Comment 6 Roland 2012-11-18 13:12:02 UTC
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1		/boot		ext2		noauto,noatime	1 2
/dev/sda8		/		ext4		noatime		0 1
/dev/sda5		/usr		ext4		noatime		0 1
/dev/sda6		/opt		ext4		noatime		0 1
/dev/sda7		/tmp		ext4		noatime		0 1
/dev/sda9		/var		ext4		noatime		0 1
/dev/sda10		/var/tmp	ext4		noatime		0 1
/dev/sda11		/home		ext4		noatime		0 1
/dev/md/127_0		/home/samba	ext4		noatime		0 1
/dev/cdrom		/mnt/cdrom	auto		noauto,ro	0 0
#/dev/fd0		/mnt/floppy	auto		noauto		0 0

yes I use a initramfs
mount

mount
rootfs on / type rootfs (rw)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=1922318,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda8 on / type ext4 (rw,noatime,commit=0)
/dev/sda5 on /usr type ext4 (rw,noatime,commit=0)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc)
cpuset on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cpuacct on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda6 on /opt type ext4 (rw,noatime,commit=0)
/dev/sda7 on /tmp type ext4 (rw,noatime,commit=0)
/dev/sda9 on /var type ext4 (rw,noatime,commit=0)
/dev/sda10 on /var/tmp type ext4 (rw,noatime,commit=0)
/dev/sda11 on /home type ext4 (rw,noatime,commit=0)
/dev/md127 on /home/samba type ext4 (rw,noatime,commit=0)
Comment 7 William Hubbs gentoo-dev 2012-12-20 22:09:56 UTC

*** This bug has been marked as a duplicate of bug 410605 ***