Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442818 - dev-lang/smlnj-110.75 - bin/sml: Fatal error -- bogus fault not in ML: sig = 11, code = 0x5356c35d, pc = 0x5356c35d)
Summary: dev-lang/smlnj-110.75 - bin/sml: Fatal error -- bogus fault not in ML: sig = ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-11 22:04 UTC by Sven E.
Modified: 2019-12-13 14:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (smlnj.build.log,152.50 KB, text/plain)
2012-11-12 21:33 UTC, Sven E.
Details
emerge --info (emerge.info,3.32 KB, text/plain)
2012-11-12 21:44 UTC, Sven E.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven E. 2012-11-11 22:04:43 UTC
dev-lang/smlnj-110.75 fails to build with an error from sml:
Fatal error -- bogus fault not in ML: sig = 11, code = 0x5356c35d, pc = 0x5356c35d

Reproducible: Always

Steps to Reproduce:
1. emerge said version of smlnj
Actual Results:  
Build failure

Expected Results:  
Clean build

The Problem seems to be limited to the 4.6 branch of gcc, I tried 2 different 4.6.x versions to confirm this. Building with 4.4/4.5 seems to work as expected.
Comment 1 Sven E. 2012-11-11 22:07:37 UTC
USE flags used to build gcc are:

sys-devel/gcc-4.6.3:4.6  USE="cxx fortran gcj gtk mudflap nls nptl objc objc++ openmp (-altivec) -bootstrap -build -doc (-fixed-point) -go -graphite (-hardened) (-libssp) (-multilib) -multislot -nocxx -nopie -nossp -objc-gc {-test} -vanilla"
Comment 2 Jeroen Roovers gentoo-dev 2012-11-12 12:47:31 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 3 Sven E. 2012-11-12 21:33:05 UTC
Created attachment 329396 [details]
build.log
Comment 4 Sven E. 2012-11-12 21:44:05 UTC
Created attachment 329406 [details]
emerge --info
Comment 5 Max Klinger 2013-04-22 15:25:38 UTC
I have the same problem for gcc 4.6.3 and both versions of the smlnj in the tree (110.71 110.75). There seems to be no open bug report that I could find upstream. Would temporarily setting the gcc version higher/lower merging the sml and then setting it back to 4.6 again work? Has anyone tried?
Comment 6 Max Klinger 2013-04-22 20:54:06 UTC
This problem seems to be restricted to gcc 4.6. I successfully compiled smlnj with 4.5.4, 4.7.2-r1 and 4.8.0 and they all appear to run without a trouble, so changing the gcc-version, compiling smlnj and changing it back is an option, but it's dirty.
Comment 7 O. William McClung 2013-11-20 14:37:56 UTC
I can confirm that I was able to compile smlnj-110.75 with with gcc-4.5.4 but received the error message mentioned in this bug with both gcc-4.6.3 and gcc-4.7.3.