Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442394 (kde-4.9.3-stable) - KDE 4.9.3 stabilization
Summary: KDE 4.9.3 stabilization
Status: RESOLVED FIXED
Alias: kde-4.9.3-stable
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: kde-4.9-keyword 432924 437610 440344 440694 440710 440854 441456 441898 441956 442278 442510 444664
Blocks: CVE-2012-4512
  Show dependency tree
 
Reported: 2012-11-08 23:34 UTC by Chris Reffett
Modified: 2013-10-06 15:29 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kde-4.9.3-stablelist.txt (kde-4.9.3-stablelist.txt,9.80 KB, text/plain)
2012-11-09 16:19 UTC, Chris Reffett
Details
kde-4.9.3-stablelist-v2.txt (kde-4.9.3-stablelist-v2.txt,9.87 KB, text/plain)
2012-11-09 22:16 UTC, Chris Reffett
Details
kde-4.9.3-stablelist-v3.txt (kde-4.9.3-stablelist-v3.txt,10.27 KB, text/plain)
2012-11-13 23:07 UTC, Chris Reffett
Details
kde-4.9.3-stablelist-v4.txt (kde-4.9.3-stablelist-v4.txt,10.27 KB, text/plain)
2012-11-14 02:51 UTC, Chris Reffett
Details
kde-4.9.3-stablelist-v5.txt (kde-4.9.3-stablelist-v5.txt,10.07 KB, text/plain)
2012-11-16 22:33 UTC, Johannes Huber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Reffett gentoo-dev Security 2012-11-08 23:34:34 UTC
KDE SC 4.9.3 will be the next stable KDE candidate. We will be wanting to stabilize this faster than normal, because to the best of my knowledge it fixes the security vulnerabilities noted in bug 438452. This will also be the first time we will have the kde-stable group helping to locate bugs before stabilization.
Comment 1 Chris Reffett gentoo-dev Security 2012-11-09 16:19:25 UTC
Created attachment 329016 [details]
kde-4.9.3-stablelist.txt

(Apologies if I got the format wrong, this is the first time I've been the one generating the keyword list). Attached is the list of packages to be tested and stabilized, it includes 4.9.3 packages, dependencies, and a few miscellaneous packages that we'd like to stabilize at the same time. Herd testers, please install KDE 4.9.3 and start using it. If you encounter any problems, please open a bug and have it block this one. Talk to a KDE team member if you have any questions about the process.
Comment 2 Chris Reffett gentoo-dev Security 2012-11-09 22:16:17 UTC
Created attachment 329042 [details]
kde-4.9.3-stablelist-v2.txt
Comment 3 Fabian Henze 2012-11-09 22:21:24 UTC
Seems like some packages are missing?

#required by kde-base/kjots-4.9.3
=dev-libs/grantlee-0.2.0
#required by kde-base/libkcddb-4.9.3[musicbrainz]
=media-libs/musicbrainz-5.0.1
#required by kde-base/kdepimlibs-4.9.3[semantic-desktop]
=app-office/akonadi-server-1.8.1
#required by kde-base/kdelibs-4.9.3[semantic-desktop]
=dev-libs/soprano-2.8.0

This is on an otherwise pretty stable amd64 system.
Comment 4 academicsam@gmail.com 2012-11-10 14:38:10 UTC
On an otherwise stable amd64 system, I also needed following

#required by kde-base/kleopatra-4.9.3
=app-crypt/gpgme-1.3.2 ~amd64
Comment 5 David Flogeras 2012-11-10 14:54:54 UTC
I also needed to add

>=app-test/poppler-0.20

for PDF support in okular
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2012-11-11 11:13:25 UTC
(In reply to comment #5)
> I also needed to add
> 
> >=app-test/poppler-0.20
> 
> for PDF support in okular

The poppler is handled in different bug.
Comment 7 Chris Reffett gentoo-dev Security 2012-11-11 18:43:22 UTC
And kdeaccounts-plugin-4.9.3 shouldn't be on the list. Sorry about the delay here, been busy the past few days, but I'll try to get an updated stable list out soon.
Comment 8 Chris Reffett gentoo-dev Security 2012-11-13 23:07:28 UTC
Created attachment 329496 [details]
kde-4.9.3-stablelist-v3.txt

Updated stabilization list.
Comment 9 Chris Reffett gentoo-dev Security 2012-11-14 02:51:07 UTC
Created attachment 329500 [details]
kde-4.9.3-stablelist-v4.txt

Bump konqueror stable target to -r1.
Comment 10 Johannes Huber gentoo-dev 2012-11-14 10:29:14 UTC
Comment on attachment 329500 [details]
kde-4.9.3-stablelist-v4.txt

>#required by kde-base/kleopatra-4.9.3
>=app-crypt/gpgme-1.3.2

already handled in bug #441956 (see depends on)

>#required by kde-base/okular-4.9.3
>>=app-test/poppler-0.20

already handled in bug #437610 (see depends on)

># Renamed since 4.9.3
># kde-base/kbattleship -> kde-base/knavalbattle
># kde-base/ktron -> kde-base/ksnakeduel

since 4.9.2
Comment 11 Johannes Huber gentoo-dev 2012-11-16 22:33:51 UTC
Created attachment 329678 [details]
kde-4.9.3-stablelist-v5.txt
Comment 12 Agostino Sarubbo gentoo-dev 2012-11-17 13:55:56 UTC
Dear Testers..sorry for the mailspam.

The latest list looks good, so add it to your package.keywords and proceed with the testing.
You don't need to install all packages, just run emerge -DuN world and update what you have.

As said by creffett, please report any issue on irc.
Comment 13 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2012-11-17 16:09:05 UTC
amd64: looks ok ( i had installed last stable kdebase-startkde as start point)
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2012-11-17 18:33:18 UTC
x86: same result for same start point
Comment 15 Andrius Štikonas 2012-11-18 12:21:18 UTC
#required by dev-cpp/libxsd-frontend-1.17.0, required by dev-cpp/xsd-3.3.0, required by net-libs/libkolabxml-0.8.1, required by net-libs/libkolab-0.3.2, required by kde-base/kdepim-runtime-4.9.3[kolab], required by kde-base/kdepim-meta-4.9.3, required by kde-base/kde-meta-4.9.3[semantic-desktop], required by @selected, required by @world (argument)
=dev-util/build-0.3.9 ~amd64
#required by dev-cpp/libxsd-frontend-1.17.0, required by dev-cpp/xsd-3.3.0, required by net-libs/libkolabxml-0.8.1, required by net-libs/libkolab-0.3.2, required by kde-base/kdepim-runtime-4.9.3[kolab], required by kde-base/kdepim-meta-4.9.3, required by kde-base/kde-meta-4.9.3[semantic-desktop], required by @selected, required by @world (argument)
=dev-cpp/libfrontend-elements-1.1.4 ~amd64
Comment 16 Sebastian 2012-11-23 09:14:56 UTC
Hello,

I updated with the help of your stable list on an amd64, too. Install went fine.

On first start plasma desktop was switched to Search & Launch mode. Going back to my previous Folder View mode I ran into KDE bug 253485.

https://bugs.kde.org/show_bug.cgi?id=253485

My desktop looked like the one you can see in the screen-shot in comment #8 in above bug report.

On a hunch I logged out of KDE and deleted the plasma* files in ~/.kde4/share/config. I then had to configure the plasma desktop to my liking once again, but at least I didn't have to remove ~/.kde4 completely.

Otherwise 4.9.3 seems to work like a charm since yesterday.
Comment 17 Sebastian 2012-11-23 09:17:05 UTC
Ups, actually it's in comment #6.
Comment 18 Enrico Tagliavini 2012-11-23 09:31:34 UTC
There are a lot of this strange bugs, which happens only rarely and most of the times they are one time issues. Usually there is a workaround like you case.

Another example (and you can find other examples listed there) is https://bugs.kde.org/show_bug.cgi?id=294795 .

I don't think this is a blocker. Most of these bugs are not 4.9 specific.

Side note: I had to reconfigure my desktop too even if I don't use folderview for the entire desktop.
Comment 19 João Paulo Teixeira 2012-11-23 19:08:18 UTC
So far these packages are still keyworded with ~amd64; they are dependencies of stabilized kde-4.9.3 packages.  

=kde-base/systemsettings-4.9.3
=kde-base/solid-runtime-4.9.3
=kde-base/superkaramba-4.9.3
=kde-base/svgpart-4.9.3
=kde-base/sweeper-4.9.3
=kde-base/rocs-4.9.3
=kde-base/solid-4.9.3
=kde-base/renamedlg-plugins-4.9.3
=kde-base/thumbnailers-4.9.3
=kde-base/system-config-printer-kde-4.9.3
=kde-base/step-4.9.3
Comment 20 João Paulo Teixeira 2012-11-23 19:12:46 UTC
(In reply to comment #19)

Solved on the last portage update!
Comment 21 Agostino Sarubbo gentoo-dev 2012-11-24 19:39:29 UTC
Thanks everyone. Now kde-4.9.3 is stable on amd64 and x86.

ppc is a work in progress.
Comment 22 Agostino Sarubbo gentoo-dev 2012-11-30 16:56:30 UTC
ppc done
Comment 23 Andreas K. Hüttel gentoo-dev 2012-11-30 18:09:37 UTC
I guess we're done here!