Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442322 - dev-db/myodbc-5.1.6 - Build fails against dev-db/mysql-5.5.28 - error: too many arguments to function 'my_free'
Summary: dev-db/myodbc-5.1.6 - Build fails against dev-db/mysql-5.5.28 - error: too ma...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL: http://bugs.mysql.com/bug.php?id=59473
Whiteboard:
Keywords:
: 521274 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-08 08:43 UTC by Bernd Feige
Modified: 2014-08-28 13:11 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
myodbc-5.1.11.ebuild (myodbc-5.1.11.ebuild,3.39 KB, application/octet-stream)
2012-11-12 10:23 UTC, Bernd Feige
Details
Patch to driver/Makefile.am adding three required files... (myodbc_driver_my_stmt_am.patch,275 bytes, text/plain)
2012-11-12 10:24 UTC, Bernd Feige
Details
myodbc-5.2.2.ebuild for current version, using cmake (myodbc-5.2.2.ebuild,2.74 KB, text/plain)
2012-11-13 08:50 UTC, Bernd Feige
Details
myodbc-5.2.4.ebuild for current version, using cmake (myodbc-5.2.4.ebuild,2.91 KB, text/plain)
2013-03-09 11:35 UTC, Bernd Feige
Details
myodbc-5.2.4-cmake.patch (myodbc-5.2.4-cmake.patch,2.72 KB, patch)
2013-03-09 11:36 UTC, Bernd Feige
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Feige 2012-11-08 08:43:33 UTC
As stated in the referenced bug report, upgrading to the newest version of myodbc (newer 5.1 or current 5.2, https://code.launchpad.net/myodbc) should fix this.
Regards,
Bernd

Reproducible: Always
Comment 1 Bernd Feige 2012-11-12 10:23:59 UTC
Created attachment 329318 [details]
myodbc-5.1.11.ebuild

For good measure, this is an updated version for 5.1.11 that works for me - including the addition of 3 files to Makefile.am.
Appears as if the project switched to cmake and didn't update the autotools sources... Probably should use cmake then.
The ebuild needs the next patch in ${FILESDIR}...
Comment 2 Bernd Feige 2012-11-12 10:24:39 UTC
Created attachment 329320 [details]
Patch to driver/Makefile.am adding three required files...
Comment 3 Bernd Feige 2012-11-13 08:50:32 UTC
Created attachment 329444 [details]
myodbc-5.2.2.ebuild for current version, using cmake

And here for the current version 5.2.2, using cmake, so no patches required. Support for USE flags should still be reviewed / added. Also the current FindODBC won't expose odbc_config --libs to the build system, needed to added -lodbc by hand.
Comment 4 James L. Hammons 2012-11-16 21:32:57 UTC
I can confirm this bug on my system (~amd64); also confirm that the newest ebuild attached (5.2.2) works as advertised. Maybe it's time for a revbump? :-)
Comment 5 Trevor Bowen 2012-12-10 18:16:45 UTC
I opted for the 5.1.11 ebuild with patches, and it worked fine for me, correcting the same build errors, which I was seeing.  Please consider at least a bump from 5.1.6 to 5.1.11. ... Thanks!
Comment 6 Hamlet 2013-03-08 23:10:49 UTC
Thanks for the patch... since you are patching, could you also patch the problem similar to the one in bug #445122?
Your ebuild installs two documents in /usr, exactly as mysql-connector does.
This creates a conflict that in my case would prevent the installation of both together.
Installing those files in the usual package subdirectory in /usr/share/doc or similar should do.
Comment 7 Bernd Feige 2013-03-09 11:33:44 UTC
(In reply to comment #6)
> Thanks for the patch... since you are patching, could you also patch the
> problem similar to the one in bug #445122?
> Your ebuild installs two documents in /usr, exactly as mysql-connector does.
> This creates a conflict that in my case would prevent the installation of
> both together.
> Installing those files in the usual package subdirectory in /usr/share/doc
> or similar should do.

Okay, here it is. There are two ways - one would be letting cmake install to the wrong places in the image and correct this manually (as in the #445122 patch). I chose the other route to patch the CMakeList.txt files to add options WITH_DOCUMENTATION_INSTALL_PATH and WITH_TEST_INSTALL_PATH enabling us to set the install paths from the ebuild. One downside currently is that dodoc is not used to install the documentation since it's handled by cmake install. Maybe there's an official solution to that? Only effect right now is that the doc files are not compressed.
"test" files are now installed in /usr/share/myodbc-5.2/test.

If the default paths would be set to "." (currently they're gentoo-ish), there would be no functional change for upstream and they could accept it.

Cheers,
Bernd
Comment 8 Bernd Feige 2013-03-09 11:35:34 UTC
Created attachment 341408 [details]
myodbc-5.2.4.ebuild for current version, using cmake
Comment 9 Bernd Feige 2013-03-09 11:36:33 UTC
Created attachment 341410 [details, diff]
myodbc-5.2.4-cmake.patch
Comment 10 Garri 2013-03-15 07:36:04 UTC
Same problem for me.

myodbc-5.1.11.ebuild with patches solved the problem.
Install phase fails if files odbc.ini.m4 and odbcinst.ini.m4 not copied from original portage to overlay.

Thank you!
Comment 11 Brian Evans Gentoo Infrastructure gentoo-dev 2013-07-29 13:35:37 UTC
dev-db/myodbc-5.2.5 has been pushed to the mysql overlay.

Please test and report if issues are solved.
Comment 12 Bernd Feige 2013-07-30 08:36:01 UTC
(In reply to Brian Evans from comment #11)
> dev-db/myodbc-5.2.5 has been pushed to the mysql overlay.
> 
> Please test and report if issues are solved.

Compiled, installed and worked flawlessly here, thanks!
Comment 13 Alexander Brüning 2013-09-20 15:10:46 UTC
Overlay version works for me as well, as opposed to the portage one.
Comment 14 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-09-20 16:42:03 UTC
(In reply to Alexander Brüning from comment #13)
> Overlay version works for me as well, as opposed to the portage one.

Brian asked me to push the new build to the tree, but I got distracted with other issues. I'll push it this weekend.
Comment 15 Brian Evans Gentoo Infrastructure gentoo-dev 2014-05-04 19:39:57 UTC
Version 5.2.6 added to the tree
Comment 16 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-28 13:11:42 UTC
*** Bug 521274 has been marked as a duplicate of this bug. ***