Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442320 - install-cd (sparc) - errors at boot
Summary: install-cd (sparc) - errors at boot
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: Sparc64 Linux
: Normal major (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2012-11-08 08:43 UTC by Anton
Modified: 2017-10-22 15:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Anton 2012-11-08 08:43:24 UTC
Some days ago I've tried to install Gentoo upon Netra120 machine driven by UltraSparc-IIe and faced with following problems at boot phase which prevents to normal installation process:
  1. [critical] mkdir /var/run Cannot create directory: File exists
  2. [optional] unmute needs service(s) alsasound
  3. [optional] /etc/sysconfig/mouse: No such file
  4. [unknown]  bootmisc failed to start
  5. [moderate] failed to start syslog-ng: error creating persistent state file: No such file or directory. 
  6. [unknown]  rpcbind failed.

Unability to create /var/run at boot-time leads also to following problems:
  * DHCP does not configure interfaces
  * syslog is not starting
  * SSH server could not be started because of syslog is not running

I've repaired this using following scenario:
  * rm -f /var/run
  * mkdir /var/run
  * mkdir /var/lib/misc [for syslog-ng]
  * start_stop_daemon syslog-ng
  * rpcbind
  * [optional] dhcpcd eth1

But I've failed to start SSH server due to [possibly] broken dynamic libraries. At the generation of keys it raises following error at stage of generating ecdsa key pair
  * ssh-keygen: undefined symbol EC_KEY_new_by_curve_name
I've tried to create fake key pair by putting zero-sized appropriately named files. And I've managed to start SSH daemon but was unable to login. So I continued installation using serial connection.

At the stage of disk partitioning there was problem that disk partitioner:
  * Gentoo Linux Handbook SPARC says that "When prompted for the first cylinder, hit enter". And this is FALSE. This works only for the first partition. For any other partition it shoulde by typed manually.

[Probably lyric paragraf]
At the unpacking stage3 tarball there was message that something is beeing unpacked into wrong directories like (instead of ./usr/*): /usr  ./u/lib ./usr/lb .usr usr/libperl5 ./usrinclude etc. But when I checked by
using ls contents of / and /usr there was no such directories, so I've decide that all of them if caused by
serial connection and the client soft(HyperTerminal of WinXP).
Portage tarball was extracted without v option of tar, so I can't say anything.

I'm not sure a date of minimal install iso I've tried to use but I still have, but I still have it burned and can inspect its contents if needed.
But I guess that it is of September 2012.

Reproducible: Always

Steps to Reproduce:
1. Just try to boot from installation media
Comment 1 Ben Kohler gentoo-dev 2017-02-02 18:31:29 UTC
It's been a little over 4 years, is this still a problem?