Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442144 - firefox 16.0.2 doesn't compile
Summary: firefox 16.0.2 doesn't compile
Status: RESOLVED DUPLICATE of bug 439244
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-07 01:43 UTC by Herbert Wantesh
Modified: 2012-11-07 02:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Herbert Wantesh 2012-11-07 01:43:19 UTC
i get this error while compiling:

x86_64-pc-linux-gnu-gcc -o quarantine.o -c -I../../dist/system_wrappers -include /tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -D_GNU_SOURCE -Dabort=moz_abort -I/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/include -Isrc/include  -I/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc -I. -I../../dist/include  -I/usr/include/nspr -I/usr/include/nss      -fPIC  -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wno-unused -Wno-overlength-strings -Wcast-align -march=core2 -mtune=generic -pipe -mno-avx -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe  -DNDEBUG -DTRIMMED -g -fprofile-use -fprofile-correction -Wcoverage-mismatch -O2 -fomit-frame-pointer -std=gnu99   -include ../../mozilla-config.h -DMOZILLA_CLIENT -MD -MF .deps/quarantine.o.pp /tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/quarantine.c
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c: In function 'malloc_conf_init':
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c:547:5: warning: comparison of unsigned expression < 0 is always false
prof.c
x86_64-pc-linux-gnu-gcc -o prof.o -c -I../../dist/system_wrappers -include /tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -D_GNU_SOURCE -Dabort=moz_abort -I/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/include -Isrc/include  -I/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc -I. -I../../dist/include  -I/usr/include/nspr -I/usr/include/nss      -fPIC  -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wno-unused -Wno-overlength-strings -Wcast-align -march=core2 -mtune=generic -pipe -mno-avx -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe  -DNDEBUG -DTRIMMED -g -fprofile-use -fprofile-correction -Wcoverage-mismatch -O2 -fomit-frame-pointer -std=gnu99   -include ../../mozilla-config.h -DMOZILLA_CLIENT -MD -MF .deps/prof.o.pp /tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/prof.c
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c: In function 'tcache_event':
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c:1736:1: error: corrupted profile info: edge from 0 to 2 exceeds maximal count
hash.c
x86_64-pc-linux-gnu-gcc -o hash.o -c -I../../dist/system_wrappers -include /tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -D_GNU_SOURCE -Dabort=moz_abort -I/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/include -Isrc/include  -I/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc -I. -I../../dist/include  -I/usr/include/nspr -I/usr/include/nss      -fPIC  -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wno-unused -Wno-overlength-strings -Wcast-align -march=core2 -mtune=generic -pipe -mno-avx -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe  -DNDEBUG -DTRIMMED -g -fprofile-use -fprofile-correction -Wcoverage-mismatch -O2 -fomit-frame-pointer -std=gnu99   -include ../../mozilla-config.h -DMOZILLA_CLIENT -MD -MF .deps/hash.o.pp /tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/hash.c
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c: In function 'tcache_get':
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c:1736:1: error: corrupted profile info: edge from 27 to 28 exceeds maximal count
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c: In function 'arena_dalloc':
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/jemalloc.c:1736:1: note: correcting inconsistent profile data
make[5]: *** [jemalloc.o] Error 1
make[5]: *** Waiting for unfinished jobs....
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/arena.c: In function 'arena_tcache_fill_small':
/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/memory/jemalloc/src/src/arena.c:2221:1: note: correcting inconsistent profile data
make[5]: Leaving directory `/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/obj-x86_64-unknown-linux-gnu/memory/jemalloc'
make[4]: *** [libs_tier_base] Error 2
make[4]: Leaving directory `/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/obj-x86_64-unknown-linux-gnu'
make[3]: *** [tier_base] Error 2
make[3]: Leaving directory `/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/obj-x86_64-unknown-linux-gnu'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release/obj-x86_64-unknown-linux-gnu'
make[1]: *** [realbuild] Error 2
make[1]: Leaving directory `/tmp/portage/portage/www-client/firefox-16.0.2/work/mozilla-release'
make: *** [profiledbuild] Error 2


Reproducible: Always

Steps to Reproduce:
1. emerge firefox with pgo USE flag
Comment 1 Herbert Wantesh 2012-11-07 01:44:06 UTC
emerge --info
Portage 2.2.0_alpha142 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.6.6 x86_64)
=================================================================
System uname: Linux-3.6.6-x86_64-Intel-R-_Core-TM-_i5_CPU_750_@_2.67GHz-with-gentoo-2.2
Timestamp of tree: Tue, 06 Nov 2012 23:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo kde local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common"
LINGUAS="en de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude ChangeLog"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit X a52 aac aalib accessibility acpi additions aften akonadi alsa amd64 amr amrnb amrwb apm apng archive asf aspell audio avi browserplugin bzip2 cairo caps cdda cdparanoia classic clucene cmake commercial consolekit cracklib crypt css cups curl custom-cflags custom-optimization cvs cxx daemon dbus device-mapper devil dga dirac divx divx4linux djvu dri dts dvd dvdnav dvdr dvdread ebook egl embedded encode enda eselect exceptions exif expat extensions extras faac faad fam ffmpeg firefox flac fontconfig fortran ftp fts3 fuse g3dvl gallium gcrypt gd gecko geoip gif gimp gimpprint git gles1 gles2 glib glitz gnutls gpl gpm gs gstreamer gtk gtk2 gudev httpd hwdb icecast iconv icu id3 id3tag idn imagemagick imap imlib inotify intel ipc irda jabber java jit jpeg jpeg2k kde kdrive kipi kqemu lame lcms less libkms libnotify libsamplerate libvisual lm_sensors lua lzma lzo mad matroska mdnsresponder-compat mercurial methodjit midi minizip mmx mmxext mng mono mousewarp moznocompose moznoirc moznomail mp2 mp3 mp4 mpeg mplayer mtp mudflap multilib musepack nas ncurses nemesi network nfs nfsv3 nls normalize nptl nptlonly nsplugin nut nxclient ogg okteta openal opencore-amr openexr opengl openmp openssl optimized-qmake otr pam parti pcap pch pcre pdf perl pgo plasma player png policykit poppler-data ppds privacy ps qmake qt-faststart qt3support qt4 quicktime raptor rar readline realmedia redland replaygain rtc rtmp rtsp samba sasl schroedinger scrobbler sdl secure-delete server sesame2 sftp sha512 shout slit smbclient smi smp sna sndfile socks5 speex spell sqlite srt sse sse2 ssh ssl startup-notification stats stream subversion svg system-sqlite tcpd texteffect theora threads threadsafe tiff tk toolbar tordns transcode trayicon tremor truetype twolame udev udisks unicode unlock-notify upower usb userlocales utempter utils vaapi vcd vcdimager vdpau video virtuoso vorbis wallpapers wav wavpack weather webdav-neon webm wma wmf wmp x264 xanim xcb xcomposite xft xml xmp xorg xpdf-headers xprint xv xvfb xvid xvmc zeroconf zip zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CURL_SSL="openssl" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LINGUAS="en de" PYTHON_TARGETS="python3_2" RUBY_TARGETS="ruby18" SANE_BACKENDS="hp5400" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON
Comment 2 Jeroen Roovers gentoo-dev 2012-11-07 02:13:33 UTC

*** This bug has been marked as a duplicate of bug 439244 ***