Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 441770 - =dev-db/mysql-workbench-5.2.45 calls GCC, AR and RANLIB directly
Summary: =dev-db/mysql-workbench-5.2.45 calls GCC, AR and RANLIB directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
: 450216 (view as bug list)
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2012-11-04 19:16 UTC by Vicente Olivert Riera (RETIRED)
Modified: 2013-09-01 07:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
compressed build log (mysql-workbench-5.2.44:20121104-162226.log.bz2,62.63 KB, application/x-bzip2)
2012-11-04 19:26 UTC, Vicente Olivert Riera (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vicente Olivert Riera (RETIRED) gentoo-dev 2012-11-04 19:16:22 UTC
I have observed a little issue in the build log. gcc, ar and ranlib are called directly for libantlr3c_wb. The rest is ok. The problem is only for that lib. Look:

GCC
libtool: link: gcc -shared  -fPIC -DPIC  .libs/antlr3baserecognizer.o .libs/antlr3basetree.o .libs/antlr3basetreeadaptor.o .libs/antlr3bitset.o .libs/antlr3collections.o .libs/antlr3commontoken.o .libs/antlr3commontree.o .libs/antlr3commontreeadaptor.o .libs/antlr3commontreenodestream.o .libs/antlr3convertutf.o .libs/antlr3cyclicdfa.o .libs/antlr3debughandlers.o .libs/antlr3encodings.o .libs/antlr3exception.o .libs/antlr3filestream.o .libs/antlr3inputstream.o .libs/antlr3intstream.o .libs/antlr3lexer.o .libs/antlr3parser.o .libs/antlr3rewritestreams.o .libs/antlr3string.o .libs/antlr3tokenstream.o .libs/antlr3treeparser.o   -Wl,--as-needed  -O2 -Wl,-O1 -Wl,--hash-style=gnu   -Wl,-soname -Wl,libantlr3c_wb.so -o .libs/libantlr3c_wb.so

AR
libtool: link: ar cru .libs/libantlr3c_wb.a  antlr3baserecognizer.o antlr3basetree.o antlr3basetreeadaptor.o antlr3bitset.o antlr3collections.o antlr3commontoken.o antlr3commontree.o antlr3commontreeadaptor.o antlr3commontreenodestream.o antlr3convertutf.o antlr3cyclicdfa.o antlr3debughandlers.o antlr3encodings.o antlr3exception.o antlr3filestream.o antlr3inputstream.o antlr3intstream.o antlr3lexer.o antlr3parser.o antlr3rewritestreams.o antlr3string.o antlr3tokenstream.o antlr3treeparser.o

RANLIB
libtool: link: ranlib .libs/libantlr3c_wb.a
libtool: install: ranlib /var/tmp/portage/dev-db/mysql-workbench-5.2.44/image//usr/lib/mysql-workbench/libantlr3c_wb.a
Comment 1 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-11-04 19:26:52 UTC
Created attachment 328342 [details]
compressed build log
Comment 2 Hans de Graaff gentoo-dev 2013-03-08 05:50:21 UTC
*** Bug 450216 has been marked as a duplicate of this bug. ***
Comment 3 Hans de Graaff gentoo-dev 2013-09-01 07:25:09 UTC
mysql-workbench-5.2.47-r1 now depends on dev-libs/antlr-c instead of using a bundled copy, so these problems should now be gone as well.