Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 440892 - media-video/vlc-2.0.4 doesn't build with ncurses USE flag turned on
Summary: media-video/vlc-2.0.4 doesn't build with ncurses USE flag turned on
Status: RESOLVED DUPLICATE of bug 438922
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-02 02:47 UTC by Max Klinger
Modified: 2013-01-14 15:38 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,27.94 KB, text/plain)
2012-11-02 02:47 UTC, Max Klinger
Details
emerge info of the package (file_440892.txt,6.31 KB, text/plain)
2012-11-02 03:01 UTC, Max Klinger
Details
config log (file_440892.txt,289.98 KB, text/plain)
2012-11-02 08:55 UTC, Max Klinger
Details
emerge --info ncurses pkgconfig (file_440892.txt,6.20 KB, text/plain)
2013-01-12 22:20 UTC, Sean Santos
Details
emerge --info for 32-bit (emerge_info,5.10 KB, text/plain)
2013-01-14 01:41 UTC, rypervenche
Details
Failed build.log for 32-bit (build.log,26.50 KB, text/plain)
2013-01-14 01:42 UTC, rypervenche
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max Klinger 2012-11-02 02:47:02 UTC
It fails at,

checking for NCURSES... no
configure: error: No package 'ncursesw' found.

even though ncurses is installed and current

[I] sys-libs/ncurses
     Available versions:  (5) 5.7-r7 5.9 ~5.9-r1 5.9-r2


Reproducible: Always

Steps to Reproduce:
1. USE=ncurses emerge vlc
2.
3.
Actual Results:  
no profit

Expected Results:  
nvlc
Comment 1 Max Klinger 2012-11-02 02:47:50 UTC
Created attachment 328028 [details]
build log
Comment 2 Max Klinger 2012-11-02 03:01:43 UTC
Created attachment 328034 [details]
emerge info of the package
Comment 3 Rafał Mużyło 2012-11-02 04:22:02 UTC
As the dep looks fine, config.log is needed.
Comment 4 Max Klinger 2012-11-02 08:55:55 UTC
Created attachment 328042 [details]
config log
Comment 5 Reinis Danne 2012-11-02 10:02:30 UTC
Try rebuilding ncurses, it worked for me.
Comment 6 Rafał Mużyło 2012-11-02 11:31:56 UTC
Here, with sys-libs/ncurses-5.9-r2, 'pkg-config --modversion ncursesw' returns '5.9.20110404'; for you - it fails. Check why.
Comment 7 Max Klinger 2012-11-02 13:23:57 UTC
Rafał Mużyło
It came out empty, it's hard to tell why. I believe the pkgconfig files where in place. Reinstalling ncurses as Dennis suggested helped. pkgconfig then returns the right version, which is a bit odd to me. 

We diffed the configure.ac of vlc 2.0.4 and 2.0.3 and there are some lines regarding ncursesw that changed between the versions, so that change might have caused this to surface, I don't know if it is the real problem though. 

I guess reinstalling ncurses solved it but also destroyed the testbed. Is there anything else i could provide to clear this up or do i just close it as solved?
Comment 8 Sean Santos 2013-01-12 22:09:24 UTC
I have the same issue since VLC 2.0.4 went stable. I can reinstall ncurses and see if that fixes it, but if there's any other information you'd like me to provide first, I can do that.

> pkg-config --exists --print-errors "ncursesw"
Package ncursesw was not found in the pkg-config search path.
Perhaps you should add the directory containing `ncursesw.pc'
to the PKG_CONFIG_PATH environment variable
No package 'ncursesw' found

"equery f ncurses" does not show a .pc file anywhere (assuming that package is supposed to own it; I'm ignorant about pkg-config). There is no "ncursesw.pc" file anywhere in /usr. The ncurses version is 5.9-r2 (current stable *and* testing).
Comment 9 Sean Santos 2013-01-12 22:19:05 UTC
Correction: this is going from 2.0.3 to 2.0.5. But again, same issue.
Comment 10 Sean Santos 2013-01-12 22:20:09 UTC
Created attachment 335378 [details]
emerge --info ncurses pkgconfig
Comment 11 poletti.marco 2013-01-13 09:03:23 UTC
I also get the same issue, and after recompiling ncurses I get the .pc files installed and then vlc works.
I think the cause is this commit:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-libs/ncurses/ncurses-5.9-r2.ebuild?r1=1.15&r2=1.16

That commit makes the ncurses-5.9-r2 ebuild start to install .pc files, but there was no revbump, so it didn't trigger an update and people were still using ncurses installed without this commit, so lacking the .pc files.
The ncurses-5.9-r2 ebuild should be revbumped (IMO) to fix this problem.
Comment 12 rypervenche 2013-01-14 01:41:45 UTC
Created attachment 335552 [details]
emerge --info for 32-bit
Comment 13 rypervenche 2013-01-14 01:42:42 UTC
Created attachment 335554 [details]
Failed build.log for 32-bit
Comment 14 rypervenche 2013-01-14 01:43:35 UTC
I am also having this problem. I have attached two logs for you to review. Please let me know if you need any more information. Thanks.^^
Comment 15 Samuli Suominen gentoo-dev 2013-01-14 15:36:28 UTC

*** This bug has been marked as a duplicate of bug 438922 ***
Comment 16 Samuli Suominen gentoo-dev 2013-01-14 15:38:44 UTC
# emerge -1 sys-libs/ncurses for immediate fix

and you can raise the issue of revbumping in bug 438922, not here, since the bug is clearly not in media-video@ package VLC but in base-system@ package ncurses