Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 439130 - >=sys-apps/systemd-197: stabilize in order to unmask USE="systemd" for polkit, upower, udisks and others
Summary: >=sys-apps/systemd-197: stabilize in order to unmask USE="systemd" for polkit...
Status: RESOLVED DUPLICATE of bug 465870
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo systemd Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 438696 (view as bug list)
Depends on: 457568
Blocks:
  Show dependency tree
 
Reported: 2012-10-21 08:27 UTC by Christoph Brill (egore) (RESIGNED)
Modified: 2013-05-13 13:15 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Brill (egore) (RESIGNED) 2012-10-21 08:27:02 UTC
I'm using a systemd based gentoo with polkit compiled using USE="systemd"

Currently a mask esxists that disables this use flag. My system is running stable so I think it's safe to drop that mask.
Comment 1 Christoph Brill (egore) (RESIGNED) 2012-10-21 08:27:52 UTC
As a sidenote: I don't have consolekit installed anymore, so I'm sure that polkit picks systemd.
Comment 2 Samuli Suominen gentoo-dev 2012-10-21 08:40:24 UTC
You can use /etc/portage/profile/use.mask entry of:
-systemd
consolekit

That should unmask the flag in global basis, and you could mask consolekit with it...

To unmask the flag, systemd would have to be stabilized first, for KEYWORDS to match. I don't know the status of systemd stabilization. Let's ask the maintainers.
Comment 3 Samuli Suominen gentoo-dev 2012-10-21 08:41:09 UTC
@systemd: How do you want to handle this?
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2012-10-21 08:49:12 UTC
(In reply to comment #3)
> @systemd: How do you want to handle this?

That's a hard question. Nobody requested systemd stable yet, so I didn't consider it. I'm not running any stable system myself so I'm not sure how it works there.

One issue I see is that it would be hard to find a good systemd version with at least those 30 days of lifetime. Although -194 is free of bugs known to me so far, it's quite fresh. At the same time I'm afraid that older versions had some minor issues.

The other issue is that we'd have to have the corresponding udev stable first. As far as I'm aware, people are not really happy with them (mostly due to the firmware loading conflict with Linus).

@udev folks, do you have anything to add?
Comment 5 Samuli Suominen gentoo-dev 2012-10-30 18:56:25 UTC
Masked USE=systemd for sys-power/upower too since it's going stable now, expecting it to be masked for a lot more as time goes by
Comment 6 Samuli Suominen gentoo-dev 2012-12-19 16:57:26 UTC
*** Bug 438696 has been marked as a duplicate of this bug. ***
Comment 7 Morse 2012-12-19 19:48:12 UTC
(In reply to comment #5)
> Masked USE=systemd for sys-power/upower too since it's going stable now,
> expecting it to be masked for a lot more as time goes by

Then adding the -systemd to the use.mask should become the official recommendation for the systemd users. Otherwise they'll end up with broken system.

@Michał Górny:

You're the author of the official systemd installation guide, can you mention it there?
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2012-12-19 19:55:23 UTC
(In reply to comment #5)
> Masked USE=systemd for sys-power/upower too since it's going stable now,
> expecting it to be masked for a lot more as time goes by

Please do not mask flags like that. Please do fork (revbump) ebuilds instead, and remove the flag from the to-go-stable ebuild, leaving it in the eternally-testing revbump.

It's not great, it's hell of additional work, but it's what can work now. If you believe things shouldn't work like that, feel free to try to support bug 447090 which people seem to ignore.
Comment 9 Samuli Suominen gentoo-dev 2013-01-17 16:23:30 UTC
depends on bug
Comment 10 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-01-17 17:00:14 UTC
(In reply to comment #9)
> depends on bug

Er, the bug is about newer udev version.
Comment 11 Mike Gilbert gentoo-dev 2013-01-19 16:09:40 UTC
If it helps, I normally run a stable base system. I have added the following packages to package.keywords in my conversion to systemd; most of them are due to blockers on udev.

net-wireless/bluez
sys-apps/hwids
sys-apps/systemd
sys-apps/dbus
sys-apps/shadow
sys-auth/pambase
sys-fs/lvm2
sys-fs/udev
sys-fs/udev-init-scripts
sys-libs/gpm
virtual/udev
sys-fs/udisks
sys-apps/baselayout
Comment 12 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-03-06 20:41:55 UTC
Is this still necessary when USE=systemd is stable-masked?
Comment 13 Alexander Tsoy 2013-03-14 16:05:27 UTC
There are 2 critical bugs which need to be fixed before stabilization of systemd. lvm support is very important imho.
bug 453594
bug 451452
Comment 14 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-03-14 17:14:43 UTC
Well, I think the major reason for quick stabilization has been fixed and there's no need for it to go stable now. If someone would really want for systemd to go stable, I think we should set some kind of plan ;).
Comment 15 Samuli Suominen gentoo-dev 2013-03-15 09:09:43 UTC
(In reply to comment #14)
> Well, I think the major reason for quick stabilization has been fixed and
> there's no need for it to go stable now. If someone would really want for
> systemd to go stable, I think we should set some kind of plan ;).

Do you mean the new package.use.stable support?

Yet we have entry/entries like this in tree?

What to do with them? Some are with # and some without. Not entirely clear to me how to unmask USE=systemd for an package only for ~arch so that it can also be stabilized without repoman complaining...

# Robert Piasek <dagger@gentoo.org> (26 Apr 2012)
# Packages with optional systemd support. Masked in base and unmasked on arches
# where sys-apps/systemd is available.
# Samuli Suominen <ssuominen@gentoo.org> (07 Sep 2012)
# Masked again because this was never allowed before systemd is marked stable.
#sys-auth/polkit -systemd

(sorry for the reopen but profiles/ needs to be handled based on ^above)
Comment 16 Samuli Suominen gentoo-dev 2013-05-13 13:14:09 UTC

*** This bug has been marked as a duplicate of bug 465870 ***