Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 438922 - stage3-i686-20121016: missing pkgconfig files for sys-libs/ncurses-5.9-r2 (was: media-video/vlc-2.0.4 with <=sys-libs/ncurses-5.9 - configure: error: No package 'ncursesw' found. )
Summary: stage3-i686-20121016: missing pkgconfig files for sys-libs/ncurses-5.9-r2 (wa...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Stages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 440892 451908 452424 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-19 13:02 UTC by Benjamin Peterson
Modified: 2013-01-16 04:20 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (x,27.29 KB, text/plain)
2012-10-19 13:04 UTC, Benjamin Peterson
Details
config.log (x,274.08 KB, text/plain)
2012-10-19 15:27 UTC, Benjamin Peterson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Peterson 2012-10-19 13:02:34 UTC
VLC's configure complains about a lack of ncurses during configure.

Reproducible: Always




 $ emerge --info
Portage 2.1.11.9 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.3.8-gentoo x86_64)
=================================================================
System uname: Linux-3.3.8-gentoo-x86_64-Intel-R-_Core-TM-_i7-2860QM_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Fri, 19 Oct 2012 03:00:01 +0000
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 apng berkdb bzip2 cli consolekit cracklib crypt cups cxx dbus djvu dri fortran freetype gdbm gpm gudev hwdb iconv ipv6 jit kde kpathsea laptop mmx modules mudflap multilib ncurses networkmanager nls nptl ogg opengl openmp pam pcre policykit pppd python qt3support qt4 readline session sqlite sse sse2 ssl svg tcpd tiff truetype udev unicode vorbis wifi xcomposite xft xinerama zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="multitouch mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Benjamin Peterson 2012-10-19 13:04:17 UTC
Created attachment 326936 [details]
build log
Comment 2 Jeroen Roovers gentoo-dev 2012-10-19 14:31:55 UTC
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-video/vlc-2.0.4/work/vlc-2.0.4/config.log

Please do.
Comment 3 Benjamin Peterson 2012-10-19 15:27:22 UTC
Created attachment 326942 [details]
config.log
Comment 4 megabaks 2012-10-20 05:37:36 UTC
ls -lh /usr{/local,}/lib*/pkgconfig/ncurses*.pc
Comment 5 Andreas Sturmlechner gentoo-dev 2012-10-20 15:04:06 UTC
Same here
Comment 6 Benjamin Peterson 2012-10-20 15:06:36 UTC
Remerging ncurses fixed it for me.
Comment 7 Andreas Sturmlechner gentoo-dev 2012-10-20 15:19:22 UTC
Indeed. Seems it was my fault, I had my system rebuilt with mostly BINKPGs and the *pc files were not included.
Comment 8 Jeroen Roovers gentoo-dev 2012-10-20 15:34:54 UTC
*ncurses-5.9-r1 (21 Nov 2011)
  
  21 Nov 2011; Mike Frysinger <vapier@gentoo.org> +ncurses-5.9-r1.ebuild:
  Install pkg-config files.
Comment 9 Moritz Schlarb 2012-10-22 19:44:36 UTC
(In reply to comment #6)
> Remerging ncurses fixed it for me.

Indeed, that fixed it for me, too, but I can not see why this could anyhow be supposed to happen.

Could that have been a faulty stage3? Is ncurses on stage3?
Comment 10 Tianon 2012-10-22 22:55:10 UTC
My guess is that the ncurses included in the stage3 was essentially a "binpkg", so didn't include the *.pc files necessary for VLC to link against, so doing a simple rebuild of ncurses (or ever having updated it since your initial stage3) fixes the issue.
Comment 11 Ulrich Müller gentoo-dev 2012-10-23 18:04:37 UTC
(In reply to comment #9)
> Could that have been a faulty stage3? Is ncurses on stage3?

sys-libs/ncurses is on stage3, but /usr/lib*/pkgconfig/ncurses*.pc are not installed.

Reassigning to releng.
Comment 12 Rick Farina (Zero_Chaos) gentoo-dev 2012-10-23 19:30:56 UTC
Tested adding DEPEND=virtual/pkgconfig to rerunning catalyst stage1, everything appears fine.  I'd prefer not to wait long since this is an important fix but we will give the maintainer a bit to respond. Spanky, you touch it a lot, what say you?
Comment 13 SpanKY gentoo-dev 2012-10-23 20:07:25 UTC
Commit message: Bypass dumb pkg-config install checks
http://sources.gentoo.org/sys-libs/ncurses/ncurses-5.9-r2.ebuild?r1=1.15&r2=1.16
Comment 14 Ulrich Müller gentoo-dev 2012-10-23 20:55:07 UTC
(In reply to comment #13)
> Commit message: Bypass dumb pkg-config install checks
> http://sources.gentoo.org/sys-libs/ncurses/ncurses-5.9-r2.ebuild?r1=1.15&r2=1.16

Tested and looks good here. Closing, as discussed with zerochaos on IRC.
Comment 15 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-13 21:44:39 UTC
*** Bug 451908 has been marked as a duplicate of this bug. ***
Comment 16 Samuli Suominen gentoo-dev 2013-01-14 15:36:28 UTC
*** Bug 440892 has been marked as a duplicate of this bug. ***
Comment 17 Samuli Suominen gentoo-dev 2013-01-14 15:39:38 UTC
Can we have revbump of ncurses? Users are still hitting this because of lack of it.
Comment 18 poletti.marco 2013-01-14 15:42:52 UTC
(In reply to comment #17)
> Can we have revbump of ncurses? Users are still hitting this because of lack
> of it.

Yes, I agree. For example, this issue produces bug 440892.
Comment 19 Rafał Mużyło 2013-01-16 04:20:16 UTC
*** Bug 452424 has been marked as a duplicate of this bug. ***