Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 438890 - net-nds/openldap USE="gnutls ssl" cannot find gcrypt.h
Summary: net-nds/openldap USE="gnutls ssl" cannot find gcrypt.h
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-19 06:21 UTC by Olaf Leidinger
Modified: 2014-10-12 06:03 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Leidinger 2012-10-19 06:21:15 UTC
When compiling openldap on a freshly installed system, building failes complaining about a missing gcrypt.h. When using the flag "gnutls", a patch "openldap-2.4.28-gnutls-gcrypt.patch" is applied with introduces a library dependency on libgcrypt. 

In order to make the building of the package succeed, a dependency on libgcrypt must me introduced when activating the use flags "ssl" and "gnutls".

Reproducible: Always

Steps to Reproduce:
1. remove libgcrypt from your system
2. compile openldap with flags: "ssl" and "gnutls"
Comment 1 Rafał Mużyło 2012-10-19 15:55:56 UTC
As noted in bug 420887, this might not be as straightforward as you think.

I'd say opening a bug upstream (at openldap) regarding more recent versions of gnutls (especially gnutls[nettle]) would be useful.
Comment 2 Cédric Jeanneret 2012-12-06 06:53:51 UTC
hmm, I do have libgcrypt installed on my system, but openldap (2.4.33-r1) compilation fails.
the failure comes when I updated to the latest, unstable gnutls (3.1.5) :

./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'
collect2: ld returned 1 exit status
make[2]: *** [ftest] Error 1
make[2]: *** Waiting for unfinished jobs....
./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'
collect2: ld returned 1 exit status
make[2]: *** [dntest] Error 1
./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'
collect2: ld returned 1 exit status
make[2]: *** [ltest] Error 1
./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'
collect2: ld returned 1 exit status
make[2]: *** [apitest] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.33-r1/work/openldap-2.4.33/libraries/libldap'
make[1]: *** [all-common] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.33-r1/work/openldap-2.4.33/libraries'
make: *** [all-common] Error 1
 * ERROR: net-nds/openldap-2.4.33-r1 failed (compile phase):

I'm not really sure it's a related bug, but can you please show your openldap and gnutls versions ?

Cheers,

C.
Comment 3 Olaf Leidinger 2012-12-06 07:02:30 UTC
It's better to compile without gnutls support, as openldap really only supports older versions of gnutls. OpenSSL is used instead which is fine.
Comment 4 Cédric Jeanneret 2012-12-06 12:54:56 UTC
(In reply to comment #3)
> It's better to compile without gnutls support, as openldap really only
> supports older versions of gnutls. OpenSSL is used instead which is fine.

good point - USE="-gnutls" emerge openldap works. don't even remember why it's installed in fact - probably some nice deps for some app I need…
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2014-10-12 06:03:48 UTC
This was fixed long since in OpenLDAP