Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 437642 - sys-auth/libfprint needs a patch in order to be compatible with certain upek fingerprint readers
Summary: sys-auth/libfprint needs a patch in order to be compatible with certain upek ...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-08 22:43 UTC by Benjamin Schulz
Modified: 2020-01-15 07:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Schulz 2012-10-08 22:43:10 UTC
My thinkpad W510 from lenovo has a fingerprint reader with this usb id:

147e:2016

current gentoo fprint does not work with it. Although thinkwiki says that libfprint can be patched to work with this scanner:

http://www.thinkwiki.org/wiki/Integrated_Fingerprint_Reader

Thinkwiki points to this bugzilla entry of the red hat linux distribution.

https://bugzilla.redhat.com/show_bug.cgi?id=504399

Red Hat has included the patches mentioned in this entry in their distribution.

Perhaps gentoo should do that too, since it is needed for the following lenovo thinkpads:


ThinkPad R61, R61i
ThinkPad Edge 14", Edge 15"
ThinkPad L412, L512
ThinkPad T400s, T410, T410i, T410s, T410si, T420, T510, T510i
ThinkPad W510, W701, W701ds
ThinkPad X201, X201i, X201s, X201 Tablet, X220, X1



Reproducible: Always

Steps to Reproduce:
1.install libfprint and fprint_demo on a ws 510 thinkpad
2.try to record and identify a fingerprint. fprint demo will give errors for the latter procedure and exists with errors or sometimes crashes  during the first.
3.
Comment 1 Michael Weber (RETIRED) gentoo-dev 2012-10-08 23:56:31 UTC
Which patch exactly do you need?
Comment 2 Benjamin Schulz 2012-10-09 11:05:35 UTC
I do not know it. I just know that the libfprint from gentoo does not work for my thinkpad, but when i install redhat, it miracuously works.
Comment 3 Benjamin Schulz 2012-10-09 11:16:37 UTC
from the redhat bugzilla entrys, it seems that one needs the two patches together.
Comment 4 Michael Weber (RETIRED) gentoo-dev 2013-01-06 08:40:52 UTC
"0001-Rework-discover-code-for-drivers.patch" [1] is included to big parts.
"0002-Implement-discover-methods-for-upeke2-and-upeksonly.patch" [2], too, in both versions I checked (0.4.0 and 0.5.0).

[1] https://bugzilla.redhat.com/attachment.cgi?id=439239
[2] https://bugzilla.redhat.com/attachment.cgi?id=439240
Comment 5 Benjamin Schulz 2013-01-06 15:14:58 UTC
the strange thing what happens on my t520 is the following:

When I start fprint_demo, and try to record a fingerprint,

the yellow light of the finger print scanner works and I'm asked to swipe my finger for six times. Even the swipes work. However, after the fifth swipe, I'm asked again to swipe my thinger on the printer. fprint_demo now says that the sixth swipe was completed, and then, it crashes.

Fprint demo also says that my device would have no fingerprint intentification implemented. So, even if the recording of the fingerprints would work, fprint would say that I would not be able to verify my fingerprint.

I have now installed fingerprint_gui in gentoo. And this program miracuously works for my t520.

Even if there seems to be some bug too. When logging in, fingerprint_gui asks me to verify my fingerprint or to type in my password. if I now swipe my finger, then everything is fine. However, if I choose to type my passwort, then the led of the fingerprint scanner will stay on and shine until i restart my computer....
Comment 6 haarp 2013-12-21 14:17:07 UTC
I also get a buggy fprint_demo, but that is unrelated to this bug.

The patches have already been upstreamed long ago. My fingerprint reader (the same kind as is the subject of this bug) works fine.