Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 436540 - dev-util/cmake-2.8.9 fails FindModulesExecuteAll test
Summary: dev-util/cmake-2.8.9 fails FindModulesExecuteAll test
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard: fixed in 2.8.11
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-28 21:25 UTC by Nikoli
Modified: 2013-06-09 12:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (cmake-2.8.9_build1.log,376.89 KB, text/plain)
2012-09-28 21:25 UTC, Nikoli
Details
LastTest.log (LastTest.log,55.02 KB, text/plain)
2012-10-02 11:47 UTC, Nikoli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikoli 2012-09-28 21:25:08 UTC
Created attachment 325278 [details]
build.log

I have such problem only with my non hardened systems.


99% tests passed, 1 tests failed out of 231

Label Time Summary:
Label1    =   0.09 sec
Label2    =   0.09 sec

Total Test time (real) = 649.23 sec

The following tests FAILED:
         25 - FindModulesExecuteAll (Failed)
Errors while running CTest


[ebuild  N     ] dev-util/cmake-2.8.9  USE="ncurses qt4 test -emacs -vim-syntax"


Portage 2.1.10.49 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.3.8-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
Timestamp of tree: Fri, 28 Sep 2012 18:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo nikoli
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages/core2"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/nikoli"
USE="X a52 aac acl acpi akonadi alsa amd64 amr atm audiofile bash-completion bzip2 cairo caps cdda cddb cdio cdparanoia cdr celt cli consolekit cracklib crypt css cups cxx dbus dc1394 djvu dri dts dv dvd dvdr emboss encode exif fat ffmpeg firefox flac fluidsynth fontconfig fortran gd geoip gif gimp gmp gnutls gphoto2 gpm graphviz gsm gstreamer gtk handbook iconv icu id3tag idn ieee1394 ilbc imagemagick imap imlib ios ipod ipv6 jbig jpeg jpeg2k kde kipi kontact lame lcms libass libnotify libproxy libsamplerate lm_sensors lzma lzo mac mad matroska mikmod mmx mmxext mng modplug modules mp3 mp4 mpeg mtp mudflap multilib musepack musicbrainz ncurses networkmanager nls nptl nptlonly ntfs nvidia ogg openal openexr opengl openmp pam pango pcre pdf pg-intdatetime phonon plasma pm-utils png policykit postscript ppds pppd qt3support qt4 quicktime rar raw readline reiserfs replaygain rtmp sasl scanner schroedinger semantic-desktop session sid smp sndfile socks5 speex spell sqlite sse sse2 sse3 ssl ssse3 startup-notification svg symlink sysfs taglib theora threads thumbnail tiff truetype tta udev udisks unicode upnp upower usb v4l v4l2 vaapi vcd vdpau vorbis vpx wavpack webkit webp wma wmf wxwidgets x264 xattr xcb xcomposite xface xinerama xml xmp xpm xscreensaver xv xvid xz zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" NGINX_MODULES_HTTP="access auth_basic autoindex fastcgi gzip rewrite" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia modesetting vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Johannes Huber gentoo-dev 2012-10-01 12:54:25 UTC

*** This bug has been marked as a duplicate of bug 436188 ***
Comment 2 Nikoli 2012-10-02 11:12:11 UTC
Bug #436188 is fixed, this bug is not.
Comment 3 Nikoli 2012-10-02 11:47:02 UTC
Created attachment 325528 [details]
LastTest.log
Comment 4 Rolf Eike Beer 2012-11-03 15:53:12 UTC
Comment on attachment 325528 [details]
LastTest.log

CMake Error at /usr/share/apps/cmake/modules/FindQt4.cmake:514 (MESSAGE):
  Invalid Qt version string given: "4.5.0", major version 4 is required, e.g.
  "4.0.1"
Call Stack (most recent call first):
  /var/tmp/portage/dev-util/cmake-2.8.9/work/cmake-2.8.9/Modules/FindQt.cmake:137 (INCLUDE)
  CMakeLists.txt:16 (include)

I can't see a message statement in line 514. In fact line 514 is just in the middle of one find_program() call. Also CMake installs it's modules into /usr/share/cmake on my system.

I guess there are 2 things here going wrong: FindQt does include(FindQt4) without specifying that it should be loaded from the same directory, so it includes the one from the system installation (as seen by all these warnings). And you have an old CMake version installed which does something wrong in FindQt4, leading to that error.

The first one is an upstream thing (I'll care for this for 2.8.11), the other one can be solved by just upgrading your CMake or removing the old version before running the testcases.
Comment 5 Rolf Eike Beer 2013-06-08 21:24:07 UTC
Should be fixed by upstream 2.8.11. Please put upstream version 2.8.11.1 in the tree.
Comment 6 Johannes Huber gentoo-dev 2013-06-09 12:08:29 UTC
Thanks all, fixed version is in tree now.

+  09 Jun 2013; Johannes Huber <johu@gentoo.org> +cmake-2.8.11.1.ebuild,
+  +files/cmake-2.8.11-FindBLAS.patch,
+  +files/cmake-2.8.11-FindBoost-python.patch,
+  +files/cmake-2.8.11-FindImageMagick.patch,
+  +files/cmake-2.8.11-more-no_host_paths.patch:
+  Version bump by several people in kde overlay. Fixes bug bug #436540.