Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 436450 - media-libs/imlib2-1.4.5: toolchain-funcs.eclass: Kernel version could not be determined, please inherit kernel-2 or linux-info
Summary: media-libs/imlib2-1.4.5: toolchain-funcs.eclass: Kernel version could not b...
Status: RESOLVED DUPLICATE of bug 432390
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: x86 Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 23:57 UTC by gilhad
Modified: 2012-09-28 15:11 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
detect KV, workaround (toolchain-funcs.eclass.diff,667 bytes, patch)
2012-09-28 09:40 UTC, iGentoo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description gilhad 2012-09-27 23:57:00 UTC
emerge fails with error

Reproducible: Always

Actual Results:  
 * Messages for package media-libs/imlib2-1.4.5:

 * ERROR: media-libs/imlib2-1.4.5 failed (configure phase):
 *   toolchain-funcs.eclass: Kernel version could not be determined, please inherit kernel-2 or linux-info
 * 
 * Call stack:
 *     ebuild.sh, line   85:  Called src_configure
 *   environment, line 2444:  Called tc-arch
 *   environment, line 2525:  Called tc-ninja_magic_to_arch 'portage'
 *   environment, line 2827:  Called die
 * The specific snippet of code:
 *       [[ -z ${KV} ]] && die "toolchain-funcs.eclass: Kernel version could not be determined, please inherit kernel-2 or linux-info";
 * 
 * If you need support, post the output of `emerge --info '=media-libs/imlib2-1.4.5'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/imlib2-1.4.5'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/imlib2-1.4.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/imlib2-1.4.5/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/imlib2-1.4.5/work/imlib2-1.4.5'
 * S: '/var/tmp/portage/media-libs/imlib2-1.4.5/work/imlib2-1.4.5'



emerge --info
Portage 2.1.11.9 (default/linux/x86/10.0, gcc-4.5.4, glibc-2.15-r2, 3.3.8-gentoo i686)
=================================================================
System uname: Linux-3.3.8-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_E4700_@_2.60GHz-with-gentoo-2.1
Timestamp of tree: Thu, 27 Sep 2012 23:30:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo x-gilhad
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gilhad.cz"
LANG="C"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j 3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/gilhad"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa apng berkdb bzip2 cairo cdr cli cracklib crypt cups cxx dlz dri dvd fortran g_notime_adjuster gdbm gif gpm iconv jpeg jpeg2k modules mp3 mpg123 mudflap ncurses nls nptl openmp pam pcre png pnm pppd python qt3support readline sdl session ssl tcpd tiff unicode win32codecs x86 zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 bigfoot 2012-09-28 03:46:13 UTC
I can confirm the same thing with at least qt-core and mpg123 (along with imlib2) and possibly more.  So it's definitely not just an imlib2 issue.  Still not sure what is causing it, but I wanted to chime in with what I have found so far.  I'm continuing to look.
Comment 2 dwfreed 2012-09-28 04:33:22 UTC
This error message comes from this commit: http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/toolchain-funcs.eclass?r1=1.117&r2=1.118 which is from bug #432390

As far as I can tell, this commit breaks every ebuild that uses tc-arch() or tc-arch-kernel() from toolchain-funcs without inheriting kernel-2 or linux-info.

As a workaround until a fix is pushed, set KV to the output of uname -r when running portage, like so:

KV=$(uname -r) emerge -NDuav world
Comment 3 gilhad 2012-09-28 05:39:38 UTC
dwfreed: does not work for me :(

But it is probabelly result of the bug you mentioned. 
I tried to do (in /usr/portage/gentoo/eclass/toolchain-funcs.eclass):

+    KV=`uname -r`
    local KV=${KV:-${KV_FULL}}

and it worked for me (but REALLY slowed down the initial emerge phase with rotating dash -/|\)
Comment 4 Albert Veli 2012-09-28 08:08:14 UTC
I have the same problem trying to emerge qt-core. The workaround from gilhad works (to put KV=`uname -r` into toolchain-funcs.eclass). But it slows down emerge. I hope this will be fixed soon, before a lot of users gets breakage :)
Comment 5 iGentoo 2012-09-28 09:36:44 UTC
media-libs/libmad-0.15.1b-r7: the same error.
Comment 6 iGentoo 2012-09-28 09:40:49 UTC
Created attachment 325174 [details, diff]
detect KV, workaround
Comment 7 Kerin Millar 2012-09-28 09:56:15 UTC
I would suggest that Alphat-PC attach the amended patch to bug 432390 and that this bug be marked as a duplicate. As imlib2 is far from being the only package affected, there seems little to be gained in spreading the discussion across multiple bugs.
Comment 8 Robert Piasek (RETIRED) gentoo-dev 2012-09-28 14:31:22 UTC
It also breaks catalyst stage building
Comment 9 Ian Stakenvicius (RETIRED) gentoo-dev 2012-09-28 14:41:00 UTC
Setting KV to uname -r isn't a good idea imo ; the whole idea behind this was to get the kernel version properly according to the eclasses that can do this (kernel-2 or otherwise).

I added the ||die because the output of tc-arch-kernel is wrong/undefined when KV is unset, and this has been going on for a while.  Things "just work" on x86/amd64 because the kernel config itself maps the (invalid/undefined) value returned by tc-arch-kernel to the correct one, but it doesn't for arches like ppc/ppc64 (ie mapping them to 'powerpc').

However, if it is pereferrable this could be changed to an eqawarn and not be fatal.

I think making it non-fatal would be the better way to go than setting KV on 'uname -r' by default.
Comment 10 Ian Stakenvicius (RETIRED) gentoo-dev 2012-09-28 15:11:00 UTC
Marking as duplicate, as requested.  Also, just committed a fix to make the warning non-fatal and only be displayed when arch type check is 'kern' since that's the only time KV seems to matter.

*** This bug has been marked as a duplicate of bug 432390 ***