Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 435856 - >=media-libs/chromaprint-0.6 with media-video/ffmpeg-0.11 - .../work/chromaprint-0.7/tools/../src/ext/ffmpeg_decoder.h:92:74: error: ‘av_open_input_file’ was not declared in this scope
Summary: >=media-libs/chromaprint-0.6 with media-video/ffmpeg-0.11 - .../work/chromapr...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ffmpeg-0.11-breakage
  Show dependency tree
 
Reported: 2012-09-22 12:52 UTC by Tomasz Golinski
Modified: 2012-11-08 11:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
chromaprint build.log (build.log,63.67 KB, text/plain)
2012-09-22 12:53 UTC, Tomasz Golinski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Golinski 2012-09-22 12:52:29 UTC
New chromaprint has in Changelog: Support for the latest FFmpeg API. However, it still doesn't build with ffmpeg-0.11. Details in attached build.log

Reproducible: Always
Comment 1 Tomasz Golinski 2012-09-22 12:53:25 UTC
Created attachment 324620 [details]
chromaprint build.log
Comment 2 Tomasz Golinski 2012-09-24 15:14:24 UTC
According to author comment at http://oxygene.sk/2012/09/chromaprint-0-7-released/ we don't need to build tools. Now, USE=tools enables both tools and examples. What media-sound/picard really needs is only examples which contain fpcalc. 

I commented out lines
$(cmake-utils_use_build tools)
 and
use tools && dobin "${CMAKE_BUILD_DIR}"/tools/fpcollect

and it build fine. I also have fpcalc binary needed by picard.
Comment 3 Hanno Böck gentoo-dev 2012-10-26 18:15:23 UTC
pld-linux has a patch to support latest ffmpeg api:
https://raw.github.com/pld-linux/chromaprint/master/chromaprint-ffmpeg.patch

Works fine here.
Comment 4 Alexis Ballier gentoo-dev 2012-10-26 18:33:20 UTC
or just bump it to 0.7 :)
Comment 5 Alexis Ballier gentoo-dev 2012-10-26 18:35:22 UTC
(In reply to comment #4)
> or just bump it to 0.7 :)

forget this, i didnt build the faulty part...
Comment 6 Tomasz Golinski 2012-10-26 18:38:48 UTC
But why not follow upstream advise and get rid of tools? Is there anything useful there?
Comment 7 Alexis Ballier gentoo-dev 2012-11-08 11:11:24 UTC
(In reply to comment #3)
> pld-linux has a patch to support latest ffmpeg api:
> https://raw.github.com/pld-linux/chromaprint/master/chromaprint-ffmpeg.patch
> 
> Works fine here.

been too long, applied this one, thanks, was easy enough not to rip out the extra utility.