Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 435110 - sys-devel/binutils: ar mishandles 4GB files (causing net-libs/webkit-gtk build to fail with debug flags)
Summary: sys-devel/binutils: ar mishandles 4GB files (causing net-libs/webkit-gtk buil...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2012-09-15 11:07 UTC by emil karlson
Modified: 2014-01-09 15:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description emil karlson 2012-09-15 11:07:48 UTC
I get with any >=webkit-gtk-1.8.2 and CFLAGS="... -g -gdwarf-4" using gcc-4.7.

Builds fine without debug symbols.

see url, also ubuntu bug

  CXXLD    TestNetscapePlugin/
  CXXLD    Libraries/
  CXXLD    Libraries/
x86_64-pc-linux-gnu-ar: .libs/libWebCore.a: File truncated
make: *** [] Error 1
 * ERROR: net-libs/webkit-gtk-1.8.3-r300 failed (compile phase):
 *   emake failed
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-1.8.3-r300'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-1.8.3-r300'`.
 * The complete build log is located at '/tmp/portage-logs/net-libs:webkit-gtk-1.8.3-r300:20120915-085216.log'.
 * For convenience, a symlink to the build log is located at '/usr/local/tmp/portage/net-libs/webkit-gtk-1.8.3-r300/temp/build.log'.
 * The ebuild environment file is located at '/usr/local/tmp/portage/net-libs/webkit-gtk-1.8.3-r300/temp/environment'.
 * Working directory: '/usr/local/tmp/portage/net-libs/webkit-gtk-1.8.3-r300/work/webkit-1.8.3'
 * S: '/usr/local/tmp/portage/net-libs/webkit-gtk-1.8.3-r300/work/webkit-1.8.3'


Portage 2.2.0_alpha128 (default/linux/amd64/10.0/desktop, gcc-4.7.1, glibc-2.15-r2, 3.5.3 x86_64)
System uname: Linux-3.5.3-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.2
Timestamp of tree: Sat, 15 Sep 2012 00:45:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.3
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo gentoo-haskell x11 ke-shared
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula"
CFLAGS="-O2 -pipe -march=native -g -gdwarf-4"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native -g -gdwarf-4"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs compressdebug config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,--as-needed -Wl,-O1"
LINGUAS="en fi en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/haskell /var/lib/layman/x11 /etc/shared/lib/portage/overlay"
USE="256-color X a52 aac accessibility acl acpi alisp alltargets alsa amd64 amr ansi apng bash-completion berkdb bluetooth branding btrfs bzip2 cairo caps cdda cdr cli clisp consolekit cracklib crypt cryptsetup cscope css cups curl cxx darcs dbus declarative dirac dri dts dvd dvdr eds emboss enca encode exif extra extras fam ffmpeg fftw firefox flac fontconfig fortran fortran95 ftp g3dvl gallium games gbm gcj gd gdbm gdu gif git glamor glib gmp gnome gnuplot go gold gpm graphics graphite gtk gtk3 gudev hoogle iconv icu idn image imagemagick imlib inotify iproute2 ipv6 jadetex java javascript jpeg jpeg2k kipi kpathsea lapack laptop latex latex3 lcms ldap libkms libnotify llvm lto lxde lzma lzo mad math matroska md5sum midi minizip mmap mmx mng mod modplug mono mouse mp3 mp4 mpeg mpi mpi_njtree mplayer mudflap multilib multitarget musepack music nautilus ncurses net netpbm network networkmanager nls npp nptl nsplugin ntp ogg openexr opengl openmp pam pango pcre pdf perl plotutils png pnm policykit postscript ppds pppd ps pstricks publishers pulseaudio python python3 qt3support qt4 readline reports romio rtmp rtsp samba schroedinger science sdl sdl-image secure-delete semantic-desktop server session smbclient smp sna sparse speex spell sqlite sse sse2 sse3 ssl ssse3 startup-notification stream subtitles subversion supernodal svg system-libs system-sqlite systemd systemtap tcpd tex4ht theora threads threadsafe tiff timidity tk toolbar trace truetype udev udis86 udisks unicode unlock-notify upower usb vaapi vdpau vim vim-syntax vorbis wav wavpack weather webkit webkit2 wma x264 xattr xcb xcomposite xinerama xml xmp xorg xosd xpm xrandr xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en fi en_GB" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vesa intel radeon fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Reproducible: Always

Steps to Reproduce:
1. emerge webkit-gtk with debug symbols on amd64.
Comment 1 emil karlson 2012-09-15 11:56:04 UTC
It seems though that our binutils already have the fix from url, no idea why this still happens.
Comment 2 SpanKY gentoo-dev 2012-09-16 05:11:54 UTC
yes, 2.22.90 already contains the aforementioned fix.  plus, that bug should only be affecting 32bit platforms which amd64 is not (since size_t/etc... should already handle 4GB+ fine).
Comment 3 emil karlson 2012-09-16 16:02:51 UTC
So after a couple of builds, it seems to be the -gdwarf-4 that makes the difference, with just -g it builds fine.
Comment 4 SpanKY gentoo-dev 2012-12-10 03:39:52 UTC
looks like upstream is tracking this down now.  might want to give the referenced patch a test on your system.
Comment 5 emil karlson 2012-12-14 16:39:36 UTC
(In reply to comment #4)
> looks like upstream is tracking this down now.  might want to give the
> referenced patch a test on your system.

Tested on binutils-2.23.1, did not help. Perhaps I should actively push this this to upstream myself, I guess not many people compile webkit-gtk with -gdwarf-4.
Comment 6 SpanKY gentoo-dev 2012-12-29 21:00:11 UTC
(In reply to comment #5)

what about ?  there's another truncate related fix in there ...
Comment 7 emil karlson 2013-01-01 20:56:38 UTC
(In reply to comment #6)
> (In reply to comment #5)
> what about ?  there's another truncate related fix in there ...

No luck with that one either.
Comment 8 SpanKY gentoo-dev 2014-01-08 00:03:39 UTC
i just built net-libs/webkit-gtk-1.8.3-r300 using binutils-2.24 and -gdwarf-4 on my amd64 system and it worked fine.  can you see if that version works for you ?
Comment 9 emil karlson 2014-01-08 18:05:49 UTC
(In reply to SpanKY from comment #8)
> i just built net-libs/webkit-gtk-1.8.3-r300 using binutils-2.24 and
> -gdwarf-4 on my amd64 system and it worked fine.  can you see if that
> version works for you ?

Still fails the same way on sys-devel/binutils-2.24-r1.