Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 434940 - net-print/cups-1.6.2 fails to collate in printer
Summary: net-print/cups-1.6.2 fails to collate in printer
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
: 458980 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-13 20:07 UTC by Steve Garcia
Modified: 2017-02-11 22:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Garcia 2012-09-13 20:07:01 UTC
Reproducible: always

Steps to reproduce:
1. Upgrade from cups 1.5.3 to cups 1.6.1
2. Print x copies of a document

Actual Results: x**2 copies of the document are printed

Expected results: x copies of the document are printed



Ever since I upgraded to CUPS 1.6.1 I have had a problem when I try to print multiple copies. It appears that it's trying to print the square of the number that I actually need.

A few days ago I was a bit startled when my 40 copies (of a one page file) used up a ream of paper before I canceled it. Today I watched the printer more closely, and there was about a quarter of an inch of paper in the output tray when the screen on the printer changed from "processing 1 of 40" to "processing 2 of 40." It appears that CUPS is creating one big file with all 40 copies in it, sending it to the printer and instructing the printer to make 40 copies.

Our printer is set to duplex all print jobs, but when it's just a single page being printed, that shouldn't make any difference. When they all get bundled together you get the odd situation of every page having the same thing on front and back.

Reversion to 1.5.3 fixes the problem.
Comment 1 James 2012-09-24 16:56:30 UTC
I had been seeing this problem as well.  The problem appears to be something to do with in printer and/or out-of-printer collation. While this problem (of x^2 prints) disappeared a while back, something in collation is still messed up, I cannot collate right now (I prefer to collate in my printers, but nothing is collating).  I'm not absolutely sure when the x^2 problem stopped, but I believe it was when cups-filters was updated to version 1.0.24 (at least that's the only change in my printing system between now and then)
Comment 2 Andreas K. Hüttel gentoo-dev 2013-03-24 20:09:55 UTC
Please test 1.6.2
Comment 3 James 2013-03-29 20:24:36 UTC
still no dice, and further, it takes longer to print the labels than it does to burn cds or dvds that the labels go on.
Comment 4 Andreas K. Hüttel gentoo-dev 2013-05-13 20:08:58 UTC
*** Bug 458980 has been marked as a duplicate of this bug. ***
Comment 5 Andreas K. Hüttel gentoo-dev 2013-06-28 00:17:37 UTC
OK let's reflect the fact that the "square printing" got fixed sometime
Comment 6 Andreas K. Hüttel gentoo-dev 2013-06-28 00:19:57 UTC
Ok this is certainly annoying but not really a stable blocker.
Comment 7 Andreas K. Hüttel gentoo-dev 2014-04-26 23:26:55 UTC
How about current 1.7.1-r1 and cups-filters (whic verision)?
Comment 8 Andreas K. Hüttel gentoo-dev 2017-02-11 22:52:02 UTC
(In reply to Andreas K. Hüttel from comment #7)
> How about current 1.7.1-r1 and cups-filters (whic verision)?