Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 434412 - app-crypt/gcr-3.4.1 USE=-introspection - Couldn't find include 'Gtk-3.0.gir' (search path: ['../gck', '/usr/local/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0'])
Summary: app-crypt/gcr-3.4.1 USE=-introspection - Couldn't find include 'Gtk-3.0.gir' ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-09-09 09:40 UTC by Sergey Golubev
Modified: 2012-09-10 17:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,34.77 KB, text/plain)
2012-09-10 03:04 UTC, Ben Longbons
Details
emerge --info (emerge--info,15.25 KB, text/plain)
2012-09-10 03:05 UTC, Ben Longbons
Details
tested patch (gcr-introspection.diff,394 bytes, patch)
2012-09-10 03:45 UTC, Ben Longbons
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Golubev 2012-09-09 09:40:37 UTC
Steps to reproduce bug:

1. emerge =gcr-3.4.1
2. In the compiler output we see GISCAN Gcr-3.gir
Couldn't find include 'Gtk-3.0.gir' (search path: ['../gck', '/usr/local/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0']), but this must not appear, because i specify USE="-introspection


To fix this bug we must append --enable-introspection=no to ./configure parameters in ebuild depend on USE.
Comment 1 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-09-09 10:04:18 UTC
"If you are unsure, please file your bug in this product:
Gentoo Linux: 	The Gentoo Linux Distribution – Ebuilds and System related issues
…

Examples for bugs in this product:
…
Compile errors (please follow the instructions contained in the error message!)"

Please read and follow our precise instructions for filing a bug next time.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-09-09 15:51:42 UTC
1) Please post your `emerge --info' output in a comment,.
2) Please attach the entire build log to this bug report.
Comment 3 Ben Longbons 2012-09-10 03:04:32 UTC
Created attachment 323356 [details]
build.log
Comment 4 Ben Longbons 2012-09-10 03:05:59 UTC
Created attachment 323358 [details]
emerge --info

$ emerge -pqv '=app-crypt/gcr-3.4.1'
[ebuild  N    ] app-crypt/gcr-3.4.1  USE="doc -debug -introspection -test" 
[blocks B     ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.4.1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (gnome-base/gnome-keyring-3.2.2::gentoo, installed) pulled in by
    >=gnome-base/gnome-keyring-0.4 required by (gnome-base/libgnomeui-2.24.5::gentoo, installed)
    >=gnome-base/gnome-keyring-3.1.92 required by (gnome-base/libgnome-keyring-3.2.2::gentoo, installed)

  (app-crypt/gcr-3.4.1::gentoo, ebuild scheduled for merge) pulled in by
    =app-crypt/gcr-3.4.1

$ emerge -pqv =gnome-base/gnome-keyring-3.4.1                                                                                                                                                  
[ebuild  N    ] app-crypt/gcr-3.4.1  USE="doc -debug -introspection -test" 
[ebuild     U ] gnome-base/gnome-keyring-3.4.1 [3.2.2] USE="caps doc pam -debug (-selinux) -test" 
[blocks b     ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.4.1)
Comment 5 Ben Longbons 2012-09-10 03:45:10 UTC
Created attachment 323366 [details, diff]
tested patch
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-10 17:28:37 UTC
Fixed, thanks for reporting.

>*gcr-3.4.1-r2 (10 Sep 2012)
>
>  10 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org> -gcr-3.4.1.ebuild,
>  -gcr-3.4.1-r1.ebuild, +gcr-3.4.1-r2.ebuild:
>  Respect USE=-introspection (bug #434412, thanks to Sergey Golubev and Ben
>  Longbons). Drop revisions that didn't.