Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 434316 - sci-libs/gdal-1.8.1-r1 - In member function ‘virtual CPLErr PDFRasterBand::IReadBlock(int, int, void*)’: pdfdataset.cpp:351:47: error: no matching function for call to ‘SplashOutputDev::startDoc(XRef*)’
Summary: sci-libs/gdal-1.8.1-r1 - In member function ‘virtual CPLErr PDFRasterBand::IR...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords:
: 441604 (view as bug list)
Depends on:
Blocks: 437610
  Show dependency tree
 
Reported: 2012-09-08 10:14 UTC by Toralf Förster
Modified: 2013-06-24 23:36 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (sci-libs:gdal-1.8.1-r1:20120908-093738.log.gz,22.34 KB, application/x-gzip)
2012-09-08 10:14 UTC, Toralf Förster
Details
Port of the 1.9.1 patch to 1.8.1. (gdal-1.8.1-poppler-0.20.1.patch,5.54 KB, patch)
2013-02-11 21:59 UTC, John R. Graham
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2012-09-08 10:14:38 UTC
make[2]: Entering directory `/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/frmts/pdf'
i686-pc-linux-gnu-g++ -O2 -march=native -pipe -fPIC  -Wall  -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/port -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/gcore -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/alg -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/ogr -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/ogr/ogrsf_frmts -DOGR_ENABLED -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/port -Iexternal/include -I/usr/ -I/usr//include  -DPOPPLER_HAS_OPTCONTENT -DPOPPLER_BASE_STREAM_HAS_TWO_ARGS -I/usr/include -I/usr/include/poppler -c -o ../o/pdfdataset.o pdfdataset.cpp
pdfdataset.cpp: In member function ‘virtual CPLErr PDFRasterBand::IReadBlock(int, int, void*)’:
pdfdataset.cpp:351:47: error: no matching function for call to ‘SplashOutputDev::startDoc(XRef*)’
pdfdataset.cpp:351:47: note: candidate is:
/usr/include/poppler/SplashOutputDev.h:309:8: note: void SplashOutputDev::startDoc(PDFDoc*)
/usr/include/poppler/SplashOutputDev.h:309:8: note:   no known conversion for argument 1 from ‘XRef*’ to ‘PDFDoc*’
pdfdataset.cpp: In static member function ‘static GDALDataset* PDFDataset::Open(GDALOpenInfo*)’:
pdfdataset.cpp:539:45: error: ‘setErrorFunction’ was not declared in this scope
pdfdataset.cpp:565:67: warning: ignoring return value of ‘char* fgets(char*, int, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]



(BTW I upgraded to app-text/poppler-0.20.3 which was nexcessary for KDE 4.9.1)

Reproducible: Always




tfoerste@n22 ~/devel/wireshark $ emerge --info sci-libs/gdal
Portage 2.1.11.9 (default/linux/x86/10.0/desktop/kde, gcc-4.6.3, glibc-2.15-r2, 3.5.3 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.5.3-i686-Intel-R-_Core-TM-_i5-2540M_CPU_@_2.60GHz-with-gentoo-2.1
Timestamp of tree: Fri, 07 Sep 2012 15:45:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo toralf
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --keep-going=y --nospinner --tree --deep --quiet-build"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.mneisen.org/ http://www.gtlib.gatech.edu/pub/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bittorrent branding bzip2 cairo cdda cdr classic cli consolekit corefonts cracklib crypt css cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif fam fastbuild ffmpeg firefox flac fontconfig fortran g3dvl gdbm gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kipi kqemu kvm lcms ldap libnotify lirc logrotate mad mbox mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nsplugin ntfs ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd qemu qt3support qt4 rdesktop readline sdl session sna spell sse sse2 sse4_1 ssl ssse3 startup-notification svg tcpd thinkpad threads tiff tk transparent-proxy truetype udev udisks unicode upower usb v4l vaapi vim-syntax vlc vnc vorbis wxwidgets x264 x86 xa xcb xcomposite xinerama xml xpm xscreensaver xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sci-libs/gdal-1.8.1-r1 was built with the following:
USE="aux_xml (consolekit) gif jpeg mysql pdf png (policykit) test threads -curl -debug -doc -ecwj2k -fits -geos -gml -hdf5 -jpeg2k -netcdf -odbc -ogdi -perl -postgres -python -ruby -sqlite" RUBY_TARGETS="-ruby18"
Comment 1 Toralf Förster gentoo-dev 2012-09-08 10:14:59 UTC
Created attachment 323200 [details]
build log
Comment 2 Toralf Förster gentoo-dev 2012-09-08 10:33:32 UTC
BTW gdal-1.9.1 compiles fine here.
Comment 3 Jaak Ristioja 2012-09-17 09:06:26 UTC
I can confirm this build error also for amd64. For weeks, building gdal-1.8.1-r1 has failed via revdep-rebuild.
Comment 4 Bernd Waibel 2012-10-27 08:17:42 UTC
I can confirm this bug too for stable amd64. It came up, when portage updated poppler to release 0.20.4 yesterday. As a workaround, if you emerge gdal with USE="-pdf" it builds fine.
Comment 5 kavol 2012-10-27 22:02:57 UTC
exactly the same here ... amd64, this issue has popped out with revdep-rebuild, and emerging gdal with USE=-pdf works
Comment 6 Jeroen Roovers gentoo-dev 2012-11-03 18:30:38 UTC
*** Bug 441604 has been marked as a duplicate of this bug. ***
Comment 7 Fabian Köster 2012-11-10 12:43:14 UTC
The patch from http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sci-libs/gdal/files/gdal-1.9.1-poppler-0.20.1.patch for sci-libs/gdal-1.9.1 needs to be backported to sci-libs/gdal-1.8.1.

See also
https://bugs.gentoo.org/show_bug.cgi?id=426584
Comment 8 pavel sanda 2012-11-20 00:41:05 UTC
i was just hit by this after poppler update
Comment 9 Stefan Langenmaier 2012-11-28 00:21:16 UTC
I can confirm it too. Happened to me after an update and revdep-rebuild. Building with USE="-pdf" solved the issue.
Comment 10 Thomas Weininger 2013-01-18 18:56:20 UTC
I can also confirm this bug on x86.
Comment 11 John R. Graham gentoo-dev 2013-02-11 21:59:02 UTC
Created attachment 338644 [details, diff]
Port of the 1.9.1 patch to 1.8.1.

Provisional port of the patch attached. Minimal testing under x86 only so far. Trivial modifications needed to the src_prepare() function to apply the patch left as an exercise for the reader. ;)
Comment 12 Jaak Ristioja 2013-02-13 19:28:44 UTC
I can confirm that the patch in comment #11 fixes the build on x86-64.
Comment 13 Aaron W. Swenson gentoo-dev 2013-06-24 23:36:08 UTC
1.8.1 no longer in tree.