Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 434156 - kde-base/kmail-4.9.1: Problems creating imap folder
Summary: kde-base/kmail-4.9.1: Problems creating imap folder
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: fixed in 4.10.2
Keywords:
Depends on: 466074
Blocks:
  Show dependency tree
 
Reported: 2012-09-06 20:31 UTC by Andreas K. Hüttel
Modified: 2013-05-05 10:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel archtester gentoo-dev 2012-09-06 20:31:46 UTC
My folders are on an imap server. When I try to create a new folder in KMail in the top level of the server, it is not appearing in KMail. Instead, akonadi error messages about non-existing objects pop up.

Checking in akonadiconsole, a local object exists but with a mangled name (Archv instead of Archiv). This for whatever reason cannot be transmitted to the server, hindering all further sync.

@team: please check and add info here, if we can confirm this a few times we should carry it upstream. I wont be able to help for the next 10days or so.
Comment 1 Franz Trischberger 2012-09-07 05:55:14 UTC
I first thought it is an automatism to rename "Archiv" to something less common - "Archiv" may exist on the server.
But then I created a folder "inziwinzi" - and it stripped all "i"s out of the name leaving "nzwnz" - so definitely a bug. ("Inz" keeps the big "I", btw.)
I also don't get them listed in kmail. In akonadiconsole they show up but can't be used. Nevertheless there is absolutely no error message in kmail. I only get one in akonadiconsole:
"AgentBase(akonadi_imap_resource_2): Could not create collection Archv resourceId: 8"
Comment 2 Andreas K. Hüttel archtester gentoo-dev 2012-09-07 08:38:14 UTC
Blargh. So it's real.

Franz, since you can reproduce the bug exactly, could you please report it upstream and keep the contact there?

(Im traveling during the next days and my laptop still has kmail-4.4.11.1-rX, which does not show this bug.)
Comment 3 Franz Trischberger 2012-09-07 09:20:33 UTC
This already was reported for 4.9.0 ;)
https://bugs.kde.org/show_bug.cgi?id=305269

The other issue with the "i"s:
https://bugs.kde.org/show_bug.cgi?id=306390
Comment 4 Agostino Sarubbo gentoo-dev 2012-11-25 11:40:22 UTC
I have no problem in kmail-4.9.3, what's the status for you?
Comment 5 Karl-Johan Karlsson 2012-11-25 12:15:10 UTC
I'm the one who reported the upstream bug (305269), and I'm still seeing it in KMail 4.9.3.
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2013-02-23 20:31:22 UTC
https://bugs.kde.org/show_bug.cgi?id=305269 is far too general for this, removing from URL
Comment 7 Johannes Huber gentoo-dev 2013-05-05 10:34:08 UTC
Thanks all. As KDE SC 4.10.2 is now stable on all target arches. This bug is fixed.