Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432350 - dev-java/emma won't build on non-Sun JDKs
Summary: dev-java/emma won't build on non-Sun JDKs
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-22 20:42 UTC by Andrew John Hughes
Modified: 2012-08-22 20:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew John Hughes 2012-08-22 20:42:46 UTC
[javac] 1. ERROR in /mnt/builder/portage.build/portage/dev-java/emma-2.0.5312-r2/work/emma-2.0.5312/core/java13/com/vladium/util/exit/ExitHookManager.java (at line 14)
    [javac] 	import sun.misc.Signal;
    [javac] 	       ^^^^^^^^^^^^^^^
    [javac] The import sun.misc.Signal cannot be resolved
    [javac] ----------
    [javac] 2. ERROR in /mnt/builder/portage.build/portage/dev-java/emma-2.0.5312-r2/work/emma-2.0.5312/core/jav
    [javac] a13/com/vladium/util/exit/ExitHookManager.java (at line 15)
    [javac] 	import sun.misc.SignalHandler;
    [javac] 	       ^^^^^^^^^^^^^^^^^^^^^^
    [javac] The import sun.misc.SignalHandler cannot be resolved

Thus the dependency on >=virtual/jdk-1.4 & >=virtual/jre-1.4 is not sufficient.

Reproducible: Always




Portage 2.2.0_alpha121 (default/linux/amd64/10.0/desktop, gcc-4.7.1, glibc-2.15-r2, 3.5.2-gentoo.rivendell x86_64)
=================================================================
System uname: Linux-3.5.2-gentoo.rivendell-x86_64-Intel-R-_Xeon-R-_CPU_X5482_@_3.20GHz-with-gentoo-2.1
Timestamp of tree: Wed, 22 Aug 2012 01:45:01 +0000
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5, 1.12.3
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2