Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432252 - x11-drivers/nvidia-drivers-304.37-r1 ${WORKDIR}//32/libnvidia-opencl.so.304.37 does not exist
Summary: x11-drivers/nvidia-drivers-304.37-r1 ${WORKDIR}//32/libnvidia-opencl.so.304.3...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
: 432270 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-21 22:51 UTC by Chris Smith
Modified: 2012-08-22 14:35 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,66.17 KB, text/x-log)
2012-08-21 23:34 UTC, Luke Wallace
Details
build log (build.log,64.01 KB, text/plain)
2012-08-22 02:48 UTC, mjh49783
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Smith 2012-08-21 22:51:15 UTC
x11-drivers/nvidia-drivers-304.37-r1 fails to install on amd64

Reproducible: Always

Actual Results:  
>>> Install nvidia-drivers-304.37-r1 into /var/tmp/portage/x11-drivers/nvidia-drivers-304.37-r1/image/ category x11-drivers
 * Installing nvidia module
!!! dolib: /var/tmp/portage/x11-drivers/nvidia-drivers-304.37-r1/work//32/libnvidia-opencl.so.304.37 does not exist
 * ERROR: x11-drivers/nvidia-drivers-304.37-r1 failed (install phase):
 *   dolib failed


Expected Results:  
Should install normally (why is it looking in //32/ on amd64?).
Comment 1 Luke Wallace 2012-08-21 23:32:01 UTC
emerge --info '=x11-drivers/nvidia-drivers-304.37-r1
Portage 2.2.0_alpha121 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.15-r2, 3.5.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.5.0-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9400_@_2.53GHz-with-gentoo-2.2
Timestamp of tree: Tue, 21 Aug 2012 22:45:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.3
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo gechi gentoo-guis sabayon
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula skype-4.0.0.7-copyright google-talkplugin googleearth AdobeFlash-10.3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j2 --load-average=1.8 --keep-going --autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://lug.mtu.edu/gentoo/ http://lug.mtu.edu/gentoo/ http://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3 --load-average=2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gechi /var/lib/layman/gentoo-guis /var/lib/layman/sabayon"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus dhcpcd dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gnutls gpm gstreamer gtk iconv ipv6 java jpeg kde lcms ldap libnotify mad matroska mmx mng modules mozilla mp3 mp4 mpeg mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline samba sdl semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


sudo emerge -pqv '=x11-drivers/nvidia-drivers-304.37-r1'
[ebuild     U ] x11-drivers/nvidia-drivers-304.37-r1 [304.37] USE="X acpi (multilib) tools"
Comment 2 Luke Wallace 2012-08-21 23:34:22 UTC
Created attachment 321896 [details]
build log
Comment 3 mjh49783 2012-08-22 02:48:02 UTC
Created attachment 321906 [details]
build log
Comment 4 mjh49783 2012-08-22 02:49:49 UTC
Having the same issue.

emerge --info =x11-drivers/nvidia-drivers-304.37-r1


Portage 2.1.11.9 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r2, 3.3.8-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.8-gentoo-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.1
Timestamp of tree: Wed, 22 Aug 2012 01:15:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.cites.uiuc.edu/pub/gentoo/ http://gentoo.netnitco.net http://gentoo.cs.uni.edu/ http://lug.mtu.edu/gentoo/ http://mirror.mcs.anl.gov/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 apache2 apng audacious autoipd avahi berkdb bluetooth branding bzip2 cairo cdb cdda cddb cdparanoia cdr chipcard clamdtop cli colord compat consolekit cracklib crypt css cups cxx daap dbus declarative device-mapper dhcpcd directfb disk-partition dmraid dri dts dvb dvd dvdr emboss encode evo exif extensions extras fam fat fbcon fbcondecor fbsplash ffmpeg firefox flac fortran ftdi ftp g3dvl gcj gdbm gif gimp gmail gnome-online-accounts gnutls gpac gpm gstreamer gtk hbci hddtemp hfs iconv icu id3tag ieee1394 imagemagick imap ipv6 java javascript jfs joystick jpeg jpeg2k kde kdrive lame laptop latin1 lcd lcms ldap libnotify lm_sensors lock lvm mad maildir mbox mdadm mdnsresponder-compat milter mmx mmxext mng modules mp3 mp4 mpeg msn mudflap multilib nautilus ncurses nfs nls nptl nsplugin ntfs ntfsprogs offensive offlinehelp ogg opengl openmp oss pam pango parted pcre pdf pidgin png policykit pop posix ppds pppd python qt3support qt4 quicktime readline rss samba scanner sdl sensord session smp sndfile socialweb spell sql sqlite sse sse2 sse3 ssl startup-notification static-libs svg syslog tcpd theora threads thunar tiff transcode truetype type1 udev udisks unicode upower usb vcd virtualbox vorbis wavpack weather webkit wifi winbind wma wps wxwidgets x264 xcb xcomposite xfs xine xml xv xvid xvmc yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="cfontzpacket" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

[ebuild     U ] x11-drivers/nvidia-drivers-304.37-r1 [304.37] USE="X acpi (multilib) tools"
Comment 5 Doug Goldstein gentoo-dev 2012-08-22 04:13:00 UTC
Should be fixed in the tree now.
Comment 6 Mike Gilbert gentoo-dev 2012-08-22 04:21:23 UTC
Nope. Now I get this:

!!! dolib: /libnvidia-opencl.so.304.37 does not exist

I think ${libdir} is not set in src_install.
Comment 7 Doug Goldstein gentoo-dev 2012-08-22 04:51:09 UTC
Maybe now.
Comment 8 mjh49783 2012-08-22 13:58:33 UTC
Yay! It's working for me now. ;^)
Comment 9 Jeroen Roovers gentoo-dev 2012-08-22 14:20:31 UTC
*** Bug 432270 has been marked as a duplicate of this bug. ***
Comment 10 Chris Smith 2012-08-22 14:35:09 UTC
Installs now.

What about libnvidia-wfb.so mentioned in https://bugs.gentoo.org/show_bug.cgi?id=431998#c1 should this lib also be installed?

Thanks!