Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 431488 - net-wireless/bluez-tools - Command line tools for Bluez
Summary: net-wireless/bluez-tools - Command line tools for Bluez
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://code.google.com/p/bluez-tools/
Whiteboard:
Keywords: EBUILD
: 488146 (view as bug list)
Depends on: 452162
Blocks:
  Show dependency tree
 
Reported: 2012-08-15 08:13 UTC by James Le Cuirot
Modified: 2015-10-22 03:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
bluez-tools-20110923.ebuild (bluez-tools-20110923.ebuild,744 bytes, text/plain)
2012-08-15 08:13 UTC, James Le Cuirot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Le Cuirot gentoo-dev 2012-08-15 08:13:32 UTC
Created attachment 321386 [details]
bluez-tools-20110923.ebuild

Command line tools have been sorely missing from Bluez since they were removed a good while back. Thankfully someone has created some new ones. Please see the attached ebuild. The latest release doesn't support recent versions of Bluez but this snapshot from Gitorious does.

I won't have to install X on my Pentium 120 after all! ;)
Comment 1 James Le Cuirot gentoo-dev 2012-08-18 12:52:27 UTC
This produces an implicit declaration for getline when building with uClibc 0.9.33.2 but this is simply because that version of uClibc still treats it as a GNU extension. This has already been fixed in uClibc master.
Comment 2 Elias Probst 2013-01-14 00:38:09 UTC
This will be deprecated once net-wireless/bluez-5.1 is there.
Since BlueZ 5.0, there is "bluetoothctl" which replaces AFAIK all these tools.
Comment 3 Samuli Suominen gentoo-dev 2013-05-07 12:31:06 UTC
Closing as OBSOLETE since this won't go in tree -- BlueZ 5.x will
Comment 4 Rick Farina (Zero_Chaos) gentoo-dev 2015-10-22 03:15:53 UTC
*** Bug 488146 has been marked as a duplicate of this bug. ***