Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430468 - app-dicts/myspell-de-2012.06.10, hunspell: Incompatible file names for LyX
Summary: app-dicts/myspell-de-2012.06.10, hunspell: Incompatible file names for LyX
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Spell checking utilities and dictionaries -- related bugs (OBSOLETE)
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-08-08 15:53 UTC by tbartdev
Modified: 2013-06-15 20:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patched ebuild, creates links without "frami" in their names (myspell-de-2012.06.10-r1.ebuild,1.69 KB, text/plain)
2012-08-08 15:53 UTC, tbartdev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tbartdev 2012-08-08 15:53:07 UTC
Created attachment 320718 [details]
Patched ebuild, creates links without "frami" in their names

current myspell-de ebuild (pulled in by hunspell) puts files like
de_AT_frami.aff
de_AT_frami.dic

into /usr/share/hunspell

LyX does not find those, as it searches for <locale>.dic

see
http://wiki.lyx.org/Devel/Hunspell

for details.

I don't know what the correct way to solve this is, but the attached ebuild solves it. Please correct it if should be solved with dosym etc. and let me know!

tia!
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-08-08 23:57:34 UTC
Comment on attachment 320718 [details]
Patched ebuild, creates links without "frami" in their names

--- myspell-de-2012.06.10.ebuild        2012-06-17 12:31:03.000000000 +0200
+++ -   2012-08-09 01:57:04.512341237 +0200
@@ -46,3 +46,14 @@
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
 IUSE=""
+
+src_install() {
+
+myspell-r2_src_install
+
+# LyX won't find dicts with _frami appended, see
+# http://wiki.lyx.org/Devel/Hunspell
+cd "${D}/usr/share/hunspell"
+for d in *_frami.*; do
+       ln -s "$d" "${d/_frami}" || die; done
+}


Needs some indenting, it seems.
Comment 2 pavel sanda 2012-08-13 07:52:44 UTC
also #356853 

i believe there was bug for this naming myspell issues (i found its not case just for _de) but i can't find it in the database now...
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2012-08-17 10:01:07 UTC
This is weird, see how enchant/myspell actually does it.

I would say the lyx should actually fix the loading mechanism they use for the dicts. If that is not possible, we can for sure rename the files with no problem.
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2012-08-17 11:23:38 UTC
Anyway renamed the files to be done with it. If you find problem with other langs just feel free to report them.
Comment 5 Johannes Huber gentoo-dev 2012-08-18 09:22:24 UTC
Re-opened.

+  18 Aug 2012; Johannes Huber <johu@gentoo.org> +myspell-de-2012.06.17.ebuild,
+  -myspell-de-2012.06.17-r1.ebuild:
+  Restore -r0 remove newer as it is broken by scarabeus.
Comment 6 Michael Hofmann 2013-06-02 16:45:14 UTC
German spell checking in LibreOffice 4.0 doesn't work because LibreOffice
doesn't find German dictionaries.

If I rename de_DE_frami.dic and de_DE_frami.aff to de_DE.dic and de_DE.aff, 
the spell checker works fine...

It would be better remove '_frami' from the filenames of the German dictionaries.

See also https://bugs.gentoo.org/show_bug.cgi?id=458772, Comment 7
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2013-06-04 13:10:38 UTC
Removed the frami part in -r1 bump of the dicts as suggested.

Lets see how many regressions that cause.
Comment 8 Christian Loosli 2013-06-15 20:50:01 UTC
(In reply to Tomáš Chvátal from comment #7)
> Removed the frami part in -r1 bump of the dicts as suggested.
> 
> Lets see how many regressions that cause.

KDE spellchecking breaks with swissgerman, 

kate(10596): No language dictionaries for the language :  "de_CH_frami" 

could you see if providing compatibility symlinks including _frami doesn't break open/libre office, or poke the KDE people? 

Thanks.