Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430204 - sys-devel/gcc-4.2* fails to build on amd64 NetBSD during bootstrap due to missing typedef in ansidecl.h
Summary: sys-devel/gcc-4.2* fails to build on amd64 NetBSD during bootstrap due to mis...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: AMD64 NetBSD
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords: Bug
Depends on:
Blocks:
 
Reported: 2012-08-06 17:50 UTC by dougztr
Modified: 2017-07-18 09:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix for gcc during prefix bootstrap on NetBSD (patch-gcc-ansidecl.h,285 bytes, text/plain)
2012-08-06 17:50 UTC, dougztr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dougztr 2012-08-06 17:50:07 UTC
Created attachment 320572 [details]
Fix for gcc during prefix bootstrap on NetBSD

bootstrapping gcc 4.2 and possibly higher fails in iberty with errors in mempcpy.c. The issue is caused in ansidecl.h where PTR is not defined for NetBSD systems. Confirmed on irc #netbsd that PTR should be (int *) on x64. ryao found a patch for this which I tested and confirmed it to work. http://www.ki.nu/~makoto/diary/2009/01/19/  and I have attached the patch.
Comment 1 Richard Yao (RETIRED) gentoo-dev 2012-08-06 18:02:56 UTC
There is another failure in libstdc++. The bootstrap procedure should build a newer version of GCC before that becomes an issue.

This patch will permit sys-devel/gcc-4.2* to build on amd64 NetBSD with USE="-cxx nocxx". Without it, it will not build at all.
Comment 2 Richard Yao (RETIRED) gentoo-dev 2012-08-06 18:05:47 UTC
Also, we should either wrap the typedef with a NetBSD preprocessor conditional or do regression testing on other platforms.
Comment 3 Michael Haubenwallner gentoo-dev 2017-07-18 09:03:16 UTC
We do not use gcc-4.2 any more in Prefix.