Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427990 - virtual/perl-File-Spec-3.330.0-r1 tries to downgrade dev-lang/perl-5.16.0
Summary: virtual/perl-File-Spec-3.330.0-r1 tries to downgrade dev-lang/perl-5.16.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-25 06:21 UTC by Dmytro Gorbunov
Modified: 2013-09-04 23:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmytro Gorbunov 2012-07-25 06:21:26 UTC
Hello, 

I have perl-5.16 installed and virtual/perl-File-Spec-3.330.0-r1 asks for downgrade to perl-5.14 because of the following line in perl-File-Spec-3.330.0-r1.ebuild

14 RDEPEND="|| ( =dev-lang/perl-5.14* ~perl-core/${PN#perl-}-${PV} )"

Please fix if possible.

P.S.
Locally I've changed it to the following for avoid downgrading
RDEPEND="|| ( >=dev-lang/perl-5.14.0 ~perl-core/${PN#perl-}-${PV} )"

Reproducible: Always
Comment 1 turtle 2012-09-25 19:42:06 UTC
Thanks For finding this I was wondering why perl-cleaner kept downgrading me.
I can confirm this bug.
Comment 2 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-09-04 23:26:29 UTC
3.330.0-r1 no longer in the tree, please use last stable version (3.400.0) instead.