Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427830 - sys-devel/clang-3.1-r4 - clang: error: unable to execute command: Illegal instruction (in .../work/llvm-3.1.src/tools/clang/runtime/compiler-rt/clang_linux/full-i386/i386/SubDir.lib/gcc_personality_v0.o] Ошибка 254)
Summary: sys-devel/clang-3.1-r4 - clang: error: unable to execute command: Illegal ins...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo Clang Team (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-24 01:07 UTC by devt
Modified: 2015-09-03 09:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
complete log of building clang (build.log.tar.xz,74.06 KB, application/x-xz)
2012-07-24 01:20 UTC, devt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description devt 2012-07-24 01:07:37 UTC
I'd tried to compile clang-3.1, but compile fails one and the same place.


Reproducible: Always

Steps to Reproduce:
emerge -v clang
Actual Results:  
'emake failed' every time, when I'm trying to compile clang-3.1-r4

Expected Results:  
I want just compile clang on Gentoo i686 successfully, nothing else o_O

emerge --info:
Portage 2.2.0_alpha118 (default/linux/x86/10.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r2, 3.4.0-gentoo i686)                                                                    
=================================================================                                                                                                             
System uname: Linux-3.4.0-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_E7300_@_2.66GHz-with-gentoo-2.1                                                                              
Timestamp of tree: Sat, 14 Jul 2012 00:45:01 +0000                                                                                                                            
ccache version 3.1.7 [enabled]                                                                                                                                                
app-shells/bash:          4.2_p20                                                                                                                                             
dev-lang/python:          2.7.3-r2, 3.2.3                                                                                                                                     
dev-util/ccache:          3.1.7                                                                                                                                               
dev-util/pkgconfig:       0.27                                                                                                                                                
sys-apps/baselayout:      2.1-r1                                                                                                                                              
sys-apps/openrc:          0.10.4                                                                                                                                              
sys-apps/sandbox:         2.5                                                                                                                                                 
sys-devel/autoconf:       2.69                                                                                                                                                
sys-devel/automake:       1.12.2                                                                                                                                              
sys-devel/binutils:       2.22-r1                                                                                                                                             
sys-devel/gcc:            4.5.3-r2, 4.6.3, 4.7.1                                                                                                                              
sys-devel/gcc-config:     1.5-r2                                                                                                                                              
sys-devel/libtool:        2.4.2                                                                                                                                               
sys-devel/make:           3.82-r1                                                                                                                                             
sys-kernel/linux-headers: 3.1 (virtual/os-headers)                                                                                                                            
sys-libs/glibc:           2.15-r2                                                                                                                                             
Repositories: gentoo                                                                                                                                                          
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -ftree-vectorize -msse -msse2 -mssse3 -msse4 -msse4.1 -g0"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -ftree-vectorize -msse -msse2 -mssse3 -msse4 -msse4.1 -g0"
DISTDIR="/home/devt/distfiles"
EMERGE_DEFAULT_OPTS=" --with-bdeps=y"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs candy ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/home/devt/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cleartype cli colord consolekit cracklib crypt cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam fbcondecor firefox flac fortran freetype gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline sdl session socialweb spell sse sse2 sse3 ssl startup-notification svg tcpd tiff truetype type1 udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 devt 2012-07-24 01:20:48 UTC
Created attachment 319048 [details]
complete log of building clang
Comment 2 devt 2012-07-24 01:33:56 UTC
Part of build log:

ASSEMBLE:  clang_linux/full-i386/i386: /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/i386/moddi3.S
/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/Release/bin/clang -Wall -Werror -O3 -fomit-frame-pointer -m32 --sysroot=/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/SDKs/linux -c -o /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt/clang_linux/full-i386/i386/SubDir.lib__i386/moddi3.o /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/i386/moddi3.S
0  libLLVM-3.1.so  0x5581a2e8
1  libLLVM-3.1.so  0x5581a9b4
2  linux-gate.so.1 0x55577400 __kernel_sigreturn + 0
3  libLLVM-3.1.so  0x557436b1
4  libLLVM-3.1.so  0x55745a56
5  libLLVM-3.1.so  0x5574b7f5
6  libLLVM-3.1.so  0x5574d2c6
7  libLLVM-3.1.so  0x55a3233e llvm::LPPassManager::runOnFunction(llvm::Function&) + 942
8  libLLVM-3.1.so  0x55d2632c llvm::FPPassManager::runOnFunction(llvm::Function&) + 556
9  libLLVM-3.1.so  0x55d263ec llvm::FPPassManager::runOnModule(llvm::Module&) + 76
10 libLLVM-3.1.so  0x55d25f65 llvm::MPPassManager::runOnModule(llvm::Module&) + 501
11 libLLVM-3.1.so  0x55d260a0 llvm::PassManagerImpl::run(llvm::Module&) + 128
12 libLLVM-3.1.so  0x55d260f6 llvm::PassManager::run(llvm::Module&) + 38
13 clang           0x082c14bc clang::EmitBackendOutput(clang::DiagnosticsEngine&, clang::CodeGenOptions const&, clang::TargetOptions const&, clang::LangOptions const&, llvm::Module*, clang::BackendAction, llvm::raw_ostream*) + 2028
14 clang           0x082bf360
15 clang           0x08412f40 clang::ParseAST(clang::Sema&, bool, bool) + 512
16 clang           0x08199c57 clang::ASTFrontendAction::ExecuteAction() + 119
Stack dump:
0.      Program arguments: /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/Release/bin/clang -cc1 -triple i386-pc-linux-gnu -emit-obj -disable-free -disable-llvm-verifier -main-file-name gcc_personality_v0.c -pic-level 2 -masm-verbose -mconstructor-aliases -target-cpu pentium4 -target-linker-version 2.22 -momit-leaf-frame-pointer -coverage-file /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt/clang_linux/full-i386/i386/SubDir.lib/gcc_personality_v0.o -resource-dir /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/Release/bin/../lib/clang/3.1 -isysroot /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/SDKs/linux -fmodule-cache-path /var/tmp/portage/sys-devel/clang-3.1-r4/temp/clang-module-cache -internal-isystem /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/SDKs/linux/usr/local/include -internal-isystem /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/Release/bin/../lib/clang/3.1/include -internal-externc-isystem /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/SDKs/linux/include -internal-externc-isystem /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/SDKs/linux/usr/include -O3 -Wall -Werror -fdebug-compilation-dir /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt -ferror-limit 19 -fmessage-length 0 -mstackrealign -fgnu-runtime -fobjc-runtime-has-arc -fobjc-runtime-has-weak -fobjc-fragile-abi -fdiagnostics-show-option -o /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt/clang_linux/full-i386/i386/SubDir.lib/gcc_personality_v0.o -x c /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/gcc_personality_v0.c 
1.      <eof> parser at end of file
2.      Code generation
3.      Running pass 'Function Pass Manager' on module '/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/gcc_personality_v0.c'.
4.      Running pass 'Loop Pass Manager' on function '@__gcc_personality_v0'
5.      Running pass 'Loop Strength Reduction' on basic block '%.preheader'
clang: error: unable to execute command: Illegal instruction
clang: error: clang frontend command failed due to signal (use -v to see invocation)
clang: note: diagnostic msg: Please submit a bug report to http://llvm.org/bugs/ and include command line arguments and all diagnostic information.
  COMPILE:   clang_linux/full-i386/i386: /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/modsi3.c
/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/Release/bin/clang -Wall -Werror -O3 -fomit-frame-pointer -m32 --sysroot=/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/SDKs/linux -c -fPIC -o /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt/clang_linux/full-i386/i386/SubDir.lib/modsi3.o /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/modsi3.c
  COMPILE:   clang_linux/full-i386/i386: /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/modti3.c
clang: note: diagnostic msg: Preprocessed source(s) and associated run script(s) are located at:
clang: note: diagnostic msg: /var/tmp/portage/sys-devel/clang-3.1-r4/temp/gcc_personality_v0-d43efp.i
clang: note: diagnostic msg: /var/tmp/portage/sys-devel/clang-3.1-r4/temp/gcc_personality_v0-d43efp.sh
make[4]: *** [/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt/clang_linux/full-i386/i386/SubDir.lib/gcc_personality_v0.o] Error 254
make[4]: *** Ожидание завершения заданий...
/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/Release/bin/clang -Wall -Werror -O3 -fomit-frame-pointer -m32 --sysroot=/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/SDKs/linux -c -fPIC -o /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt/clang_linux/full-i386/i386/SubDir.lib/modti3.o /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt/lib/modti3.c
make[4]: Выход из каталога `/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/projects/compiler-rt'
make[3]: *** [BuildRuntimeLibraries] Error 2
rm /var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/Release/lib/clang/3.1/lib/linux/.dir
make[3]: Выход из каталога `/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime/compiler-rt'
make[2]: *** [compiler-rt/.makeall] Error 2
make[2]: Выход из каталога `/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang/runtime'
make[1]: *** [all] Error 1
make[1]: Выход из каталога `/var/tmp/portage/sys-devel/clang-3.1-r4/work/llvm-3.1.src/tools/clang'
make: *** [all] Error 1
 * ERROR: sys-devel/clang-3.1-r4 failed (compile phase):
 *   emake failed
Comment 3 Rafał Mużyło 2012-07-24 02:12:42 UTC
Likely, this line of the build log should give you a thought:
clang: error: unable to execute command: Illegal instruction

While there *is* a chance you've stumbled upon a genuine compiler bug, first try more conservative cflags.
Comment 4 devt 2012-07-24 03:18:46 UTC
(In reply to comment #3)
> Likely, this line of the build log should give you a thought:
> clang: error: unable to execute command: Illegal instruction
> 
> While there *is* a chance you've stumbled upon a genuine compiler bug, first
> try more conservative cflags.

Ok, I will try it. But what idea from You? What сflags should be removed in Your think?

Хорошо, я попробую. Но какие идеи у Вас? Какие флаги следует убрать по Вашему мнению?
Comment 5 Jeroen Roovers gentoo-dev 2012-07-24 15:50:35 UTC
Comment on attachment 319048 [details]
complete log of building clang

Please don't put a single file in a tar archive next time.
Comment 6 Rafał Mużyło 2012-07-24 16:06:15 UTC
Wait a moment:
Portage 2.2.0_alpha118 (default/linux/x86/10.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r2, 3.4.0-gentoo *i686*)

Is that a fresh install or a chroot, cause i686 and core2 is an odd mix otherwise ?
Comment 7 devt 2012-07-25 12:50:04 UTC
(In reply to comment #6)
> Wait a moment:
> Portage 2.2.0_alpha118 (default/linux/x86/10.0/desktop/gnome, gcc-4.6.3,
> glibc-2.15-r2, 3.4.0-gentoo *i686*)
> 
> Is that a fresh install or a chroot, cause i686 and core2 is an odd mix
> otherwise ?

And in the real system and the virtual - the same error. Yes, when I'd compile clang, I was in chroot, but when I reboot into real system — the same error. And thos system has no X-org and DE.
Comment 8 devt 2012-07-25 12:52:07 UTC
(In reply to comment #5)
> Comment on attachment 319048 [details]
> complete log of building clang
> 
> Please don't put a single file in a tar archive next time.

Ok. Say me please any other idea to sent 1.2 MiB log file. I'm really don't know or wasn't understand.
Comment 9 devt 2012-07-25 14:31:15 UTC
Clang has been compiled without -ftree-vectorize cxxflag!
Comment 10 devt 2012-07-25 14:59:26 UTC
But after trying to compile any program error appears again. Example with compiling llvm using clang as main compiler:

llvm[1]: Compiling APFloat.cpp for Release build
if  clang++ -I/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/include -I/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support  -DNDEBUG -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS   -fvisibility-inlines-hidden -fno-exceptions -fPIC -Woverloaded-virtual -Wcast-qual -O2 -march=core2 -pipe -fomit-frame-pointer -msse -msse2 -msse3  -I/usr/lib/libffi-3.0.11/include    -Wall -W -Wno-unused-parameter -Wwrite-strings -Wcovered-switch-default -c -MMD -MP -MF "/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d.tmp" -MT "/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.o" -MT "/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d" APFloat.cpp -o /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.o ; \
        then /bin/mv -f "/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d.tmp" "/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d"; else /bin/rm "/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d.tmp"; exit 1; fi
0  libLLVM-3.1.so  0x55827798
1  libLLVM-3.1.so  0x55827e64
2  linux-gate.so.1 0x55577400 __kernel_sigreturn + 0
3  libLLVM-3.1.so  0x55750f41
4  libLLVM-3.1.so  0x557532e6
5  libLLVM-3.1.so  0x55759085
6  libLLVM-3.1.so  0x5575ab56
7  libLLVM-3.1.so  0x55a3f59e llvm::LPPassManager::runOnFunction(llvm::Function&) + 942
8  libLLVM-3.1.so  0x55d3310c llvm::FPPassManager::runOnFunction(llvm::Function&) + 556
9  libLLVM-3.1.so  0x55d331cc llvm::FPPassManager::runOnModule(llvm::Module&) + 76
10 libLLVM-3.1.so  0x55d32d45 llvm::MPPassManager::runOnModule(llvm::Module&) + 501
11 libLLVM-3.1.so  0x55d32e80 llvm::PassManagerImpl::run(llvm::Module&) + 128
12 libLLVM-3.1.so  0x55d32ed6 llvm::PassManager::run(llvm::Module&) + 38
13 clang           0x082ccd8d clang::EmitBackendOutput(clang::DiagnosticsEngine&, clang::CodeGenOptions const&, clang::TargetOptions const&, clang::LangOptions const&, llvm::Module*, clang::BackendAction, llvm::raw_ostream*) + 1965
14 clang           0x082cae3a
15 clang           0x0841aa2f clang::ParseAST(clang::Sema&, bool, bool) + 511
16 clang           0x081a2a48 clang::ASTFrontendAction::ExecuteAction() + 120
Stack dump:
0.      Program arguments: /usr/bin/clang -cc1 -triple i386-pc-linux-gnu -emit-obj -disable-free -disable-llvm-verifier -main-file-name APFloat.cpp -pic-level 2 -masm-verbose -mconstructor-aliases -target-cpu core2 -target-feature +sse -target-feature +sse2 -target-feature +sse3 -target-linker-version 2.22 -momit-leaf-frame-pointer -coverage-file /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.o -resource-dir /usr/bin/../lib/clang/3.1 -dependency-file /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d.tmp -MP -MT /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.o -MT /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d -D NDEBUG -D _GNU_SOURCE -D __STDC_CONSTANT_MACROS -D __STDC_FORMAT_MACROS -D __STDC_LIMIT_MACROS -I /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/include -I /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support -I /usr/lib/libffi-3.0.11/include -fmodule-cache-path /var/tmp/portage/sys-devel/llvm-3.1-r1/temp/clang-module-cache -internal-isystem /usr/lib/gcc/i686-pc-linux-gnu/4.7.1/include/g++-v4 -internal-isystem /usr/lib/gcc/i686-pc-linux-gnu/4.7.1/include/g++-v4/i686-pc-linux-gnu -internal-isystem /usr/lib/gcc/i686-pc-linux-gnu/4.7.1/include/g++-v4/backward -internal-isystem /usr/local/include -internal-isystem /usr/bin/../lib/clang/3.1/include -internal-externc-isystem /include -internal-externc-isystem /usr/include -O2 -Woverloaded-virtual -Wcast-qual -Wall -W -Wno-unused-parameter -Wwrite-strings -Wcovered-switch-default -fconst-strings -fdeprecated-macro -fdebug-compilation-dir /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support -ferror-limit 19 -fmessage-length 0 -fvisibility-inlines-hidden -mstackrealign -fgnu-runtime -fobjc-runtime-has-arc -fobjc-runtime-has-weak -fobjc-fragile-abi -fdiagnostics-show-option -o /var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.o -x c++ APFloat.cpp 
1.      <eof> parser at end of file
2.      Code generation
3.      Running pass 'Function Pass Manager' on module 'APFloat.cpp'.
4.      Running pass 'Loop Pass Manager' on function '@_ZN4llvm7APFloat28convertFromHexadecimalStringENS_9StringRefENS0_12roundingModeE'
5.      Running pass 'Loop Strength Reduction' on basic block '%.preheader.i'
clang: error: unable to execute command: Illegal instruction
clang: error: clang frontend command failed due to signal (use -v to see invocation)
clang: note: diagnostic msg: Please submit a bug report to http://llvm.org/bugs/ and include command line arguments and all diagnostic information.
clang: note: diagnostic msg: Preprocessed source(s) and associated run script(s) are located at:
clang: note: diagnostic msg: /var/tmp/portage/sys-devel/llvm-3.1-r1/temp/APFloat-7IkRPw.ii
clang: note: diagnostic msg: /var/tmp/portage/sys-devel/llvm-3.1-r1/temp/APFloat-7IkRPw.sh
/bin/rm: невозможно удалить «/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.d.tmp»: Нет такого файла или каталога
make[1]: *** [/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support/Release/APFloat.o] Ошибка 1
make[1]: Выход из каталога `/var/tmp/portage/sys-devel/llvm-3.1-r1/work/llvm-3.1.src/lib/Support'
make: *** [all] Ошибка 1
 * ERROR: sys-devel/llvm-3.1-r1 failed (compile phase):
 *   emake failed
Comment 11 Bernard Cafarelli gentoo-dev 2015-09-03 09:46:58 UTC
Cleaning some old llvm/clang bugs, does it still fail to compile with current versions? (3.7.0 was just added in tree)