Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426756 - sci-physics/jaxodraw-2.0.1 - doicon etc/OS/Linux/*.png: etc/OS/Linux/*.png is not a valid file/directory!
Summary: sci-physics/jaxodraw-2.0.1 - doicon etc/OS/Linux/*.png: etc/OS/Linux/*.png is...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-15 22:28 UTC by David Zaslavsky
Modified: 2014-03-28 10:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,1.61 KB, text/plain)
2012-07-21 23:17 UTC, David Zaslavsky
Details
Updated ebuild which fixes the problem for me (jaxodraw-2.0.1-r1.ebuild,1.50 KB, text/plain)
2012-09-25 02:28 UTC, David Zaslavsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Zaslavsky 2012-07-15 22:28:48 UTC
Emerging sci-physics/jaxodraw-2.0.1 gives the error message "etc/OS/Linux/*.png is not a valid file/directory!" in the installation step.


Reproducible: Always

Steps to Reproduce:
1. emerge =sci-physics/jaxodraw-2.0.1

Actual Results:  
Emerge failed with the output

 * etc/OS/Linux/*.png is not a valid file/directory!
 * ERROR: sci-physics/jaxodraw-2.0.1 failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line   85:  Called src_install
 *   environment, line 4048:  Called doicon 'etc/OS/Linux/*.png'
 *   environment, line  466:  Called _iconins 'doicon' 'etc/OS/Linux/*.png'
 *   environment, line  347:  Called die
 * The specific snippet of code:
 *       fi ) || die
 * 


Expected Results:  
The package should have installed without error

GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.33"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER="javac"

Output of emerge --info:
Portage 2.1.11.7 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.15-r2, 3.3.3-gentoo x86_64)
=================================================================
System uname: Linux-3.3.3-gentoo-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.1
Timestamp of tree: Sat, 14 Jul 2012 06:45:01 +0000
app-shells/bash:          4.2_p36
dev-java/java-config:     2.1.12
dev-lang/python:          2.4.6, 2.5.4-r4, 2.6.7-r2, 2.7.3-r2, 3.1.4-r3, 3.2.3-r1
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.6, 1.12.2
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo sunrise x-ellipsix cj-overlay sage-on-gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL AdobeFlash-10.3 AdobeFlash-10.1 AdobeFlash-10 google-talkplugin Oracle-BCLA-JavaSE Mendeley-EULA skype-eula skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -pipe -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -pipe -O2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet --ask-enter-invalid --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.gtlib.gatech.edu/pub/gentoo http://mirror.mcs.anl.gov/pub/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/  http://mirrors.cs.wmich.edu/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/ellipsix /var/lib/layman/cj-overlay /var/lib/layman/sage-on-gentoo /usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo caps cdda cddb cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif git gnutls gphoto2 gpm iconv idn imagemagick imap ipv6 ipython jadetex java java6 javascript jpeg jpeg2k kde kdepim kpathsea latex lcms ldap libnotify logrotate mad maildir matplotlib midi mime mmx mng modules mp3 mp4 mpeg mtp mudflap multilib mysql ncurses networkmanager nls nptl nsplugin nvidia ogg opengl openmp pam pango pcmcia pcre pdf phonon png policykit posix ppds pppd pulseaudio python qt3support qt4 readline rss samba sdl semantic-desktop session smp spell sql sse sse2 ssl startup-notification subversion svg tcpd theora threads tiff tordns truetype udev udisks unicode upower usb vhosts vorbis wmf wxwidgets x264 xattr xcb xcomposite xine xinerama xml xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon ptp2 samsung" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2012-07-18 16:00:24 UTC
Please attach the entire build log to this bug report.
Comment 2 David Zaslavsky 2012-07-21 23:17:38 UTC
Created attachment 318876 [details]
build log
Comment 3 David Zaslavsky 2012-09-25 02:28:06 UTC
Created attachment 324914 [details]
Updated ebuild which fixes the problem for me

Changes are in lines 31 and 32 in src_install
Comment 4 Hamlet 2013-06-01 18:01:46 UTC
I confirm the bug (on sci-physics/jaxodraw-2.0.1 ) and that the suggested solution works for me.
Please add it to the tree if it fulfills the standards!
Thank you!
Comment 5 Stefano Takekawa 2013-09-26 09:44:52 UTC
The fix works correctly. Thank you. Please commit to portage.
Comment 6 nooberwin 2014-02-16 03:11:57 UTC
Please commit this.
Comment 7 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-03-28 10:49:42 UTC
Hello, that fix has been committed.

+  28 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +jaxodraw-2.0.1-r1.ebuild,
+  -jaxodraw-2.0.1.ebuild:
+  Revision bump, adapt to new icon location and install desktop entry instead of
+  menu item; fixes bug #426756, this fix has been contributed by David Zaslavsky
+  (diazona).

Thank you for your contribution. Sorry for the delay, we're a bit undermanned.